So I downloaded many .tars (lame, faad, libmpeg, xvid...)* then extracted them passed on `--prefix flag` such that they were all neatly installed in respective /opt/bin, /opt/include, /opt/lib. Then I tested each executable & they were working fine. Some of them too were made symlinked in /usr/bin & everything worked fine.

*previously only faac was installed by default in /usr/bin

Now I don't want ffmpeg because back in windows I always used x264 syntax with custom patches a good example is

The problem while compiling x264 is that it doesn't recognize the newly installed audio codecs in /opt it only recognises the faac which previously was installed default to /usr I tried symlinking but x264 doesnt pick them up? Though I can access every function of executable properly from terminal?

    ./configure --enable-nonfree --enable-shared --disable-opencl --prefix=/opt
    fatal: Not a git repository (or any of the parent directories): .git
    fatal: Not a git repository (or any of the parent directories): .git
    platform:      X86
    system:        LINUX
    cli:           yes
    libx264:       internal
    shared:        yes
    static:        no
    asm:           yes
    interlaced:    yes
    avs:           no
    lavf:          no
    ffms:          no
    avi output:    no
    audio:         yes (raw, faac)
    gpl:           yes
    nonfree:       yes
    thread:        posix
    filters:       crop select_every hqdn3d pad vflip subtitles yadif
    debug:         no
    gprof:         no
    strip:         no
    LTO:           no
    PIC:           no
    visualize:     no
    bit depth:     8
    chroma format: all
    opencl:        no
as you can see only faac is picked up is there any method to direct x264 to know that it had to pick other libraries from /opt ?