VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    As per the thread title I'm having a really hard time with Encore seemingly having a mind of it's own when it comes to encoding my motion menu.

    The original source is a 1080i MPEG-2 file and an image overlay from Photoshop. I've put those together in a Premiere Pro project, no problem there. I import the .prproj file into encore and set it as the video and audio for my menu. Obviously the file needs to be re-encoded so I set it to what I want, 12Mbps VBR MPEG-2. I can go to File > Transcode now and that goes well, I can see in the temp files of my project there is an 80Mb M2V file and an AC3 file. In the assets menu the BR transcode status is now transcoded. Good.

    I go to build the Blu-Ray and Encore seems to encoding the file again. I don't know whether it's encoding the original Premiere project or the transcoded file but the output is a 166Mb file with the following properties:

    Video
    ID : 4113 (0x1011)
    Menu ID : 1 (0x1)
    Format : MPEG Video
    Format version : Version 2
    Format profile : Main@High
    Format settings, BVOP : Yes
    Format settings, Matrix : Default
    Format settings, GOP : M=3, N=12
    Codec ID : 2
    Duration : 54s 288ms
    Bit rate mode : Variable
    Bit rate : 24.2 Mbps
    Maximum bit rate : 30.0 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate : 29.970 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Interlaced
    Scan order : Top Field First
    Compression mode : Lossy
    Bits/(Pixel*Frame) : 0.390
    Stream size : 157 MiB (94%)

    Audio
    ID : 4352 (0x1100)
    Menu ID : 1 (0x1)
    Format : AC-3
    Format/Info : Audio Coding 3
    Mode extension : CM (complete main)
    Codec ID : 129
    Duration : 54s 368ms
    Bit rate mode : Constant
    Bit rate : 192 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Bit depth : 16 bits
    Compression mode : Lossy
    Delay relative to video : -67ms
    Stream size : 1.24 MiB (1%)
    I've also tried not doing the transcoding before building and letting it do it only during the build and the results are the same. I wouldn't worry about it but I'm very tight on space for my project, this would push it slightly over the size limit whereas my intended ~12Mbps version wouldn't. So why is Encore seemingly ignoring my chosen transcode settings and how can I change the settings it is encoding to? I can't see any transcode default that outputs 24.2Mbps/30Mbps max and the default settings are set at 15Mbps max.

    I had an idea of replacing the output 00002.m2ts file with the smaller one but then the menu links don't work.

    Any ideas? This is rather frustrating. I've done this before and don't recall ever having this issue.

    EDIT:
    Forgot to add I've also tried it the other way, encoding in Premiere and loading the M2V/AC3 file in Encore as Menu video/audio. Same result it re-encodes it to a 23.7Mbps VBR file.
    Last edited by Killer3737; 6th Oct 2012 at 23:19.
    Quote Quote  
  2. Member turk690's Avatar
    Join Date
    Jul 2003
    Location
    ON, Canada
    Search Comp PM
    This regularly and unpredictably happened to me with Premiere Pro CS5 when all I knew was to export (via AME) to MPEG2/4 streams with the requisite templates there. You would think that Encore would recognize and not encode again anything that came via PP/AME since both use the same templates & encoding engine (MainConcept).
    But it was the very poor results from having to rescale AVCHD HD material to SD to use for DVD that made me do my research & I have since figured out how to use x264 encoder (for MPEG4) and HCenc (for MPEG2), and various SD2HD and HD2SD avisynth scripts. While using these freeware encoders made the encoded quality difference I was very happy with (it was like night and day), I also did notice that Encore now immediately accepts the streams I submitted to it (*.264, *.m2v, *.ac3) in a snap & now always offered the option of 'do not encode', making creating a blu-ray *.iso file with all the requisite streams finished in 5mins or less.
    I pour all of the available space to the program material as much as I can so I only ever use static menus. Separately, I have been told Encore likes to re-encode menus all to MPEG2 so this may partially account for what you are experiencing.
    Last edited by turk690; 7th Oct 2012 at 08:44.
    For the nth time, with the possible exception of certain Intel processors, I don't have/ever owned anything whose name starts with "i".
    Quote Quote  
  3. Member
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Maybe I wasn't clear enough, the video I'm exporting from Premiere Pro needs encoding, it's a motion menu created from a video source and photoshop layers. I know that's got to happen, the issue is whether I encode it with Premiere Pro and import the M2V/AC3 as menu assets (BR legal, marked as Don't Transcode) or import the Premiere Pro timeline and let the encoding be done in Encore, Encore has it's own ideas and will always output the menu at 23Mbps VBR 1080i MPEG-2. I've tried various methods, set everything to be the lower bitrate I want but Encore won't budge, it's determinied to encode my menus in that quality.

    I just want them to be the bitrate I select.
    Quote Quote  
  4. Member turk690's Avatar
    Join Date
    Jul 2003
    Location
    ON, Canada
    Search Comp PM
    The common thing in Adobe Premiere Pro/Media Encoder and Encore is the encoding engine MainConcept, which has been described as so-so on one end to downright despicable on the other. It is this engine that does the actual encodes. Try NOT to encode within Premiere Pro with any of the export templates (at least for video). The thing to do is to frameserve: one of the best is DebugMode Frameserver. Download and install this, and it becomes a preset under export template 'Microsoft AVI'. Debugmode creates what is called a signpost *.avi file, which you then include in any typical avisynth script. This script is just a text file, but should be named *.avs, which you then submit to x264 or HCenc encoders via any of the multitude of front end GUIs available for them. x264 (for MPEG4) and HCenc (for MPEG2) runs circles around anything MainConcept can produce, and paradoxically, the resulting elementary streams are much more likely to be accepted without fuss by Encore and not re-encoded. Encore can be unpredictable: I swear on one occasion I gave it an elementary stream *.m2v that it accepted and didn't re-encode (encoded with sweaty AME/MainConcept). The next time around on a separate project, it insisted on re-encoding the very same wretched file, even though there was still gobs of space on the DVD.
    How to install and use x264 & HCenc and a suitable GUI, together with avisynth and DebugMode, is a whole other topic that you can research starting from this site. I once dragged my feet about this, preferring to do everything with Premiere & Encore in situ because I am used to Premiere since v5c (not Pro). I tried using Sony Vegas & Architect but for some reason always came back to Adobe, so I had to acknowledge and figure out how to work around the quirkiness and petulance of AME & Encore as it is.
    The GUI is use for x264, for example, is 'Simple x264 Launcher'. There are enough options in there for you to set all the bitrates you want.
    If, after using other encoders, Encore still insists on re-encoding your motion menu, first be clear what legal streams can be used for BD menus. Maybe you can try to export to MPEG4 (*.m4v or *.264).
    For the nth time, with the possible exception of certain Intel processors, I don't have/ever owned anything whose name starts with "i".
    Quote Quote  
  5. Member
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Ok I'm re-editing this post a lot but better than double posts.

    It seems that Encore (Well, CS5.1 at least) always builds Blu Ray menus to 25Mbps VBR MPEG-2 and there is no normal way to override that. There is a hack way though that seems to work:

    1. Encode the motion menu asset to whatever bitrate you want in whatever program you want as long as it's Blu Ray legal overall.

    2. Complete your project and set the above file as your menu asset and build the project. Encore will proceed to re-encode your file to 25Mbps VBR MPEG-2. Save the Encore project and close Encore.

    3. Open the temp folder loction, <project name>/Sources/Menus/ and you'll see the re-encoded menu asset. Put the original M2V from step 1 in this folder as well.

    4. Open <project>/ProjectMedia.acx with a text editor and search for the re-encoded m2v file. Edit that so it points to your original M2V instead and edit the filesize so it matches your original file instead.

    5. Re-open your Encore project and rebuild. This time it should use your original M2V instead of the bloated 25Mbps MPEG-2 version.

    Just posting the solution in case anyone else has the same issues I have.
    Last edited by Killer3737; 7th Oct 2012 at 20:30.
    Quote Quote  



Similar Threads