VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Hi,


    I'm trying retrive the paraters required to play this video: http://www.lightreading.com/video.asp?doc_id=129576

    I managed to get them with rtmpExplorer (or wireShark or streamTransport) but when I pass to rtmpDump the download fails.
    Can somone shed some light on why this might happen?

    Parameters found:
    Code:
    rtmpdump -r "rtmp://brightcove-60.fcod.llnwd.net:1935/a500/e1/uds/rtmp/ondemand?
    videoId=9453696001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId
    =" -a "a500/e1/uds/rtmp/ondemand?videoId=9453696001&lineUpId=&pubId=1568176135&p
    layerId=1791339103001&affiliateId=" -f "WIN 11,4,402,265" -W "http://admin.brigh
    tcove.com/viewer/us20120928.1313/federatedVideoUI/BrightcovePlayer.swf?uid=13491
    86816669" -p "http://www.lightreading.com/video.asp?doc_id=129576" -C B:0 -C S:1
    568176135/1568176135_9458825001_129576-01-768K&1349193600000&b3b2fc4b5b0bae7fd2c
    d30e43322059f -y "1568176135/1568176135_9458825001_129576-01-768K?videoId=945369
    6001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId=" -o 15681761
    35_9458825001_129576-01-768K.flv

    Any help will be appreciated.

    Tzahi
    Quote Quote  
  2. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by Tzahi.Zohar View Post
    ... but when I pass to rtmpDump the download fails.
    Can somone shed some light on why this might happen?
    Hi
    See in your command where it says:-
    Code:
    -C S:......129576-01-768K.....
    It works for me if I put that part in quotes ""
    -C S:"......129576-01-768K....."
    I think it's because of the hyphens in 129576-01-768K

    Code:
    @ubuntu:~$ rtmpdump -r "rtmp://brightcove-60.fcod.llnwd.net:1935/a500/e1/uds/rtmp/ondemand?videoId=9453696001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId=" -a "a500/e1/uds/rtmp/ondemand?videoId=9453696001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId=" -f "LNX 10,1,102,64" -W "http://admin.brightcove.com/viewer/us20120928.1313/federatedVideoUI/BrightcovePlayer.swf?uid=1349189963141" -p "http://www.lightreading.com/video.asp?doc_id=129576" -C B:0 -C S:"1568176135/1568176135_9458825001_129576-01-768K&1349197200000&fdb7f927321cff629e1a7f640d3aa3e1" -y "1568176135/1568176135_9458825001_129576-01-768K?videoId=9453696001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId=" -o 1568176135_9458825001_129576-01-768K.flv
    RTMPDump v2.4 e0056c5
    (c) 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
    Connecting ...
    INFO: Connected...
    Starting download at: 0.000 kB
    INFO: Metadata:
    INFO:   duration              387.07
    INFO:   lasttimestamp         387.07
    INFO:   datasize              11741479.00
    INFO:   metadatacreator       FlixEngineLinux_8.0.11.0 (www.on2.com)
    INFO:   canSeekToEnd          0.00
    INFO:   videocodecid          4.00
    INFO:   width                 480.00
    INFO:   height                270.00
    INFO:   videodatarate         190.60
    INFO:   framerate             30.00
    INFO:   videosize             9443278.00
    INFO:   audiocodecid          2.00
    INFO:   audiodatarate         46.39
    INFO:   audiosize             2298201.00
    11888.790 kB / 387.07 sec (100.0%)
    Download complete
    Quote Quote  
  3. Hi,


    Thx for the replay.
    Actually, this is still not working for me.
    Can you paste what has worked for you?

    BTW, I saw you're using ubunto, I know there shouldn't be any affect but I'm using windows...


    Thx.
    Quote Quote  
  4. This is working for me at present:

    Code:
    rtmpdump -r "rtmp://brightcove-60.fcod.llnwd.net:1935/a500/e1/uds/rtmp/ondemand" -a "a500/e1/uds/rtmp/ondemand?videoId=9453696001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId=" -f "WIN 11,4,402,265" -W "http://admin.brightcove.com/viewer/us20120928.1313/federatedVideoUI/BrightcovePlayer.swf" -p "http://www.lightreading.com/video.asp?doc_id=129576" -C B:0 -C S:"1568176135/1568176135_9458825001_129576-01-768K&1349269200000&1907cca3055bc3e128adc9453cef9502" -y "1568176135/1568176135_9458825001_129576-01-768K?videoId=9453696001&lineUpId=&pubId=1568176135&playerId=1791339103001&affiliateId=" -o "03-10-14_12-35-42_1568176135_9458825001_129576-01-768K.flv"
    Put parameter strings into quotes or the CLI will have trouble parsing them, also the connect data -C S:"param" seems to change or expire, you'll probably need to get a fresh one. The one I grabbed today connects but yours from yesterday won't.

    Or just put RtmpDumpHelper into same folder as RtmpDump, it's easier.
    Last edited by Chug a Bug; 3rd Oct 2012 at 07:58.
    Quote Quote  
  5. Thanks excellent, Thanks!
    Quote Quote  



Similar Threads