VideoHelp Forum

+ Reply to Thread
Results 1 to 20 of 20
Thread
  1. I've been trying to burn some .mkv's onto a dvd with .ass subtitles. (Weird file name, yeah...) This is what I did.


    Programs:

    MKVtoolnix
    MKVextractGUI2
    MKVmergeGUI
    Note: The gui is the graphical user interface, a template to put it in easier terms, not the program itself.
    AviDemux
    DVDStyler


    Instructions:
    1. Open MKVextractGUI2. Extract audio, video, subtitles, .ttf attachments.
    2. Install all .ttf files. These are the fonts. This is important so that the subtitles look identical to the original.
    3. Merge audio, video. Check AAC is SBR/HE-AAC/AAC+. Rename if you like. (I merged the audio and video together and left the subtitles seperate in order to add the subtitles later in AviDemux because if I do that in DVDStyler the subtitles aren't exactly the same as the original mkv because there were different fonts in the subtitles.)
    4. Open AviDemux. Import file. H.264 detected, click no. Index, click yes.
    5. Auto>Optical Disk>DVD 16:9 16:9 (I'm going to be watching this on those new widescreen tvs.)
    6. Video>Filters>Subtitles + Remove Black borders. Remove Resize. (I don't like black borders although I even tried this without the borders and I still had the problem.)
    7. Audio>AC3 (lav) (DVD audio so I picked it.)
    8. File>Save>Save Video.
    9. Open DVDStyler.
    10. Edit the DVD menu however you like.
    11. DVD>Options> This is where you change the DVD Label, Video Format, Aspect Ratio, Audio Format. NTSC is for the United States, PAL is for Europe. Very important because if you pick the wrong one it will not play on your DVD Player.
    12. Right-click Menu>Properties>Video Object>Audio This is the background music for your menu.
    13. Right next to that in that same bar you can right-click>Add>File. There you can add the video you want on your dvd.
    14. Right-click Title>Properties>Check do not remultiplex/transcode. Very important Also check that everything is correct. (Checked this because I heard if you don't it's like converting it a second time which could result in low quality.)
    15. File>Burn DVD Check Preview to see a preview of the DVD before burning Choose Burn from the three choices and Speed auto unless you know your speed Then click Start
    16. Before it burns the DVD it will show you a preview in Windows Media Player and it will ask you to burn the DVD. Watch the preview if you checked preview then when you're ready click Yes to burn the DVD. (In the preview everything looks fine but that's not where the trouble starts.)
    17. Done. Enjoy. (Lol I thought I finally got it and was going to finally enjoy my DVD.)

    Okay here's the problem: When I play the DVD no matter what I've tried black borders no black borders mplayer resize no resize the subtitles are so low that any lower and they'll be cut even width wise too like any longer and they'll be cut on the sides too. Also at the very top I have subtitles and same problem more or less like any higher and it will be cut and stuff. How do I fix this because I really don't want my subtitles on the very edges slightly cut?

    Please help. I've been trying to do this for a long time and I finally got the subtitles to look exactly like the original mkv now the problem is position. I'd really appreciate it.
    -Mamimi

    Also, I forgot to add, the reason why I'm using DVDStyler is because it is the best freeware for custom DVD menus and when I say custom I really mean custom. You can pretty much do anything except the subtitles are only 1 font and 1 position, the previews in the chapter menu are only still pictures not video, and the buttons well they have quite a few to choose from but to make your own that's a very hard task that I guess if you really know you could take on but not me I'll stay with the buttons provided. Finally, the guide above is a guide I made on my own so I know it needs some tweaking which is why I'm here...And wow I forgot well the video after converting looks fine on the computer as do the subtitles and everything but on the DVD it looks kind of slow. I think it's because the nominal bitrate is 8,000 Kbps and at 60 frames per second, possibly too high for the DVD player, and the original is about ~ 24 frames per second.


    DVDStyler


    WARN: not a valid DVD frame rate: 0x01
    WARN: attempt to update frame rate from 30000.0/1001.0 (NTSC VIDEO) to 24000.0/1001.0 (NTSC 3:2 pulldown converted FILM); skipping

    WARN: attempt to update resolution from 704xfull to 720xfull; skipping

    WARN: attempt to update aspect ratio from 16:9 to 4:3; skipping
    Last edited by Mamimi; 1st Sep 2012 at 00:21.
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Have you tried adjust the ass subtitle position with for example aegisub? Then load in avidemux.
    Quote Quote  
  3. Wow that's a great idea! I wish I thought of that myself. Thank you ...Well the subtitle problem should be fixed now but I noticed that the video itself gets cut a little bit when I played it in the DVD player. I don't want anything getting cut because the opening subs are hardsubed and I'm definitely 100% sure the slowness is caused by some settings, not the DVD player, but idk what though. I'm still thinking what I said earlier, "I think it's because the nominal bitrate is 8,000 Kbps and at 60 frames per second, possibly too high for the DVD player, and the original is about ~ 24 frames per second" and I think DVDStyler gives me warnings because it is trying to fix the wrong conversion but it can't because I checked do not remultiplex/transcode but I heard if you don't check that it converts it again and it's only good to convert once because the more you convert the lower the quality will be. So pretty much now all I need are the correct settings to make my .mpeg's for the DVD in AviDemux and I think that will stop the errors in DVDStyler.

    Also if this helps, I'm using a Toshiba SD-2600 DVD Player and a Samsung LN22B460B2D 720p TV that's 20" I think. I'm not exactly sure. :/...And I even tried changing the zoom on the DVD player to shrink and without black borders and the mplayer resize it shows everything in the video but of course when you view it shrinked you have black borders all around and I don't want to watch it that way, then I tried with the black borders and mplayer resize I think and even in the shrink it cuts video a little bit, and then I tried mplayer resize only or I'm not even sure. I've been trying to many times that I forget but none of them are good. The original resolution is 704x480. I've been trying for 2 weeks already and when it isn't one thing it's the other.

    Curse you Samsung TV not letting me choose screen fit to fix overscan! Lol idk where I got that from probably too much cartoons as a kid or something but I guess better than saying something else. Anyways...I've came to the conclusion that this may be an overscan issue along with the converting and the 8,000 Kbps @60 fps when it's supposed to be about ~ 24 fps.
    ---
    Originally Posted by Mamimi View Post
    Originally Posted by FulciLives View Post
    OK you said you have MKV files that are 704x480 but you didn't say if they are 4:3 or 16x9

    SolveigMM AVI Trimmer + MKV is a great free program that will let you cut out a section from a MKV and I suggest you do that and then put it on some file hosting site (for instance SendSpace or MediaFire or Ubuntu One) and post the link here. That way I can download it and have something to work with. It doesn't have to be long. 30 - 60 seconds is more than long enough.

    - John "FulciLives" Coleman

    P.S.
    Maybe you should do it in that other thread you started rather than do it here.
    Omg true I forgot that part. The display aspect ratio 4:3 in the original mkv and in the mpeg conversion but 3:2 after I extract the audio video and subtitles and merge the audio and video together so that I can then add the subtitles to it when I convert it in AviDemux. I want to play it on a widescreen 16:9 TV. True that too. I'll continue this in the other thread then.
    Sending the video that is the one I merged without the subtitles because when I convert it in AviDemux that's when I will add them.
    Last edited by Mamimi; 1st Sep 2012 at 00:06. Reason: DVD Brand, TV Brand, Overscan, Bitrate, Fps
    Quote Quote  
  4. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    OK I got the two clips you sent me BUT the subtitles aren't burned into the clips. If I understand your issue it's with the subtitles getting cut off but the subtitles must be soft subtitles which means when you add them in you can do it so they are not "too low" on the image, thus avoiding the need to fix over scan UNLESS you are that anal about slicing off the image a tad bit.

    Anyway I put it in FitCD with the following setting:



    This would give an image like this:



    Now I left it in a 4:3 or "full frame" ratio (as per the original) but you could make it 16x9 WS but really that doesn't gain you anything. This will look proper on a 4:3 TV as well as a 16x9 TV as long as you have the 16x9 TV set to display 4:3 without stretching it or resizing it and all 16x9 WS TV's have that option.

    But if you really wanted to make it 16x9 WS then you would do this in FitCD:



    It would look like this:



    The only real benefit of doing it 16x9 WS is that the aspect ratio will always be correct on a 16x9 WS TV (although it will look ugly on a 4:3 TV) but the point is with a 16x9 WS TV it is more "fool proof" in that people can't accidentally stretch it to fit etc.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  5. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    The next question is ... if the subtitles are separate then what form are they in. For instance are they SRT or SSA or ASS or what?

    Do you want to burn them into the image or make them soft subtitles (on the DVD Video you will be making)?
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  6. Omg I'm so stupid...Now I get it! That program generates a script in which you feed to the encoder and then it encodes the video with the right settings.

    The only part of the video that is hardsubbed is the intro music lyrics but that's it. The subtitles from the mkv are .ass Well I had them separate in one that I sent you and the other was the original mkv with the subtitles in it since I didn't know which one to send you. It would be great if I could make them soft subtitles on the DVD because that way I can toggle them on and off and in this case I don't need to but I just want to learn for future DVD's.

    The only problem now is I'm getting errors trying to use avisynth scripts from FitCD to AviDemux. I'll explain more later I guess since I'm leaving and I have no time at the moment. Thank you so much so far. It looks epic.
    Quote Quote  
  7. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Well I normally do my MPEG-2 DVD encoding with HCenc which is a free MPEG-2 encoder that (despite being free) is probably the best one out there (other than maybe CCE but that isn't free and the two are so close in quality output you might as well use the free HCenc instead).

    Anyway HCenc works with AviSynth input so I guess I am saying you should just use that program for your encoding instead of AviDemux.

    I know I mentioned this in a PM to you but just to say it in the thread (for people reading this) you can also use AVStoDVD which is an "all in one" program for encoding video and audio. It uses AviSynth and HCenc and you can edit the script so you can force it to use the resize values that FitCD gives you while otherwise relying on it to properly set up the script and the setting in HCenc etc. plus it supports subtitle input. In short using it will make your life easy (knock on wood).
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  8. In FitCD under ITU-R BT.601-4 where it says round to 4, 2 Real aspect for me it says 2 but in the picture I see you put it to 4 and where it says next to that round to: 16 16 = macroblock optimized you put 8 = block optimized instead...Idk if that matters or what it does so I decided just to put exactly what you did.

    What settings did you use in HCenc? Because all I did was load the .avs file I got from FitCD and I clicked make DVD compliant but the .mpeg I got has no audio.

    Using FitCD with AviSynth and HCenc is almost fool proof. Another thing though is that the subtitles in the .mpeg are hardsubbed which isn't really a problem with this video but in the future I want to make .mpeg's to burn to DVD that have dual audio and soft subs so I guess I'll try AVStoDVD 250 Alpha because like you said in a message it was giving trouble with the subtitles.

    To AVStoDVD! Lol. Opened the .avs file but it didn't load the subtitles so I extracted them and added it. DVD Size> DVD-5 (4.7 GB) Correct...Output>Muxed MPEG2 File...Hmm...Everything looks good I guess. I wouldn't know if I'd have to make any changes in the Preferences or not so I guess I'll just click Start...Wrong lol it Opened QuEnc. Preferences>Video>HCenc VBR 2-pass. Higher Bitrate Level, Lower Bitrate Level are left as the defaults since idk and the same with Higher Avg Bitrate and Lower Avg Bitrate. Checked Save Current Preferences as Default and Ok...No! Still Opens QuEnc. I tried clicking the lock icon too to see if that works but I think that may have ruined the settings since it even says not recommended.

    Tell me what settings you used in AVStoDVD please because that would be the easiest way to do this because I want to see if it will give me an .mpeg with soft subtitles.
    Quote Quote  
  9. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    HCenc doesn't do audio. It only does video. You have to do the audio separately. You also have to adjut the settings in HCenc in regards to the bitrate and a whole bunch of other settings. There are guides on how to do all this and without writing up a whole new guide myself there is no quick and simple answer. It's not hard mind you but you should read a guide.

    With AVStoDVD you have to select your input and there are options for changing which encoder you use. So you click on the imported video AFTER importing it to get to those options. One of the options is to edit the AviSynth script, allowing you to adjust the numbers if you want overscan (you'll have to use FitCD, copy the numbers from it, and change the script in AVStoDVD).

    You can play around with the numbers at the bottom of FitCD if you want. If you change them you'll see the changes it makes.

    A lot of video encoding is just playing around with the programs and doing multiple encodes until you "get the hang" of it.

    *** EDIT ***
    I forgot to mention that with AVStoDVD you have the option to burn in the subs or make them regular normal DVD subs that can be turned on and off. However if the subs are highly stylized, as is the case with many anime subs, you are better off burning them in.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  10. Omg lmao I got a 1.40 GB .mpeg with speed up mouse audio, 29.970 fps.
    I don't mind creating a guide as long as it's correct though that way I can make it easier for people and if I ever forget I can always go back to it.

    1. Open FitCD>Open Source Video
    2. Copy Settings>Save Script
    3. Open AVStoDVD>Output Muxed MPEG2 File
    4. Add Title>Add AVS Script
    5. Right-click Title 1>Subtitles>Add Subtitles
    • Use Mkvtoolnix>mkvextractGUI2 to extract the subtitles if you don't already have them.
    6. Right-click Title 1>Edit Title
    • Video>Uncheck Auto Video Setup & Auto BitRate Calculation
      Go here: Bitrate Calculator & Input your bitrate in the Video Avg BitRate
      There's a How to below on that page but incase to clarify any confusion that may occur if you're burning let's say 6 episodes onto 1 DVD-5 (4.7GB) then you need to add all the hours, minutes, and seconds then put the total in there. Audio bitrate I left as 448, Type is left as DVD, and the Calculated Bitrate is what you put in the Video Avg BitRate.
    • Audio>Uncheck Auto Audio Setup
      Mediainfo>Channels. If it says 2 put 2.0 in AVStoDVD. (Thought this would fix the audio too.)
      Change the Audio Language if you want.
      Uncheck Auto Delay Audio (Had this checked first time but this time I'm unchecking to see if maybe this is what ruined the audio.)
    • Subtitles>Uncheck Auto Subtitles Setup
      Check Hard Encoded if you want hardsubtitles.
    • AviSynth>Uncheck Auto AviSynth Script
    • Chapters>Change if you want or leave as is. I'll leave as is.
    7. Press Ok.
    8. Next click Start, and then Ok.

    Nope I guess it doesn't like when I Uncheck Auto Delay Audio because I got an error.

    Warning! Errors found during Title 1 Audio Track 1 encoding. Do you want to start backup audio encoding routine(FFmpeg based)?>Yes
    ffmpeg cmd prompt opened
    Process completed successfully!>Close

    Okay nope great still mouse audio until it ends and then no audio. File size came out good this time though, 740MB. 29.970 fps, I don't think that will work on my DVD player. Idk why it increased the fps a little bit when it was fine as it was ~ 24fps.

    I wrote the steps incase it comes out right this time I guess for my own little guide but nope still bad.

    Tried again using these settings:
    aften padding 1
    checked auto delay audio
    Still error, still bad sound.
    Quote Quote  
  11. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    AVStoDVD seems like a great program but it was giving me a lot of headaches with the audio. Seems to be a bug with Windows 7 (maybe also Vista) but not other versions. However I got the impression that it doesn't affect everyone on Windows 7.

    I couldn't get the audio to work though even after doing some suggested 'things' to fix it.

    The work around is that you encode the audio to AC-3 ahead of time and when you import it the program sees that you have DVD compliant AC-3 and will not re-encode.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  12. Damn that sucks. This is like converting hell. I'm using Windows 7 also.
    Going to try this method but in my own way:
    How to encode an Avi to dvd ready video and audio Using HCenc and Aften

    This guide shows you how to encode an .mkv into an .mpeg-2 with .ac3 audio ready for DVD.

    AviSynth 2.5.8
    mkvextractgui2
    MediaInfo
    MeGUI_2153_x86
    FitCD
    AVStoDVD Alpha 250

    AUDIO:
    1. Open mkvextractgui2. Extract the audio stream and subtitles.
    2. Open MediaInfo. Open audio stream. Sampling rate: 48.0 KHz. Lucky for me that's fine.
    If your rate is 48000Hz then you are ready to encode to ac3 if not then you need to resample.
    I think MeGUI can solve the Hz problem though incase you have a different number.
    3. Open MeGUI. Open Audio Input.
    Encoder settings>Aften AC-3: Aften - DVD - Good
    Click Queue. Go to Output directory to check audio and done.
    Yes!!!!!!!!!! Thank you MeGUI. That's for the audio, now to the video.

    VIDEO:
    1. Open FitCD>Open Source Video
    2. Copy Settings>Change 160 kbps Audio1 to 448>Save Script
    3. Open AVStoDVD>Output Muxed MPEG2 File
    4. Add Title>Add AVS Script
    5. Right-click>Title 1>Audio Track>Remove Audio Track and Add the AC3 audio track you made in MeGUI.
    6. Right-click Title 1>Subtitles>Add Subtitles
    • Use Mkvtoolnix>mkvextractGUI2 to extract the subtitles if you don't already have them.
    7. Right-click Title 1>Edit Title
    • Video>Uncheck Auto Video Setup & Auto BitRate Calculation
      Go here: Bitrate Calculator & Input your bitrate in the Video Avg BitRate
      There's a How to below on that page but incase to clarify any confusion that may occur if you're burning let's say 6 episodes onto 1 DVD-5 (4.7GB) then you need to add all the hours, minutes, and seconds then put the total in there. Audio bitrate I left as 448, Type is left as DVD, and the Calculated Bitrate is what you put in the Video Avg BitRate.
      (Only writing this for my own personal notes -> 24.09 + 24.09 + 24.08 + 24.09 + 24.09 + 24.23 = 144.67 = 145.07 = 2.25.07 = Calculated Bitrate 3744 kbit/s)
    • Audio>Uncheck Auto Audio Setup
      Change the Audio Language if you want.
      Uncheck Auto Delay Audio (Had this checked first time but this time I'm unchecking to see if maybe this is what ruined the audio.)
    • Subtitles>Uncheck Auto Subtitles Setup
      Check Hard Encoded if you want hardsubtitles.
    • AviSynth>Uncheck Auto AviSynth Script. I think if you don't uncheck this it won't use the script from FitCD and give errors.
    • Chapters>Change if you want or leave as is. I'll leave as is.
    8. Press Ok.
    9. Next click Start, and then Ok.
    Quote Quote  
  13. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Well you can use the auto bitrate function of AVStoDVD but it all depends on what you are doing. If you add one video that will be a whole disc (or multiple videos that will be the whole disc) then you can probably go with it's auto settings, although I'm not sure exactly how much it leaves over for authoring. If you use it for authoring (or another simple method that won't increase the space much) then it's probably safe. If you plan on using a program that let's you get crazy creative with the menu and you want to add motion menu's etc. then you may need to calc the bitrate yourself.

    I don't use MeGUI but if it works for you that's great. Another program I like to use that can do just audio (but also video and audio) is XVID4PSP and again I use this often to input a video just so I can encode the audio. You can pass the video through and output a new file (with the same video yet a new audio file) or just output a new audio file. It's a very handy program. Just one example: I use it to import a MP4 file with H.264 video and AAC audio and have it output a M2TS file with the same video (untouched) and new AC-3 audio.

    Anyway it seems like you finally got a chain of programs now to do what you want
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  14. So close yet so far away! I almost had it but HCenc gives me errors.

    Probably this is the problem: Change 160 kbps Audio1 to 448. I'm going to try again but without changing that since you told me that doesn't matter.
    Nope. Tried that and still the same thing.
    Now I'm going to try HCenc seperate because I remember that worked instead of AVStoDVD.
    Changed the average bitrate and click the make DVD compliant button.
    I think it might be because AVStoDVD is using HCenc 0.26 beta and the one I have separate is version 0.25.
    .m2v? Opps...I think I was supposed to go to output and save it as .mpeg
    ...Or better yet I'll just go to the directory and replace 0.26 with 0.25 and see if that works.
    Quote Quote  
  15. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Read a guide on using HCenc ... you have to do more than just click "make DVD compliant"

    I've only used 0.25 so far but I'm sure 0.26 is fine (I didn't even know it was out).

    Don't change it to MPEG because it only does video and you'll need it as a M2V ... you can mux it with your audio using ImagoMPEG-Muxer (which gives you a MPEG file) but you shouldn't make it a MPEG file when it is just a video file.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  16. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Here is how I set up HCenc



    I'll try to explain briefly:

    Profile: Always pick BEST

    dc prec: My understanding is that for a DVD you should always pick 9 unless it is very short and the bitrate is very high then you can pick 10 (I always just use 9 myself)

    aspect ratio: You should pick 4:3 or 16:9 according to your source

    miscellaneous: My settings here are proper for a progressive NTSC source. The settings are different if you have an interlaced NTSC source or a PAL source. The only change here you MAY wish to make is the "closed gop" option. I like to use "closed gop" but that is not actually recommended but it is something I prefer. It really doesn't matter either way but supposedly you get better compression without using it (which means you do NOT checkmark it). Otherwise mimic the options here (again if you have progressive NTSC input).

    I assume you know to pick "average bitrate" and how to set your bitrate (it seems from other posts that you do understand this)

    Again, for a progressive NTSC input, that really is all you need to change.

    The only other thing I change is on the SETTINGS 2 tab:



    I believe the default for "luminance gain" is 0 but I set it to 1 but I doubt it makes a big difference with most sources. My understanding (and I'm not actually 100% on this) but as I understand it the darker the movie is in total (or the more the dark scenes) the more you want to move this towards 4 but I just always leave it at 1 *shrugs*

    That's it.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  17. Using FitCD
    I guess this answers my question about the FitCD sliders...well if I understood it. So the 2 sliders on the left are the height and width, x and y...Then the other slider is...something with the resolution...

    ImagoMPEG-Muxer, Yeah that program looks familiar since it's bundled with AVStoDVD. Pretty straight forward.

    Now the problem is getting it all to fit on the DVD in DVDStyler. ;_;
    Configurations>Settings>Core>Frame count of menu: 24, Menu video bitrate: 2533, Slideshow video bitrate: 2533. I guess I didn't use the bitrate calculator correctly because I had to lower this to that number but I think it should be fine because my menu backgrounds are just using images.
    Okay nope...
    Disc size: 4488 MB
    ISO Size: 4504 MB
    Changing the Menu video bitrate & Slideshow video bitrate to 2433.
    Weird...Another thing I checked is the mpeg files I got from muxing and everything. I checked them in MediaInfo and the Bit rate says 3 760 Kbps when I know I put it to be 3744.
    Nope still...
    Disc size: 4488 MB
    ISO Size: 4504 MB
    Changing the Menu video bitrate & Slideshow video bitrate to 1533.
    No...
    Disc size: 4488 MB
    ISO Size: 4498 MB
    Changing the Menu video bitrate & Slideshow video bitrate to 533.
    Maybe it's because I added an mp3 to the main and title menu.
    Cool well it burns with the 533 bitrate.
    So now I can burn DVD's but with bad custom menu's that have 448 audio I think...Or probably the Menu & Slideshow bitrate don't even matter because the backgrounds are all images.
    Oh wow ISO...So that was what I was supposed to change I assume but how would I even get the right ISO number? O.o

    The DVD came out good, has hardsubs, but I think I needed to move the far right slider to 1 = no optimization because there's a tiny piece of black on the left and right sides of the video. With DVDStyler you can make it WS 16:9 without it looking like they're fat. Idk how it does it but it does because everything I put 4:3 except DVDStyler and the picture came out great. Actually I think I'll just change the overscan to 1 and see what happens.
    Quote Quote  
  18. I finally got this thing to work perfectly and I'm really happy with the results so I'll share my guide incase anyone else runs into the same problems. Finally, here's my guide! Thank you FulciLives for all the help, suggestions, and settings which ultimately helped me create this guide.

    This guide shows you how to encode an .mkv into an elementary .m2v(video) and .ac3(audio), mux them into an .mpg(mpeg-2), and then burn them with a custom DVD menu.

    AviSynth 2.5.8
    MKVtoolnix
    mkvextractGUI2
    Aegisub
    MediaInfo
    MeGUI_2153_x86
    FitCD
    HCgui_025
    ImagoMPEG-Muxer
    DVDStyler

    HARD SUBTITLES:
    1. Open mkvextractGUI2. Extract the audio, video, subtitles, and all font attachments.
    2. Install all fonts, if not your fonts won't match later I think. If no .ttf files appear after you've extracted them it may be because you already have them installed. Check Control Panel\Appearance and Personalization\Fonts.
    3. Open Aegisub. File>Open Subtitles. Video>Open Video.
    4. Go to the pink S in the toolbar below the file menu and click on it to open the Styles Manager. Here you will see a list of subtitles if your subtitle track has more than one if that makes any sense in the Current script section.
    For the different characters in your anime, unless it only shows one, click on that and in Margins make sure it is set to Left 30, Right 30, Vert 30. Then click okay. This applies to all the subtitles which will appear at the bottom.
    If there is one that says notes then click on that one also and in Margins put Left 30, Right 30, Vert 20 if it isn't there already. Then click okay. This applies to all the subtitles which will appear at the top of the screen.
    Also, if you'd like to change the font size then change that too.
    Any subtitles that say FO or Title will remain as is.
    After all of that is done click Close.
    You may also want to press Ctrl+F to search for all the \N's to see if you like how it will show up on the final video. For any change you may make with the \N's or whatever you chose in the box you need to click the Commit button to save it. Also check for {\fs because this tag can change the font. That is what was causing me to have some subtitles still too small even after I did the changes in the Styles Manager (S).
    This part applies to subtitle changes.
    After all changes are made. File>Save Subtitles.
    5. Open mkvmergeGUI. Add your audio, video, and your new edited subtitles.
    You may have to check AAC is SBR/HE-AAC/AAC+ because when I did it it gave me an error and said to check it so I did.

    AUDIO:
    1. Make sure you still have the audio you extracted from your original mkv because this will be used in this step.
    2. Open MediaInfo. Open audio stream. Sampling rate: 48.0 KHz. (Lucky for me that's fine.)
    If your rate is 48000Hz then you are ready to encode to ac3 if not then you need to resample but MeGUI will fix this for you.
    3. Open MeGUI. Open Audio Input.
    Encoder settings>Aften AC-3: Aften - DVD - Good
    Click Queue. Go to Output directory to check audio and done.
    Yes!!!!!!!!!! Thank you MeGUI. That's for the audio, now to the video.

    VIDEO:
    1. Open FitCD>Open Source Video
    ***Very important, if you edited your subtitles then you need to open the mkv that you muxed with mkvmergeGUI because if not your subtitles will come out as the original, unedited.
    2. Copy Settings>Save Script
    In my case overscan 2 was slightly too much so I just put it to overscan 1. It all depends on your tv though so you maybe have to test that out when you play the DVD.
    3. Open HCgui_025>Input>Add AVS Script
    Output>YourFileName.m2v
    Log>YourFileName.log
    4. Average Bitrate: Use the Bitrate Calculator & then your Calculated Bitrate goes here.
    There's a How to below on that page but incase to clarify any confusion that may occur if you're burning let's say 6 episodes onto 1 DVD-5 (4.7GB) then you need to add all the hours, minutes, and seconds then put the total in there. Audio bitrate I changed to 448, Type is left as DVD, and the Calculated Bitrate is your Average Bitrate.
    (Writing this part for my notes-> 24.09 + 24.09 + 24.08 + 24.09 + 24.09 + 24.23 = 144.67 = 145.07 = 2.25.07)
    Advanced Mode>ISO 200 MB
    This setting is tricky. It depends on if you will be adding a DVD menu and since there was no way to calculate the DVD menu size or at least for me that I may not be aware of I had to change this a couple of times.
    The ISO size I chose is for a menu video bitrate of 3000 and a slideshow video bitrate of 3000. I think for a higher menu bitrate you need a higher ISO but I think 3000 should be just fine since my background is only a picture. (I know this will show up twice but I figured I'd write it up here too incase so that it's not too late to change it.)
    5. Profile>Best
    6. Aspect Ratio>4:3 in this case but change it to your video.
    7. Click make DVD Compliant
    8. (Optional) Settings 2>luminance gain
    I don't know much about this one and my video isn't dark so I'll leave it at default, 0, change if you like.
    I believe the default for "luminance gain" is 0 but I set it to 1 but I doubt it makes a big difference with most sources. My understanding (and I'm not actually 100% on this) but as I understand it the darker the movie is in total (or the more the dark scenes) the more you want to move this towards 4 but I just always leave it at 1.
    9. Encode.

    MUX:
    1. Open ImagoMPEG-Muxer.
    2. Select Video Source>Your.m2v
    Next to this it says 720x480 30.0fps 4:3, but when I opened MediaInfo and checked the muxed .mpg's frame rate it says 23.976 fps so just ignore that and check with MediaInfo because for DVD the frame rate has to be about ~ 24 or else you'll get slow video...At least that's what I think was causing that problem for me.
    3. Add Audio Source>Your.ac3
    4. Select Output Path> Wherever you want.
    5. Output Format: MPG (MPEG-2 Program Stream)
    6. Multiplex!

    DVD:
    DVDStyler is one huge headache so if you have another program that can do custom menus like DVDStyler then I suggest you use that and even though in v2.3 it allows you to put a few seconds of video into the preview on your title menu it really just gives lots of errors and doesn't work for me so I wouldn't suggest it unless you know how to get that setting to work. If you can fix that or know of another program that can do custom menus like this then please let me know...Or you could always go with Windows DVD Maker.
    1. Open DVDStyler.
    2. Edit the DVD menu however you like.
    Not going to go into much detail on this. It's pretty self explanatory. If you have any problems there should be one or two videos on youtube showing this more in depth.
    3. DVD>Options> This is where you change the DVD Label, Video Format, Aspect Ratio, Audio Format. NTSC is for the United States, PAL is for Europe. Very important because if you pick the wrong one it will not play on your DVD Player.
    4. Configurations>Settings>Core>Frame count of menu: 24, Menu video bitrate: 3000, Slideshow video bitrate: 3000.
    I think for a higher menu bitrate you need a higher ISO but I think 3000 should be just fine since my background is only a picture.
    5. Right-click Menu>Properties>Video Object>Audio This is the background music for your menu.
    The resolution for the background image I will be using is 720x480.
    6. Right next to that in that same bar you can right-click>Add>File. There you can add the video you want on your dvd.
    7. Right-click Title>Properties>Check do not remultiplex/transcode.
    ***Very important. Also check that everything is correct. (Checked this because I heard if you don't it's like converting it a second time which is unnecessary and could result in lower quality.)
    Chapters. Make sure you put a chapter at the end of you video so that you can skip to the next episode. As in, Chapters: 5:00,10:00,15:00,20:00,24:09.616.
    Post commands: jump title 3; ect. Put this for each episode but leave the last one as call last menu; so that let's say you want to watch episode 2, you watch it, but then if you don't put jump title 3; after it finishes it will go back to the last menu instead of episode 3.
    8. File>Burn DVD Check Preview to see a preview of the DVD before burning Choose Burn from the three choices and Speed auto unless you know your speed Then click Start.
    9. Before it burns the DVD it will show you a preview in Windows Media Player and it will ask you to burn the DVD. Watch the preview if you checked preview then when you're ready click Yes to burn the DVD.
    10. DONE! Enjoy your DVD.
    Quote Quote  
  19. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Glad you got everything working for you and now have a plan of attack for future DVD conversions
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  20. Yes. Now to learn how to make soft subtitles. If you want you could check that out. The link should be in my signature.
    Quote Quote  



Similar Threads