VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Hi

    I have only just noticed that MPC is playing my .m4a files in mono. I have tried the same files in Windows Media Player, and they are stereo. I have also tried both mp3 and flv files in MPC, and they too are fine and in stereo. It seems to be the combination of m4a and MPC. To my knowledge there are no stereo/mono switches in MPC, at least not while playing an m4a file. I'm also pretty sure this is only something that has happened recently. I'd rather not do a system restore if at all possible. Is there something seriously simple I'm missing? Is there a hidden (or even obvious) stereo/mono toggle somewhere? Or maybe there's a keyboard shortcut that I could have unknowingly pressed?

    Can anyone help me?
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Are you using the old mpc? Then try the latest MPCHC (not beta).

    If you are already using mpchc then try disable the built in m4a/aac decoder, under view->options->internal filters->transform filters and unselect AAC. And see how it works.
    Quote Quote  
  3. Originally Posted by Baldrick View Post
    Are you using the old mpc? Then try the latest MPCHC (not beta).

    If you are already using mpchc then try disable the built in m4a/aac decoder, under view->options->internal filters->transform filters and unselect AAC. And see how it works.
    I was using the version that came with K-lite codec pack v8.7 (which I think was version 1.6 something or other) and had additionally upgraded that pack to the 64 bit upgradepack (which did not upgrade the player itself). Following your post I uninstalled all the MPC and K-lite installations and then installed the 64 bit MPC-HC and then the DirectX9 runtime that was also requested, followed by reinstalling the 64bit K-lite codec pack. The end result was still a big no on the stereo front. I then unchecked the AAC option (although I thought m4a was part of the mpeg 4 family), but it's still running in mono.

    This is extremely frustrating as I know these files were playing in stereo only a few weeks ago. Please, can anyone provide any further assistance?
    Quote Quote  
  4. Originally Posted by simondoy View Post
    Originally Posted by Baldrick View Post
    Are you using the old mpc? Then try the latest MPCHC (not beta).

    If you are already using mpchc then try disable the built in m4a/aac decoder, under view->options->internal filters->transform filters and unselect AAC. And see how it works.
    I was using the version that came with K-lite codec pack v8.7 (which I think was version 1.6 something or other) and had additionally upgraded that pack to the 64 bit upgradepack (which did not upgrade the player itself). Following your post I uninstalled all the MPC and K-lite installations and then installed the 64 bit MPC-HC and then the DirectX9 runtime that was also requested, followed by reinstalling the 64bit K-lite codec pack. The end result was still a big no on the stereo front. I then unchecked the AAC option (although I thought m4a was part of the mpeg 4 family), but it's still running in mono.

    This is extremely frustrating as I know these files were playing in stereo only a few weeks ago. Please, can anyone provide any further assistance?
    Oh, and I thought I'd just say that, from a basic user's point of view, the new 64 bit MPC-HC is a pain to configure the file associations. Unlike the older installations (using the K-Lite codec pack), there was no opportunity during the installation ,to set up file associations for video and audio independently, and, when I tried to set this up manually in the MPC options, well, I've never seen such an unnecessarily confusing set of options. I think they need to check out the Winamp options for some guidance on how to make it nice and simple.

    I'm still looking for some assistance on this issue though.
    Quote Quote  
  5. Right click on the video window while playing in MPC(HC). Hover over Filters... see what audio decoder is in use. Left click on it to see if there are any settings you can change -- like mono/stereo.
    Quote Quote  
  6. Originally Posted by jagabo View Post
    Right click on the video window while playing in MPC(HC). Hover over Filters... see what audio decoder is in use. Left click on it to see if there are any settings you can change -- like mono/stereo.
    Okay...did that (although had to resize the window because there is no video screen with an audio file) The 'filters' option was greyed out. This got me thinking though, and maybe there's something in the following information that I retrieved from the properties window, that could be of some use to someone?

    NB I have removed some information for licensing reasons, however I can tell you that it is downloaded radio broadcast from a popular broadcaster. (yes, I have checked all the m4a files I have). I will just recap that this file plays in stereo in both Windows Media Player and iTunes, however I have just checked the Quicktime player, where it plays in mono, and AVS, where it plays differently depending on which speaker option you select. In the 'Original' speaker option, it plays just out of the left channel, and cenrally balanced mono in both the 'Mono' and 'Stereo' options. Here's the 'Properties' info:

    General
    Complete name : xxxx
    Format : MPEG-4
    Format profile : Apple audio with iTunes info
    Codec ID : M4A
    File size : 43.2 MiB
    Duration : 1h 59mn
    Overall bit rate mode : Constant
    Overall bit rate : 50.8 Kbps
    Album : xxxxx
    Track : xxxxx
    Performer : xxxxx
    Genre : Podcast
    Recorded date : 2012
    Writing application : Lavf53.6.0
    Cover : Yes
    Comment : xxxx

    Audio
    ID : 1
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : HE-AACv2 / HE-AAC / LC
    Codec ID : 40
    Duration : 1h 59mn
    Bit rate mode : Constant
    Bit rate : 48.0 Kbps
    Channel(s) : 2 channels / 1 channel / 1 channel
    Channel positions : Front: L R / Front: C / Front: C
    Sampling rate : 44.1 KHz / 44.1 KHz / 22.05 KHz
    Compression mode : Lossy
    Stream size : 40.9 MiB (95%)


    I challenge anyone to work this crap out...all I want to know is which publisher needs to be strung up and xxxxxxx for doing whatever they've done. This was working just fine a few weeks ago!

    ***UPDATE***

    Having just checked this, I thought I'd add that Winamp also plays it in Stereo!
    Last edited by simondoy; 23rd Jul 2012 at 12:13.
    Quote Quote  
  7. MPC(HC): View -> Options -> Internal Filters -> Transform Filters -> AAC... is it selected? If so double click on it. Set Stereo/mono options. If not, select it and set the options. If you don't want to use it for some reason you'll have to figure out what DirectShow AAC decoder is in use and change it.

    Also check the audio switcher: View -> Options -> Internal Filters -> Transform Filters -> Audio Switcher... Enable Custom Channel mapping... make sure it's not set to mono.
    Quote Quote  
  8. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by simondoy View Post
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : HE-AACv2 / HE-AAC / LC
    Codec ID : 40
    Duration : 1h 59mn
    Bit rate mode : Constant
    Bit rate : 48.0 Kbps
    Channel(s) : 2 channels / 1 channel / 1 channel
    Channel positions : Front: L R / Front: C / Front: C
    Sampling rate : 44.1 KHz / 44.1 KHz / 22.05 KHz
    Hi
    Your post shows that the m4a file uses low bitrate "HE-AACv2 / HE-AAC / LC".
    Some players don't handle this properly.
    Test your MediaPlayerClassic with a regular 128Kbps LC m4a file such as this:-

    Code:
    Format            : AAC
    Format/Info       : Advanced Audio Codec
    Format profile    : LC
    Codec ID          : 40
    Duration          : 2h 30mn
    Bit rate mode     : Constant
    Bit rate          : 128 Kbps
    Channel(s)        : 2 channels
    Channel positions : Front: L R
    Sampling rate     : 44.1 KHz
    Quote Quote  
  9. Originally Posted by bat999 View Post
    Originally Posted by simondoy View Post
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : HE-AACv2 / HE-AAC / LC
    Codec ID : 40
    Duration : 1h 59mn
    Bit rate mode : Constant
    Bit rate : 48.0 Kbps
    Channel(s) : 2 channels / 1 channel / 1 channel
    Channel positions : Front: L R / Front: C / Front: C
    Sampling rate : 44.1 KHz / 44.1 KHz / 22.05 KHz
    Hi
    Your post shows that the m4a file uses low bitrate "HE-AACv2 / HE-AAC / LC".
    Some players don't handle this properly.
    Test your MediaPlayerClassic with a regular 128Kbps LC m4a file such as this:-

    Code:
    Format            : AAC
    Format/Info       : Advanced Audio Codec
    Format profile    : LC
    Codec ID          : 40
    Duration          : 2h 30mn
    Bit rate mode     : Constant
    Bit rate          : 128 Kbps
    Channel(s)        : 2 channels
    Channel positions : Front: L R
    Sampling rate     : 44.1 KHz
    The only thing is, that doesn't explain why these very same files were working a few weeks ago. These are files that hae played successfully on the older MPC that was provided in the v8.7 K-lite Codec Pack, and now are still not working evesuccessfully n though I have upgraded to the latest 64 bit version. The only thing that I can think of that changed since I last played these files in stereo, is that I upgraded the K-lite codecs using an upgrade, without (I think) changing the player.

    When I can successfully locate a 'regular' m4a file, I'll let you know, however, I'm not sure where I'll get one...any ideas?
    Quote Quote  
  10. "Normal" stereo AAC M4A:
    Image Attached Files
    Quote Quote  
  11. Originally Posted by jagabo View Post
    "Normal" stereo AAC M4A:
    Thank you for the file. Yes, it plays in stereo!!! So, it seems I need to roll back my codecs or player, or both, as the files that are now playing in mono were definitely playing okay a few weeks ago. Correct me if I'm wrong on that? So, presumably I should only roll back the .m4a codec...or could it be the player? The reason I upgraded the codecs a few weeks ago was because Jaksta was producing .flv files that were not behaving correctly...they were playing but as soon as you tried to fast forwards or backwards it just skipped to the end of the file. If you think it's the codec, would anyone have a link for an individual codec, and would this just be added to the 'System 32' folder If you think it's the player, would anyone have a link to an older version? Obviously if it's the player then I may find I still have a problem with .flv files, although that might have only been a codec issue, so maybe just changing the .m4a codec would avoid the .flv issue arising again.

    Please let me know what you think and thank you once again for the assistance with the attached .m4a file.
    Quote Quote  
  12. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by simondoy View Post

    Please let me know what you think...
    Hi
    MPC-HC plays m4a files without needing external codecs.

    Temporarily un-install the K-lite Codec Pack.

    Make sure you're using the latest version of MPC-HC from the Sourceforge website.

    Play your low-bitrate files and the Stereo.m4a test file.

    If you think there's a bug in MPC-HC then file a report.
    Last edited by bat999; 24th Jul 2012 at 15:28.
    Quote Quote  
  13. Originally Posted by bat999 View Post
    Originally Posted by simondoy View Post

    Please let me know what you think...
    Hi
    MPC-HC plays m4a files without needing external codecs.

    Temporarily un-install the K-lite Codec Pack.

    Make sure you're using the latest version of MPC-HC from the Sourceforge website.

    Play your low-bitrate files and the Stereo.m4a test file.

    If you think there's a bug in MPC-HC then file a report.
    I have done all that. Still plays the attached stereo .m4a file in stereo, but still plays all my other stereo .m4a files in mono. I will report it, but am frustrated because I can't see why this would have changed a few weeks ago.
    Quote Quote  
  14. ***Update***

    Have reported the bug.

    Have also explored oldversion.com and installed and unistalled versions of the K-lite Codec Pack, going back to early 2011. All v.7 had the same bug, however, upon trying the only v.6 (MPC build 1.4.2803.0) installation they had on the site, I discovered that this v.6 does NOT have this bug. My .m4a files play perfectly! I will pursue the bug report though, as this does need to be fixed I feel. The only thing that still bewilders me, is that I have never installed v.6 on this machine, and this whole thing started when I had the v8.7 K-lite pack on my machine...strange!
    Quote Quote  



Similar Threads