This is what worked for me:

TV: Sony KDL-32EX308
Software: Handbrake
OS: (shouldn't matter, but) Sabayon Linux 8
In Handbrake, I set the Codec to MPEG-4 (FFmpeg)
Use NTSC (29.97) framerate and set it to Variable Framerate.
Set the encode to Constant Quality and put the slider between 1 and 8. Setting 1 will be higher quality but larger filesize. If you source video is already a crappy bitrate, then a higher setting here will not help you. (you can't get something from nothing).
Make sure the filename stays .mp4 and NOT .m4v. I changed the default settings in Preferences to not use this.
My audio is set to AAC. I use 160Kbps Audio bitrate.