VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. Matsujunna
    Join Date
    Jul 2011
    Location
    Italy
    Search Comp PM
    Hi there,
    I'm trying to encode a video with Ass subtitles by using StaxRip, but everytime the final result is a video with subs in Arial, no colors, nothing.

    There is something that maybe I don't have: plugin or a filter? Or there is no way to encode Ass subs with this program?
    Quote Quote  
  2. If I remember correctly StaxRip is using AviSynth as a frameserver so it should be possible (at least if you write your own AvnSynth Script).

    You need a subtitle renderer possible to render ASS Subs (I'd recommoned you assrender since VSFilter is really slow sometimes but this will make things a little more complicated so you may want to stick to VSFilter), the subtitle script and the fonts used by the script (otherwise it will fallback to Arial which may happened to you).

    You may check if you got all needed fonts using the Aegisub "Font Collector" feature. You could also use aegisub to change the fonts and other style properties if you'd like to.

    An example for writing your own .avs would look something like this:

    Code:
    # if you want to use assrender
    LoadCPlugin("path/to/assrender.dll")
    
    # for vsfilter
    LoadPlugin("path/to/vsfilter.dll")
    
    # you will need this in both cases - it opens the video
    directshowsource("path/to/source.ext")
    
    # render subs with assrender
    assrender("path/to/subs.ass")
    
    # or render subs with VSFilter
    TextSub("path/to/subs.ass")
    You may then load this avs file as the source in staxrip.

    I hope I could be of any help but first check if the fonts are even installed.
    Quote Quote  



Similar Threads