VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 40
Thread
  1. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    Hey guys! I recently bought Immortals BD in 1080p (yayyy ) and ripped it so I can have it in my laptop. I downloaded greek subtitles from a well known site... The subs are nicely synchronized, but I can't read them!! They are some sort of weird letters/symbols instead of greek letters! My computer is bought from Greece and the user interface is translated in greek also! Can you please help me ? I'd be very indebted to you! Thank you very much!!
    Quote Quote  
  2. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    Try installing the free VLC program and play with the subtitle settings if necessary as it MIGHT be able to play them without too much fuss.

    If that doesn't work, it's going to get very ugly.

    What OS are you using? XP and below may require some nasty tricks to get it working. Are your subtitles in a Windows code page or Unicode? What format are they? If they are SRT can you open them in Word or Wordpad and read them?

    We have some members here who have experience with Greek subtitles and you can search the forums for older posts on the subject. If you still need help tomorrow and nobody else has posted, I'll try to remember to post my general suggestions for dealing with subtitles in character sets other than Latin.
    Quote Quote  
  3. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    I've already searched older post and didn't find solutions.
    Anyway, I use windows 7, I already have VLC (It's this player that can't get them right) and yes it's an .srt-file.
    And thank you for helping me
    Quote Quote  
  4. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    Open the SRT file in Microsoft Word or Wordpad. Can you read the subtitles or are they weird characters?
    Quote Quote  
  5. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    I can't read them. They're weird characters.
    Quote Quote  
  6. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    Originally Posted by MultiNikos View Post
    I can't read them. They're weird characters.
    That means that your computer is not set up correctly for Greek. That is why the subtitles don't work. Or they are in a weird code page that your PC does not currently support.

    There may be a better solution that someone else knows, but the brute force approach in the past was to go into Regional and Language Settings and then Advanced and under "Select a language to match the language version of the non-Unicode programs you want to use" you had to pick the appropriate code page for the language you want. You will need to know which code page your subtitles use. Then you may have to reboot.

    Note that this will more or less force everything on your PC into Greek by default so you need to be able to read Greek or you may have problems using the computer. Do this only if you cannot find any other better solution.

    Another approach might be to try to cut and paste these subtitles between documents in Word and save the pasted one as Unicode text. VLC should be able to use that.
    Quote Quote  
  7. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    Apparently your Greek .SRT is not encoded as UTF-8/Unicode.
    You'd better use a semi-decent text editor which can open that SRT under a Greek codepage,
    and then save it as UTF-8 or Unicode.

    Plain text supports around 200 printable 8-bit characters, and contains NO information about other character sets than Windows-1252, therefore it should be definitely avoided by everyone who creates contents containing non-Latin characters.
    Quote Quote  
  8. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    My computer is already in greek! i bought him in greece! can you tell me which semi-decent editor i have to use and how to do it please ?
    Quote Quote  
  9. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    One way you might be able to do it is that you will have to open the original subtitles in Firefox. Change the character encoding options until you fine the correct Greek code page. I am not an expert in Microsoft Word so maybe it can do this, but Libre Office (free) will let you save files as Unicode text. So you could cut and paste from the Firefox window to a Libre Office document and save it as Unicode text, then rename the ending to end in .srt instead of .txt. There is a free Unicode text editor available that might also be useful to you, but I don't remember the name of it. You can search for it.
    Quote Quote  
  10. Member dragonkeeper's Avatar
    Join Date
    Jul 2003
    Location
    United States
    Search Comp PM
    download notepad++ or textpad, use these to save the file as unicode this should fix your problem.
    Murphy's law taught me everything I know.
    Quote Quote  
  11. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    ahhh i deleted notepad++ some days ago i guess ill redownload it

    and how do i save it as unicode?
    Quote Quote  
  12. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    when i open the file with notepad++ those weird letters appear again ! (sorry for double posting)
    Quote Quote  
  13. maybe you have to change character encoding in notepad++
    Quote Quote  
  14. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    Guys tell me how to do this stuff, I don't know, I'm a noob lol
    Quote Quote  
  15. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    By the way I found out that the subs are encoded in ANSI..
    Quote Quote  
  16. Member dragonkeeper's Avatar
    Join Date
    Jul 2003
    Location
    United States
    Search Comp PM
    Originally Posted by MultiNikos View Post
    Guys tell me how to do this stuff, I don't know, I'm a noob lol
    which app are you using?
    Murphy's law taught me everything I know.
    Quote Quote  
  17. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    Originally Posted by dragonkeeper View Post
    Originally Posted by MultiNikos View Post
    Guys tell me how to do this stuff, I don't know, I'm a noob lol
    which app are you using?
    for what ? i use VLC to watch the videos and I opened the subs to view them with Notepad++
    Quote Quote  
  18. Member dragonkeeper's Avatar
    Join Date
    Jul 2003
    Location
    United States
    Search Comp PM
    open subtitles in notepad++ then change the format under the encoding tab. then save the file.

    Name:  untitled.JPG
Views: 45535
Size:  21.1 KB
    Murphy's law taught me everything I know.
    Quote Quote  
  19. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    I did it! Is this all? it didnt work .. i converted in UTF-8 but the text in notepad++ didnt change to greek it just became weirder (not in the film, in the notepad)
    Last edited by MultiNikos; 30th Apr 2012 at 09:44.
    Quote Quote  
  20. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    ^ Didn't you try the item *Character Sets*
    Quote Quote  
  21. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    What is this ''character set?
    Quote Quote  
  22. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    Can anyone help a little faster, if possible because we want to watch this film with friends tonight please?
    Quote Quote  
  23. Member dragonkeeper's Avatar
    Join Date
    Jul 2003
    Location
    United States
    Search Comp PM
    open subtitles in notepad++ then change the character set under the encoding tab. then save the file.

    Click image for larger version

Name:	untitled.JPG
Views:	37872
Size:	41.8 KB
ID:	12244
    Murphy's law taught me everything I know.
    Quote Quote  
  24. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    I think this will solve the problem.
    Anyway I tried playing the movie on a friend's PC but he gets ''?????'' <-- these symbols instead of these--> Μετάφραση και that I was getting ... is it because his PC isn't greek ?
    Quote Quote  
  25. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    No, probably it's because you have NOT saved the SRT as UTF-8 or Unicode.
    Quote Quote  
  26. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    There's no ''unicode'' in ''encoding'' and ive pressed ''UTF-8'' many times also changed the ''characters set'' to Greek>Windows
    and then I save as>.txt file on desktop
    Quote Quote  
  27. Member dragonkeeper's Avatar
    Join Date
    Jul 2003
    Location
    United States
    Search Comp PM
    Originally Posted by MultiNikos View Post
    I think this will solve the problem.
    Anyway I tried playing the movie on a friend's PC but he gets ''?????'' <-- these symbols instead of these--> Μετάφραση και that I was getting ... is it because his PC isn't greek ?
    The questions mark usually indicate the pc is not set up to display the characters.
    Murphy's law taught me everything I know.
    Quote Quote  
  28. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    This is my last post in this thread. If you don't understand what I am saying, MultiNikos, then too bad for you.

    Do what I said earlier. Use Firefox to open the SRT file. Change the encoding option under Web Developer -> Character Encoding. Change it to various Greek options until you get the one that is correct and you can read the subtitles.

    Cut and paste the entire subtitle file into a new text editor window. I use Libre Office for this. Save the output as "encoded txt" and it should have an option for Unicode. Rename the saved file to end in .srt instead of .txt. Open the saved file in something like Word or Wordpad. If you can read it after opening it, you have correctly converted the subtitles to Unicode and they should now work.
    Quote Quote  
  29. Member
    Join Date
    Jan 2012
    Location
    america
    Search PM
    Thank you jman98. IT WORKED
    HURRAY
    Quote Quote  
  30. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    Originally Posted by MultiNikos View Post
    ...
    Anyway I tried playing the movie on a friend's PC but he gets ''?????'' <-- these symbols instead of these--> Μετάφραση και that I was getting ... is it because his PC isn't greek ?
    My PC is not "Greek" either, however...

    Μετάφραση και


    Originally Posted by MultiNikos View Post
    There's no ''unicode'' in ''encoding'' and ive pressed ''UTF-8'' many times also changed the ''characters set'' to Greek>Windows
    and then I save as>.txt file on desktop
    There is UCS-2, which is the same thing.

    Originally Posted by dragonkeeper View Post
    ...
    The questions mark usually indicate the pc is not set up to display the characters.
    Unlikely --- since 1998 or 1999, IIRC, the common/default fonts of Windows do contain Greek and Cyrillic characters, without additional trickeries nor updates.
    Quote Quote  



Similar Threads