VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 61
FirstFirst 1 2 3 4 12 52 ... LastLast
Results 31 to 60 of 1828
Thread
  1. OK I unticked "Ignore all audio on buggy input'". But now the job gives this error on the 1st file and it doesn't create a FLAC or m2v file from that file:

    ABORTED ERROR: C:\Users\Dave\AppData\Local\Temp\iId_12_aid_128_00 _37_39_3421_01.ac3 is too small! (byteSize: 0byte)
    Quote Quote  
  2. Sorry, my mistake should have told you to also enable: "Config->Input->General Settings->Stream extraction with ffmpeg"
    Problem with your source is that mencoder thinks that there is no audio stream so extracting/decoding through mencoder fails, which is why ffmpeg needs to be used.

    Cu Selur
    Quote Quote  
  3. Thanks, it's working now. Just wondering, is it possible to use your program to automatically mux files. I have several folders, each with an M2V and AC3 file in it.
    Quote Quote  
  4. Sure Hybrid can mux, but not to mpg.
    This is not planned since:
    a. Hybrid supports no encoder which creates MPEG-2/MPEG-1 content atm.
    b. I have no clue how to calculate the container audio&video overhead for the mpg container

    Cu Selur
    Quote Quote  
  5. Member
    Join Date
    Nov 2002
    Location
    United States
    Search Comp PM
    There is a thread with a batch file to mux a folder full of matching m2v and ac3 (files with corresponding names). Here is the download (place the files in your folder of m2v and ac3 files and run mux.bat) mux.zip

    https://forum.videohelp.com/threads/263455-Batch-processing-joining-m2v-ac3-to-create-mpg1

    You need to remove spaces in filenames for batch to work. There is a program (exe) in the thread to remove spaces or you could use this VBS script...

    Code:
    dim objFileSys, file, folderName, folderObj, fileColl, objRegEx, newFile
         
        set objFileSys = CreateObject("Scripting.FileSystemObject")
        folderName = InputBox("Enter the full path where the files are located.", "Full path is required")
         
        set folderObj = objFileSys.GetFolder(folderName)
        set fileColl = folderObj.Files
        set objRegEx = new RegExp
         
        objRegEx.Pattern = " " ' the pattern is one space
        objRegEx.Global = true
         
        for each objFile in fileColl
        newFile = objRegEx.Replace(objFile.Name, "-") ' each pattern gets replaced with one dash
         
        objFileSys.MoveFile objFile, folderName & "\" & newFile
        next
    Copy to notepad > save as "Replace-Spaces-With-Dashes.vbs" > double click vbs file > paste path to mpeg folder > click OK


    ffmpeg supports muxing of mpeg also...
    Quote Quote  
  6. How can I get FLAC 16-bit output? At the moment it outputs at 24 or 32 bit which defeats the purpose of FLAC because it doubles the file size.
    Quote Quote  
  7. If there's a ffmpeg option for it I can add support for it,.. (don't use flac myself, so never noticed, thought the bit depth would be taken from the input,...)
    Quote Quote  
  8. Yes I currently use the ffmpeg option to convert to FLAC so could you add a 16-bit FLAC option please? I use FLAC because it's gives a lossless compression of WAV so you get up to 50% reduction in file size.
    Quote Quote  
  9. Yes, I can, if you tell me which option is used to tell ffmpeg to create 16/2432bit flac I can add a dropDownBox for it
    Quote Quote  
  10. I'm not sure what you mean. In the Audio tab there's an option for PCM (WAV) to be in 16 or 24 bit but there's no option for FLAC.

    In Config I ticked the box that says "Stream extraction with ffmpeg". It makes a FLAC but only in 24 or 32 bit.
    Quote Quote  
  11. Ah, okay, it sournded like you knew which ffmpeg option in the command line was needed to add this.
    Quote Quote  
  12. @VideoFanatic:
    Think I found and added support to choose between 16/32bit flac encoding.
    If you tell me which flavour of Hybrid you are using (32/64bit Windows XP/7, Linux, Mac), I can send you a test version.
    Quote Quote  
  13. Windows 7 64 bit. Thanks
    Quote Quote  
  14. I use Hybrid to batch demux the video of MPEG2s and to convert the audio to FLAC files. I batch demuxed about 50 MPEG2s several days ago but today I noticed that for several of the MPEG2s no FLAC file was created. Any idea why? Should I upload one of the MPEGs to you so you can fix the problem?
    Quote Quote  
  15. Any idea why?
    could have multiple reasons, hard to say might be some problem with id mapping, some problem during decoding, ....
    normally Hybrid would abort by reproducing the process and looking at the debug output file I could figure out where the problem is.
    -> fastest would probably be that you upload one of the files that doesn't work somewhere.
    Since the problem sound relatively restricted, it should be easy to reproduce and fix.
    Quote Quote  
  16. Hi. Firstly, Hybrid gives the best results I've ever seen from a converter which is why I'd like to keep using it. Unfortunately, I've had a problem with my latest file. It's an mp4 with codec ID avc1. My usual Hybrid setting is xvid, 2 pass, 1500kbps. When I start the job, everything seems to be working OK and I get the usual 'finished' message. But under the Jobs tab, it tells me it's been aborted. Which is true as there's no new file generated. Screenshot:

    Here's the last section of the log (I can post it all if needed):


    Starting Main@09:19:20.322:
    "C:\Program Files\Hybrid\mencoder.exe" -lavdopts threads=2 -ovc xvid -xvidencopts pass=2:bitrate=1500:me_quality=6:quant_type=h263:m in_iquant=1:max_iquant=31:min_pquant=1:max_pquant= 31:min_bquant=1:max_bquant=31:max_key_interval=250 :keyframe_boost=10:kfthreshold=1:kfreduction=20:qu ant_type=h263:max_bframes=2:bquant_ratio=150:bquan t_offset=100:bf_threshold=0:vhq=2:bvhq=1:curve_com pression_high=0:curve_compression_low=0verflow_control_strength=10:max_overflow_improveme nt=10:max_overflow_degradation=10:trellis:noqpel:n ogmc:nocartoon:chroma_opt:chroma_me:nointerlacingar=extar_width=1ar_height=1:closed_gop:nopacked:threads=2 -passlogfile "C:\Users\BAD\AppData\Local\Temp\09_13_29_7310_03. stats" -demuxer lavf -vfm ffmpeg -noskip -vf scale,format=i420,scale=640:360,scale,format=i420 -sws 10 -forcedsubsonly -nosub -nosound "E:\MADCCO~1\0TO423~1.MP4" -of avi -o "C:\Users\BAD\AppData\Local\Temp\09_13_29_7310_04. avi"
    finished after 00:09:09.918



    Starting Main@09:28:30.284:
    "C:\Program Files\Hybrid\MP4Box.exe" -tmp "C:\Users\BAD\AppData\Local\Temp" -new "\09_13_29_7310__06_mp4Temp.mp4"
    Error opening file \09_13_29_7310__06_mp4Temp.mp4: Requested URL is not valid or cannot be found
    finished after 00:00:00.196 with exitCode 1
    Job 09_13_29_7310 finished!


    So, can anyone tell me what the problem is? Thank you.
    Quote Quote  
  17. Member
    Join Date
    May 2013
    Location
    Turkey
    Search PM
    x264 "Level" value is depends player or platform.

    iPhone, iPod 5.5G (Level 3.0)
    iPod (Level 1.3)
    PSP (Level 2.1)
    Zune (Level 3.0)
    AppleTV (Level 3.1)
    PS3, Xbox360, > 720p (Level 4.1)


    If video size is "<= 720p", best "Level" value is "Level 3.1": Most compatible.

    If video size is "> 720p", best "Level" value is "Level 4.1".
    Last edited by Hikmet; 23rd May 2013 at 05:12.
    Quote Quote  
  18. @pooksahib:
    1. try the latest version which is rev 2013.05.22.1 (http://www.selur.de/downloads), iirc. this is one of the bugs that got fixed since 04.16
    2. if the latest version does not fix the problem, create a debug output (http://www.selur.de/support) of the job creation, meaning: enable the debug output just before you add the job to the jobqueue and after you added the job, look into the output folder and post the HybridDebugOutput.txt
    @Hikmet: unsure what you want to say with you statement

    Cu Selur
    Quote Quote  
  19. The new version did the job perfectly. Thank you so much.
    Quote Quote  
  20. Hi,

    For some reason when I try to drag a folder of files into the input line it won't allow me to do it yet it worked in the past. Could you please fix it. Thanks
    Quote Quote  
  21. Seems to work fine here. (DVD and Blu-ray input, need to be disabled)
    Quote Quote  
  22. I didn't change any settings from when it last worked. I'm not sure why it wasn't working but it's working now.

    I did a batch demux and 1 MPEG2 file gave an error message saying it couldn't rename the flac file since it didn't exist. The demux said "Aborted" in the demux window and the queue would not finish demuxing until I OK'd the message. No files were created for the MPEG2 that gave the error message.


    If I do a single file demux then it says finished but no files are created. I will send you the download link via PM.
    Quote Quote  
  23. Not sure what to do with the files you are sharing, it you can't recreate the problem yourself,...
    Quote Quote  
  24. This is a different problem I'm referring to.

    Originally Posted by VideoFanatic View Post

    I did a batch demux and 1 MPEG2 file gave an error message saying it couldn't rename the flac file since it didn't exist. The demux said "Aborted" in the demux window and the queue would not finish demuxing until I OK'd the message. No files were created for the MPEG2 that gave the error message.


    If I do a single file demux then it says finished but no files are created. I will send you the download link via PM.
    Quote Quote  
  25. okay, I'll download the file and see if the extraction works here,..
    Quote Quote  
  26. -> download will be finished in around 6h,... (I get around 80kByte/s)
    Please check if this problem only happens with this sample or if you have another smaller sample with this problem,...
    Quote Quote  
  27. It just happens with this file.
    Quote Quote  
  28. okay, will report back then once the download is finished and I could try it here.
    Quote Quote  
  29. Perhaps you can add support for muxing mks subtitles?
    Also (bug?), when using drag and drop to input files, after the file is encoded, drag and drop doesn't work. It starts back working after you manually select a new file. I'm using the current version, but have noticed this since forever.
    Quote Quote  
  30. Perhaps you can add support for muxing mks subtitles?
    I never encountered them. So I never had any need for this.
    + I'm one of those guys who think that subtitles without a video stream inside a container just don't make sense.


    Also (bug?), when using drag and drop to input files, after the file is encoded, drag and drop doesn't work. It starts back working after you manually select a new file. I'm using the current version, but have noticed this since forever.
    works here, but I thing I found the problem, seems like minimizing and restoring the GUI causes this,...
    -> will look into it
    Quote Quote  



Similar Threads