VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 12 of 12
  1. Hi to all... i have 5 small files all under 50mb each.. just only a few days ago they were playing back fine..

    then the other day i got some error msg on screen.. something about hard disk read/write if i rmbr properly..

    now these files are on an external USB HDD.. i have tons of movies/video clips there these are all fine except the 5 clips i mentioned..

    i have tried using Avirepair.. selecting a working file as source with similar fps etc.. then the corrupted file.. ( ive used this in the past and it fixed broken files ) but not this time.. i have also tried DivFix.. stripped index/rebuilt index but nope still wont work ( does show 1 error in here )..

    in VirtualDub the movie does play, and also in mplayerc it plays also..

    in VirtualDub i have tried exporting as a new avi but that dont work either.. i have now looked in GSpot it says..::

    Note: 410 bytes unneeded bytes at end of file
    AVI v1.0
    Video: 26.3 MB (99.90%)
    AVI Overhead: 28.1 KB (0.10%)

    i dont know what else i can try.. any info would be appreciated.. and if there any more info i need to post just suggest somethign plzz..

    im really hoping these can be fixed..

    thx in advance..
    Quote Quote  
  2. Member
    Join Date
    Jul 2008
    Old Dominion
    Search Comp PM
    If you received a windows delayed read/write error you did say the "magic" word - corrupted, which simply means the original file probably can't be recovered or restored since you already altered the file with the repair utilities. That error could also be an indicator of the end of your external USB drive and you may have the same thing happen to the remaining files. In my experience it hasn't been the drive itself that failed but the interface/controller in the drive housing. I would invest in a new drive and transfer the remaining files before I lost the remaining files to corruption.
    Quote Quote  
  3. hi fella thx for the reply..

    well i dont know if the error was actually aimed at the external HDD.. cause i do use 3 internals & 1 external.. so could have been any 1 of those drives..

    also before i have ran the file through any program i use a copy of the original files.. so the originals are fully intact..

    but im thinking if the files play in VirtualDub they can be fixed ??
    Quote Quote  
  4. Originally Posted by Serval View Post
    then the other day i got some error msg on screen.. something about hard disk read/write if i rmbr properly..
    Once a drive develops a bad block it's likely to develop more in the near future. You should back up everything on the drive if it's important to you.

    Originally Posted by Serval View Post
    in VirtualDub the movie does play, and also in mplayerc it plays also..
    What do you mean? It will play all the way through without any glitches?

    Originally Posted by Serval View Post
    in VirtualDub i have tried exporting as a new avi but that dont work either..
    What does that mean? VirtualDub couldn't save the video? The saved video didn't play? Do you use Direct Stream Copy for both audio and video.
    Quote Quote  
  5. yeah i selected direct stream copy.. > save as avi.. the file saves but get error playing back in WMP & also VLC..

    and yes m8.. when i load the file in VirtualDub i can select play and the file plays no problems..
    Quote Quote  
  6. What's the error WMP and VLC report?

    Generally if you can open an AVI in Virtualdub, it doesn't report a problem when opening it, and it saves it as a new AVI without any problem, there's nothing wrong with it.

    Gspot isn't reporting anything out of the ordinary. Try MediaInfo. It'll give you more info, but it the files play correctly using MPC-HC, probably nothing useful.

    You could try using MKVMergeGUI (part of MKVToolNix) to resave the AVI as an MKV. MKVMergeGUI will also report problems it finds when resaving a file. If it creates an MKV okay, see if it plays properly.
    Quote Quote  
  7. Hi m8 thx for the reply.. i have now noticed ALL my files are not playing in WMP ( only the 5 i mentioned wont play in VLC ) i have since got these working by using HJSplit split the files into 2 then rejoined and they work fine...

    i havent exactly checked the hundreds of movie files i have.. but what i have tried 99% play in VLC & KMPlayer.. but always same error in WMP error msg..::

    Windows Media Player encountered a problem while playing the file. For additional assistance, click Web Help.

    web help says " You've encountered error message C00D11B1 while using Windows Media Player. "

    ive checked the online help and it suggest something about a sound issue ? but my sound is fine..

    ive since backed up all my files onto another HDD to be safe.. but its looking more likely a WMP issue..
    Quote Quote  
  8. Member [_chef_]'s Avatar
    Join Date
    Nov 2002
    Search Comp PM
    Fixing in VirtualDub didnt work at all??
    *** Now that you have read me, do some other things. ***
    Quote Quote  
  9. theres no point in fixing them individually its looking like a WMP error/issue its happening with ALL my files now.. they wont play in WMP only KMPlayer or VLC..
    Quote Quote  
  10. just tried the external HDD in a friends laptop.. ALL files work fine there..

    so something must be corrupted on my pc or im missing some codecs.... ive used the K-lite pack.. divx codec & ffsdshow altho i have now uninstalled this.. also i just did a fresh install maybe 10 days ago..

    anyone any other ideas ?
    Quote Quote  
  11. If you have errors playing the videos in VLC (and they played fine in VLC before) the problem isn't file reader/splitters or codecs. It's the display driver. VLC doesn't use system installed reader/splitters or codecs. It has it's own filters built in. It only use DirectShow for display. Try turning off hardware acceleration in VLC. And try different Video Output Modules.
    Last edited by jagabo; 4th Apr 2012 at 20:58.
    Quote Quote  
  12. fixed it.. problem was quartz.dll file.. found the solution elsewhere.. start>run and type: regsvr32 "C:\WINDOWS\system32\quartz.dll"

    voila !

    thx to all who who responded with there suggestions !!
    Quote Quote  

Similar Threads