VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. Member
    Join Date
    Jul 2011
    Location
    São Paulo, Brazil
    Search Comp PM
    Hello encoders =)

    Right now I'm trying to set my encoding software on ubuntu (11.04) and am having problems with x264.
    I got x264 last version from git and it's configure gave me this:
    Code:
    platform:      X86_64
    system:        LINUX
    cli:           yes
    libx264:       internal
    shared:        no
    static:        no
    asm:           yes
    interlaced:    yes
    avs:           no
    lavf:          yes
    ffms:          no
    gpac:          yes
    gpl:           yes
    thread:        posix
    filters:       resize crop select_every 
    debug:         no
    gprof:         no
    strip:         no
    PIC:           no
    visualize:     no
    bit depth:     8
    chroma format: all
    
    You can run 'make' or 'make fprofiled' now.
    After compiling and installing I get this from "x264 --version":
    Code:
    x264 0.120.2164 da19765
    (libswscale 2.1.100)
    (libavformat 54.1.100)
    built on Feb 21 2012, gcc: 4.5.2
    configuration: --bit-depth=8 --chroma-format=all
    x264 license: GPL version 2 or later
    libswscale/libavformat license: LGPL version 2.1 or later
    The problem is that neither ffmpeg or mplayer seem to find this library installed. Both configure scripts say no even when trying --enable-libx264 (ffmpeg simply say I don't have x264 >= 118).

    Other things I found out are that ffmpeg detects everything BUT the encoding features for h264 and my videos with this codec do play fine (VLC Media Player apparently is even using the x264 library itself). Also when I run the version.sh script after installing it gives me this:

    Code:
    #define X264_REV 2164
    #define X264_REV_DIFF 0
    #define X264_VERSION " r2164 da19765"
    #define X264_POINTVER "0.120.2164 da19765"


    Some extra that can be useful:

    Thank you for your attention...
    Last edited by rzippert; 21st Feb 2012 at 19:23.
    Quote Quote  
  2. Member
    Join Date
    Jul 2011
    Location
    São Paulo, Brazil
    Search Comp PM
    Well... Only progress I got was using --enable-static option to configure, but then ffmpeg and mplayer got problems when compiling with it.
    I don't really understand why didn't it work the way I did, but worked when I followed a tutorial in the ubuntu forums. The only meaningful difference I noticed was the use of checkinstall instead of make install, but don't know why should it work differently.

    Anyway, thanks for your attention =)
    Quote Quote  



Similar Threads