VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Member
    Join Date
    Jan 2012
    Location
    South Africa
    Search PM
    Ok i have a movie that is a .mkv that i want to mux to mp4 the problem is that when its doen it plays fine but the seeking is buggert after doing some reading it seams it a problem with open gop. I dont realy want to re-encode the video so i want th know if there is a way i can fix it without re-encoding or a way to re-encode without lossing quality or a increase in size a step by step guide whoud be nice if posseible following is the video media info
    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 3 frames
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 1h 49mn
    Bit rate mode : Variable
    Nominal bit rate : 2 190 Kbps
    Maximum bit rate : 20.0 Mbps
    Width : 1 280 pixels
    Height : 688 pixels
    Display aspect ratio : 1.860
    Frame rate : 23.976 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.104
    Writing library : x264 core 114 r1924 08d04a4
    Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / sliced_threads=0 / slices=4 / nr=100 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=2 / weightp=0 / keyint=24 / keyint_min=2 / scenecut=40 / intra_refresh=0 / rc_lookahead=24 / rc=2pass / mbtree=1 / bitrate=2190 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=20000 / vbv_bufsize=20000 / nal_hrd=vbr / ip_ratio=1.40 / aq=1:1.00
    Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
    Transfer characteristics : BT.709-5, BT.1361
    Matrix coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177
    Quote Quote  
  2. Not possible without re-encoding

    How are you playing this back? What software or hardware has the problems with the seek ? Note some older decoders did not support open gop
    Quote Quote  
  3. Member
    Join Date
    Jan 2012
    Location
    South Africa
    Search PM
    Playing it on my pc try'd mpc, wmp, itunes and vlc
    Quote Quote  
  4. What decoder are you using for MPC ?

    Does MPCHC have problems with seeks ?

    What are your hardware specs ?
    Quote Quote  
  5. wait; are you saying it seeks fine in mkv container? But only when you re-wrap into mp4 seeking becomes a problem ?

    If so, how you are you re-wrapping ? Try something else like yamb, mp4creator, ffmpeg
    Quote Quote  
  6. Member
    Join Date
    Jan 2012
    Location
    South Africa
    Search PM
    Yes it is only when i re-wrap it that it gives the problem i have tryd yamb, XviD4PSP and Avidemux i have been a bit to lazy to try and figure out how ffmpeg works
    Last edited by Rathgar; 13th Jan 2012 at 15:47.
    Quote Quote  
  7. Try mkvtomp4
    https://forum.videohelp.com/threads/340675-Mkv%D0%A2%D0%BEMp4-v0-218-rapid-tool-for-repack-Mkv-to-Mp4


    But it might be a playback configuration problem, like a bad mp4 splitter, try configuring it with lav or haali instead (although vlc doesn't rely on those, it should be ok, but some versions of vlc are buggy)
    Quote Quote  
  8. Member
    Join Date
    Jan 2012
    Location
    South Africa
    Search PM
    Ill try mkvtomp4 and i took a look at what decoder i use it is haali and it shoud be the latest version i installed the latest k-lite pack
    Last edited by Rathgar; 13th Jan 2012 at 16:34.
    Quote Quote  



Similar Threads