VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 2 of 2
  1. Hello all!

    I'm trying currently to get the rtmp online stream in x264, transcode it to mpeg2 and send through mediatomb (linux DLNA server) to Samsung TV (DLNA renderer).

    With the mencoder here is the working command:
    rtmpdump ... | mencoder -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -srate 48000 -ofps 30000/1001 -ovc lavc -oac lavc -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=4:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=60000:vrc_buf_size=7000 -cache 8920 -quiet -aspect 16:9 -vf scale=1280:720 -o FIFO -
    FIFO is the named pipe name, where the mediatomb takes the content from. The mencoder works just fine and I have the content on TV. Now, with the ffpmeg:

    rtmpdump ...  | ffmpeg -i pipe: -vcodec mpeg2video -sameq -s hd720 -acodec libmp3lame -ar 48000 -ac 2 -vbsf h264_mp4toannexb -f mpegts -r 29.970 -minrate 10000k -maxrate 60000k -b 12000k -bufsize 36408333 pipe: > FIFO
    Don't worry about audio codec, it is irrelevant here.

    With this setup, and many more I've been trying, I have the video content on Samsung TV, but each few seconds I see the blocks in random spots of the video, looking as "big pixels". frequently these blocks are visible in bunches in single line.

    I've been trying a lot of encoding settings, I even get almost the same codec parameters in both video streams (from mencoder and ffmpeg) using mediainfo, but no matter what I changed the problem still persists. Does someone can explain what may happen here and what more can I try to avoid these blocks with ffmpeg? The thing is that I wouldn't like to back to mencoder because of some problem with process communication from mediatomb.

    This is definetly the fault of the poor Samsung TV DLNA support, because the video recorded to mpeg and played with any different player (ffplay, vlc, mplayer) looks just fine, but after all I was able to provide somehow the stream without these bugs by mencoder, and I suppose it's also available from ffmpeg. Is there any "magic option" there?

    All suggestions will be greatly appreciated. Thanks.
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Search Comp PM
    Ffmpegx is a mac os gui for ffmpeg. Moving you to our linux section.
    Quote Quote  

Similar Threads