VideoHelp Forum

+ Reply to Thread
Results 1 to 25 of 25
Thread
  1. I'm viewing 720p mkv videos on my television, streaming from my laptop via hdmi cable. My television is a 42 inch LG LCD, 1080p, 120HZ, with "tru-motion" technology. The problem is that motion in movies when viewed on the television is somewhat choppy, jerky, stuttering etc. While not unwatchable, it's far from perfect. Tinkering with settings both in VLC and on the television only produces slight improvement. Setting "tru-motion" on high, for example, helps to a certain degree. This however involves setting "de-judder" to 10, which means the "soap-opera effect" is lost. You feel more like you're watching the movie being shot, than watching the movie, if that makes sense. This effect is interesting, but ultimately not desirable. Plus it doesn't help the jerkiness all that much. Also, when viewed on the LCD screen of my laptop, the movies are perfect, not jerky at all. So is the problem with the TV, which one would have thought superior to the laptop screen in terms of delivering smooth motion? I have HD tv, and everything from sports to movies is perfect. So is there any way I can bring mkv movies, in terms of smooth motion, up to the standard of HD TV? Whether it would involve changing settings on the TV, on VLC, or anything else, or, on the other hand, if I simply have to live with what I've got, any input would be very much appreciated.
    Quote Quote  
  2. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Do you have an HDMI connected DVD or Blu-Ray player to compare? What happens when you play a movie?

    Post the mediainfo specs on the file that plays jerky. If it is 24p, how are you setting the display card out? 1080 60p?

    For troubleshooting, lets first figure out what your TV can handle. What is the TV model number? Also any DVD BD player model number?

    While you are at it, describe the computer and display card.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  3. Set the computer to output 1080i30, not 1080p60. The motion interpolation on the TV probably doesn't work with 1080p60 input.
    Quote Quote  
  4. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by jagabo View Post
    Set the computer to output 1080i30, not 1080p60. The motion interpolation on the TV probably doesn't work with 1080p60 input.
    That is my guess too but how does the player app/display card handle a 24p source file?
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  5. Originally Posted by edDV View Post
    Originally Posted by jagabo View Post
    Set the computer to output 1080i30, not 1080p60. The motion interpolation on the TV probably doesn't work with 1080p60 input.
    That is my guess too but how does the player app/display card handle a 24p source file?
    They duplicate frames in a 3:2 repeat pattern for 60p output. They perform the usual 3:2 pulldown for interlaced output.
    Quote Quote  
  6. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by jagabo View Post
    Originally Posted by edDV View Post
    Originally Posted by jagabo View Post
    Set the computer to output 1080i30, not 1080p60. The motion interpolation on the TV probably doesn't work with 1080p60 input.
    That is my guess too but how does the player app/display card handle a 24p source file?
    They duplicate frames in a 3:2 repeat pattern for 60p output. They perform the usual 3:2 pulldown for interlaced output.
    They are supposed to but are they? That is why I want him to confirm a DVD/BD player connected HDMI works for that TV.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  7. I'm sorry but I'm very much a beginner with this stuff. After researching on google, I still can't figure out how to change the computer's video output. I have looked over everything in "graphics properties", and can't find anywhere where I would be able to make a change from a 1080p60 setting to a 1080i30 setting. As far as the display card, I'm not even sure what that is, and thus where I would find the information needed to give a description of it. The only dvd player I have access to right now is the one on my computer. The TV is an LG, LK520. The computer: Intel Core (TM) i3-2310M 2.10GHz 6.00 GB ram. I am working on the media info specs. Thank you very much for your patience.
    Quote Quote  
  8. Just to see what would happen, I unchecked "IT Content", because it said "Select this box to enable the display to use its own video quality processing algorithms for movies played in full-screen mode to ensure video quality. Clear the box to use Intel HD Graphics driver to ensure video quality". I thought it might help, but in fact it made it much worse. And now, even though I recheck the box, it won't seem to go back to how it was originally. Perhaps I should have left good enough alone.
    Quote Quote  
  9. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    The manual seems to require a serial number. That means they don't want you to see the manual until after you buy the thing.

    The TV seems to be capable of the following input on HDMI

    1280x720p/59.94 implied
    1920x1080i/29.97 implied
    1920x1080p/24p (24p "real Cinema" 5-5)
    1920x1080p/frame rate spec missing

    Click image for larger version

Name:	47LK520.png
Views:	5256
Size:	52.4 KB
ID:	10004

    While the TV specs were sketchy, I suspect the issues are with the computers.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  10. Are you using the integrated graphics and the Intel driver software? I have an i5 2500K system with integrate dHD 3000 graphics but the setup applet doesn't show any interlaced options. I don't know if that's because the driver is hiding settings the monitor (standard DVI computer monitor) can't handle or if the driver simply doesn't have the ability.
    Quote Quote  
  11. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by thekenoshakid View Post
    Just to see what would happen, I unchecked "IT Content", because it said "Select this box to enable the display to use its own video quality processing algorithms for movies played in full-screen mode to ensure video quality. Clear the box to use Intel HD Graphics driver to ensure video quality". I thought it might help, but in fact it made it much worse. And now, even though I recheck the box, it won't seem to go back to how it was originally. Perhaps I should have left good enough alone.
    Try to find a link to the manual for your specific computer model. The manual should explain display settings. In most cases, a right click on the desktop brings up the display menu as an option. You can also find it in Start-Control Panel-Hardware and Sound.

    The exact menu differs by display chipset. I've got an older XP computer with Intel GMA chipset. The Display Settings window looks like this

    Click image for larger version

Name:	Intel_GMA.png
Views:	4631
Size:	84.4 KB
ID:	10005
    Last edited by edDV; 7th Dec 2011 at 21:36.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  12. Umm, it says "Intel HD Graphics", more specific than that I'm not sure. I can access the display settings; but once there, resolution seems to be the only thing it's allowing you to mess around with.
    Quote Quote  
  13. Your i3 or i5 CPU has a built in graphics device. You probably see this config dialog (from my i5 2500K system):

    Click image for larger version

Name:	config.jpg
Views:	2551
Size:	52.2 KB
ID:	10006

    But unlike on my Nvidia system which is hooked to an HDTV, there are no interlaced settings.
    Quote Quote  
  14. Yeah, that's what I see. So there's nothing I can do?
    Quote Quote  
  15. As noted earlier, I don't know if the lack of interlaced options is because the driver doesn't support interlaced output, or if it's because the applet is hiding them because I don't have a TV hooked up. Look for interlace, 30i, 60i, HDTV, or similar settings.
    Quote Quote  
  16. Also, when viewed on the LCD screen of my laptop, the movies are perfect, not jerky at all.
    Most laptops run at 60Hz refresh. So if you think "movies are perfect" on the laptop, you're probably used to the normal 3:2 judder that North Americans are used to. So if you disable the True Motion on the HDTV, it should look the same as the laptop
    Quote Quote  
  17. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Yes start with "True Motion" off. Use VLC or MPCHC players on the computer so we are all on the same reference.

    Where is that mediainfo text for the file ? There can be many errors in an MKV file.

    You need to give a specific model number for your laptop so we can check the display chipset spec. The model number should be on a label on the bottom of the computer.

    Try playing 60i source like a TV or camcorder capture. Any 480i/1080i source will be 60 fields per second. If your display card is set to 60p, your 60i will be converted to 60p in the display card. See if that plays smoothly. If not there is a processing gap in the computer.

    Next try a 720 60p TV capture. That needs no frame rate conversion. It also should play smoothly.

    Then try 24p progressive movie DVDs. Report what you see on the laptop and TV screen.

    Forget MKV downloads until you know your computer and TV are functioning together.

    If you can borrow a progressive DVD player, we can test the TV directly. Then you can compare computer performance to the DVD player.
    Last edited by edDV; 8th Dec 2011 at 12:39.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  18. jagabo: The jerkiness is not nearly as bad as it is in the video with the circles. The jerkiness I'm referring to occurs mostly with medium shots; i.e. with the camera 10-15 feet away. When the person makes quick movements, for instance with their head or their hands, slow motion takes over for a split second, producing an effect of jerkiness. Something similar does occasionally also occur to the whole shot during long distance panning shots. When the camera is mostly stable, however, there is no jerkiness in long distance shots, even when there is a great deal movement as in a car chase etc. Closeups are also perfect most of time.

    poisondeathray: Even with the tru-motion disabled, there remains a major difference between what's on the laptop screen and what's on the TV screen.

    edDV:
    Laptop model #: Toshia Satellite L755 PSK1WC - 06MO1S

    Quickly, I can tell you that videos shot on a digital camera have no motion problems. Neither do AVIs.

    I'm not sure this is what you're looking for, but here's basic mediainfo information for an mkv file. For what it's worth, all mkv files have the same motion problems, not just this one. (I have no idea if I uploaded that screenshot properly)

    Click image for larger version

Name:	screenshot.jpg
Views:	416
Size:	110.8 KB
ID:	10016
    Quote Quote  
  19. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    For media info, select VIEW then TEXT then copy text here.

    It seems your issues are limited to 24p "film" frame rates right?


    The Toshiba Satellite L755 PSK1WC - 06MO1S with i3-2310M CPU should have adequate hardware for 24p to 60p out if the player uses the hardware. The Intel HD Graphics 3000 features are integral to the i3 Sandybridge chip.

    Try the MPCHC player and see if it defaults to DXVA mode (hardware assist). That should play 24p source correctly* to 60p out. Alternately the display settings should allow a 60i output setting.

    * that would be 24p 3x then 2x frame repeats to 60p.
    Last edited by edDV; 8th Dec 2011 at 19:23.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  20. Originally Posted by thekenoshakid View Post
    The jerkiness is not nearly as bad as it is in the video with the circles.
    That video was made specifically to highlight the problem, very high contrast, sharp geometric objects, medium speed panning. Most 24p and 30p videos will not look that bad.

    Originally Posted by thekenoshakid View Post
    The jerkiness I'm referring to occurs mostly with medium shots; i.e. with the camera 10-15 feet away. When the person makes quick movements, for instance with their head or their hands, slow motion takes over for a split second, producing an effect of jerkiness. Something similar does occasionally also occur to the whole shot during long distance panning shots. When the camera is mostly stable, however, there is no jerkiness in long distance shots, even when there is a great deal movement as in a car chase etc. Closeups are also perfect most of time.
    Those sound more like tru-motion (motion interpolation) errors.
    Quote Quote  
  21. MPCHC player says "playing DXVA". The problem persists though. Basically, it seems like there are simply periodic, 1 or 2 second bouts of slow motion, every ten seconds perhaps. It's possible these are ultimately unrelated to whether or not a specific type of motion is going on on the screen. Rather, it is most likely simply that during certain types of motion the slow motion effect becomes perceptible. I suspect the issue is more subtle than you guys are imagining. For instance, I had to watch for over twenty minutes in order to determine for sure that MPCHC was in fact no better than VLC. In the "tru-motion" settings, there is "de-judder" and "de-blur", each from 1-10. I've tried every combination, and it doesn't help. Anyway, since in the end the product is not unwatchable, don't worry for too much longer about this issue. Thanks for all the help you've offered.
    Quote Quote  
  22. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    That brings us back to source file problems. Do movie DVDs look better? Real store bought DVDs.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  23. A store bought dvd played on the laptop and streamed to the tv plays with no motion problems, much like an AVI file. There is no struggling, like with the mkv. At this time I don't have access to a separate dvd player.



    If it's still relevant, here is the mediainfo information for an mkv file:

    General
    Unique ID : 252967016981292005613709598924349613680 (0xBE4FACE01C594664BBDA5F1E226FA670)
    Complete name :
    Format : Matroska
    Format version : Version 2
    File size : 1.62 GiB
    Duration : 2h 9mn
    Overall bit rate : 1 800 Kbps
    Encoded date : UTC 2010-11-19 15:18:26
    Writing application : mkvmerge v4.4.0 ('Die Wiederkehr') built on Oct 31 2010 21:52:48
    Writing library : libebml v1.0.0 + libmatroska v1.0.0
    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L3.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 4 frames
    Muxing mode : Header stripping
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 2h 9mn
    Nominal bit rate : 1 639 Kbps
    Width : 1 280 pixels
    Height : 704 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Variable
    Frame rate : 23.976 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.076
    Writing library : x264 core 107
    Encoding settings : cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=2 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=0 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=1639 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
    Language : English
    Default : Yes
    Forced : No
    Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
    Transfer characteristics : BT.709-5, BT.1361
    Matrix coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177
    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : A_AAC
    Duration : 2h 9mn
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Language : English
    Default : Yes
    Forced : No
    Text #1
    ID : 3
    Format : UTF-8
    Codec ID : S_TEXT/UTF8
    Codec ID/Info : UTF-8 Plain Text
    Language : Danish
    Default : No
    Forced : No
    Text #2
    ID : 4
    Format : UTF-8
    Codec ID : S_TEXT/UTF8
    Codec ID/Info : UTF-8 Plain Text
    Language : Finnish
    Default : No
    Forced : No
    Text #3
    ID : 5
    Format : UTF-8
    Codec ID : S_TEXT/UTF8
    Codec ID/Info : UTF-8 Plain Text
    Language : Norwegian
    Default : No
    Forced : No
    Text #4
    ID : 6
    Format : UTF-8
    Codec ID : S_TEXT/UTF8
    Codec ID/Info : UTF-8 Plain Text
    Language : Swedish
    Default : No
    Forced : No
    Quote Quote  
  24. I have this exact same problem with the same TV. Was any solution found ?
    Quote Quote  



Similar Threads