VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy a VSO converter software :)
+ Reply to Thread
Results 1 to 23 of 23
Thread
  1. I am using the above to capture uncompressed AVI from my NTSC Hi8 machine. This works well, but I do have a query...

    When I play the captured AVI through any player (VLC, Windows Media Player for example) onto my computer screen, the output appears to be interlaced, so it looks like these don't automatically recognise that the file is interlaced. When I use GSpot on the file, it is showing the frame rate as 29.97, but is not showing any field rate (which I'd have thought should be showing 59.94).

    I find this strange as when I used the Canopus ADVC-55 to capture the video as DV, VLC and WMP would automatically deinterlace, and in GSpot it would show as 29.97frames with 59.94fields.

    Anybody know if I'm doing anything wrong?

    I'm hoping to archive all my Hi8 tapes, so thought that capturing them using VirtualDub and something like Huffyuv would be the way to go, but am worried that the captured video file not "advertising" itself as interlaced could be a problem, especially when I get around to editing all that video and converting it to other formats.
    Quote Quote  
  2. AVI doesn't really support interlaced video. Individual codecsused within AVI (like DV) can signal the video is interlaced but only if the receiver knows how to look for it. If your editor doesn't automatically detect the video is interlaced you can usually just override what it thinks of the video by setting the source properties.
    Quote Quote  
  3. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by kauri View Post
    I am using the above to capture uncompressed AVI from my NTSC Hi8 machine. This works well, but I do have a query...

    When I play the captured AVI through any player (VLC, Windows Media Player for example) onto my computer screen, the output appears to be interlaced, so it looks like these don't automatically recognise that the file is interlaced. When I use GSpot on the file, it is showing the frame rate as 29.97, but is not showing any field rate (which I'd have thought should be showing 59.94).
    Let me parse this.

    First BMI only caps interlace so it is up to you to identify the cap file as interlace and the field order prior to recode.

    Wait! I think you mistook BMI as a consumer product. It caps to an intermediate file intended to be encoded to a different distribution format. The technician is expected to manage the encode.

    Be back later but it would help to better describe your capture settings.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  4. Thanks for the quick response!

    I've taken some screen captures of the settings: VirtualDub compression settings, gspot of AVI produced, part of video played in WMP, and Blackmagic settings in VirtualDub (the screen says PAL, but I did use NTSC for this capture).
    Image Attached Thumbnails Click image for larger version

Name:	1.png
Views:	143
Size:	73.7 KB
ID:	9519  

    Click image for larger version

Name:	2.png
Views:	174
Size:	263.3 KB
ID:	9520  

    Click image for larger version

Name:	3.png
Views:	203
Size:	125.6 KB
ID:	9521  

    Image Attached Images  
    Last edited by kauri; 8th Nov 2011 at 21:06.
    Quote Quote  
  5. Your attachments don't work, but everything sounds fine

    It's normal for WMP not to automatically deinterlace huffyuv/AVI

    You didn't mention this, but the aspect ratio is probably wrong as well. That's normal too. It probably plays as square pixel instead of 4:3 or 16:9. (things probably look slightly distorted, like a circle looks like an oval)

    These things are interpreted in the editing software
    Quote Quote  
  6. Originally Posted by poisondeathray View Post
    Your attachments don't work,
    Each of the 4 attachments is a link to the file. They worked for me.
    Edit: Fixed now

    Originally Posted by poisondeathray View Post
    It's normal for WMP not to automatically deinterlace huffyuv/AVI
    Same thing seems to happen, though, if I choose uncompressed AVI

    My main worry is that the editing software (like Adobe Premiere Pro) is not going to permit me to properly edit the video as it may not recognise the file as an NTSC interlaced AVI file.
    Last edited by kauri; 8th Nov 2011 at 21:08.
    Quote Quote  
  7. Maybe you get the new member preferred treatment

    This is what is says for me
    "Invalid Attachment specified. If you followed a valid link, please notify the administrator"

    It will work fine for premiere pro. You right click the files in the clip bin and interpet the file , both the aspect ratio and field order. This is standard procedure for many intermediate file types like huffyuv, lagarith, etc... most editing programs assume square pixel for AVI
    Quote Quote  
  8. mmm... In Adobe Pro v7 I only get as per attachment. Nothing about field order.
    Image Attached Thumbnails Click image for larger version

Name:	1.png
Views:	661
Size:	53.8 KB
ID:	9506  

    Quote Quote  
  9. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    So this is huffyuv?

    A Hi8 cap to huffyuv should have a PAR of 0.9091.

    Next you edit/filter, then export encode.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  10. HuffYUV and uncompressed YUV/RGB have no way of signalling interlaced and aspect ratio. And the AVI container doesn't have interlace or aspect ratio information. So you have to manually specify the video is interlaced, the field order, and the aspect ratio when you import them into an editor.
    Last edited by jagabo; 8th Nov 2011 at 09:04.
    Quote Quote  
  11. Originally Posted by kauri View Post
    mmm... In Adobe Pro v7 I only get as per attachment. Nothing about field order.
    I can see that attachment, but maybe the older version doesn't have those options ? Those options are available in CS4 - CS5.5 for certain
    Quote Quote  
  12. Yes, looks like the newer CS has that capability. Unfortunately insufficient funds to upgrade . So to summarise:
    - uncompressed or huffyvu/lagarith compressed interlaced video AVI files do not contain information to indicate that they are actually interlaced (with two fields in every frame).
    - the editing software needs to determine if the file is interlaced video.

    Based on the above, I would assume that Adobe Premiere Pro 7, for any effects/transitions, would just apply the transition to each frame instead of each field in the frame? I have played with Adobe Premiere Pro 7 using a BMIP capture through VirtualDub (huffyuv). When I "made the movie" into a DVD compatible file, it looked like WMP knew it was interlaced and played it correctly (without interlacing visible) on the monitor, so things look OK. But I'm not sure what is actually happening 'under the hood', so don't know if I'm getting the best out of it.

    I've also got the Canopus ADVC-55. The video capture files are recognised by Adobe Premiere Pro 7 as NTSC Interlaced Video. So no problems there. But I understand that DV-AVI, as it is compressed and for other reasons, does not produce the same quality output as capturing uncompressed. Hence my reason for going the Blackmagic Intensity Pro route. But if it means spending more money to get editing software that can recognise AVI files as interlaced, I might as well have stayed with the Canopus solution.
    Quote Quote  
  13. Originally Posted by kauri View Post
    I would assume that Adobe Premiere Pro 7, for any effects/transitions, would just apply the transition to each frame instead of each field in the frame?
    Just a guess: it may depend on your project setting. Interlaced project assumes interlaced sources. Progressive project assumes progressive sources.

    Originally Posted by kauri View Post
    I've also got the Canopus ADVC-55. The video capture files are recognised by Adobe Premiere Pro 7 as NTSC Interlaced Video.
    Most programs know how to query the DV data for interlace status.
    Quote Quote  
  14. Originally Posted by jagabo View Post
    Just a guess: it may depend on your project setting. Interlaced project assumes interlaced sources. Progressive project assumes progressive sources.
    Ah.. if your guess is correct, then I have nothing to worry about, unless I get the field order wrong.
    Quote Quote  
  15. One last query...
    I note that the Intensity Pro captures D1 NTSC at 720x486. Am I better off leaving the capture at these dimensions, or would it hurt if I crop off the bottom 6 pixels (which is rubbish noise anyway) to bring it to 720x480 while capturing through VirtualDub?
    Quote Quote  
  16. I'd crop it down to 720x480 because that's the norm for most applications.
    Quote Quote  
  17. Thanks all for your patience...
    Now for the last last query
    I contacted Blackmagic tech support regarding NTSC AVI field order and they indicated that the card captures TFF. To confirm, I used AVISynth with VirtualDub:

    AVISource("movie.avi")
    AssumeTFF()
    separatefield()
    When playing back through VirtualDub frame by frame, the motion was jerky (one frame forward, next frame back a bit). When I redid with AssumeBFF, the motion was smooth. This leads me to believe the card captures interlaced BFF, and not TFF

    Can anyone confirm if the Blackmagic Intensity Pro captures NTSC interlaced BFF or TFF?
    Quote Quote  
  18. Your experiment with AviSynth is definitive.
    Quote Quote  
  19. You can capture directly in h264 using virtualdub, h264 supports interlaced. I use this settings for NTSC SD with my blackmagic

    Click image for larger version

Name:	virtualdub.jpg
Views:	174
Size:	133.7 KB
ID:	9730

    But with PAL you need to change the SAR , use the ARS Calculator for a properly aspect ratio on PAL material.
    The extra commands if you can't see it are:

    --interlaced --bff
    Last edited by henryperu77; 22nd Nov 2011 at 00:59.
    Quote Quote  
  20. Originally Posted by kauri View Post
    Thanks all for your patience...
    Now for the last last query
    I contacted Blackmagic tech support regarding NTSC AVI field order and they indicated that the card captures TFF. To confirm, I used AVISynth with VirtualDub:

    AVISource("movie.avi")
    AssumeTFF()
    separatefield()
    When playing back through VirtualDub frame by frame, the motion was jerky (one frame forward, next frame back a bit). When I redid with AssumeBFF, the motion was smooth. This leads me to believe the card captures interlaced BFF, and not TFF

    Can anyone confirm if the Blackmagic Intensity Pro captures NTSC interlaced BFF or TFF?

    SD is BFF but HD is TFF
    Quote Quote  
  21. Yes, Blackmagic support has confirmed that NTSC SD is BFF.
    Quote Quote  
  22. Member
    Join Date
    Jul 2001
    Location
    United States
    Search Comp PM
    kauri,

    You've mentioned that you're expecting your file to be NTSC (post #4) yet from your attachments you've got the BMIP set to PAL.
    Have a good one,

    neomaine

    NEW! VideoHelp.com F@H team 166011!
    http://fah-web.stanford.edu/cgi-bin/main.py?qtype=teampage&teamnum=166011

    Folding@Home FAQ and download: http://folding.stanford.edu/
    Quote Quote  
  23. Yes, I know. I did indicate in that post that I did actually use NTSC for the capture...
    Originally Posted by kauri View Post
    .... (the screen says PAL, but I did use NTSC for this capture).
    Quote Quote  



Similar Threads