VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 20 of 20
Thread
  1. The Oct 31st release apparently has a apple prores encoder! This sounds like great news!

    But what commandline would I use to convert a file to prores. Can't find anything in the docs.

    Thanks!
    Guiboche
    Quote Quote  
  2. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by Guiboche View Post
    The Oct 31st release apparently has a apple prores encoder! ...
    Yup, it's in there.

    Code:
    ffmpeg -codecs | grep -i Apple
    ffmpeg version N-34354-g0b3e9d5
    ....
     DEV D  prores          Apple ProRes
    Quote Quote  
  3. -vcodec prores

    seems to work

    e.g.

    ffmpeg -i input.mov -vcodec prores -acodec copy output.mov

    I tested on some 10-bit 422 v210 inputs, and it seems ok
    Quote Quote  
  4. Awesome! It works wonderfully

    Is it possible to choose which version of prores? HQ, LT, PROXY, etc?
    Guiboche
    Quote Quote  
  5. Originally Posted by Guiboche View Post
    Is it possible to choose which version of prores? HQ, LT, PROXY, etc?

    Doesn't look like it . At least not yet

    Prores must have been one of the most requested things the last 4-5 years for ffmpeg
    Quote Quote  
  6. Originally Posted by poisondeathray View Post
    Originally Posted by Guiboche View Post
    Is it possible to choose which version of prores? HQ, LT, PROXY, etc?

    Doesn't look like it . At least not yet

    Prores must have been one of the most requested things the last 4-5 years for ffmpeg
    Your telling me!

    Having the ability to encode prores on a pc is a tiny milestone

    Thank you both for your help.

    I will wait and watch when/if the other codec versions become available.
    Guiboche
    Quote Quote  
  7. Yes that's huge

    It looks like the current one might be the LT version ... Filesizes seem very small compared to DNxHD... have to do some more tests

    But even decoding prores is a recent ffmpeg development, less than a few weeks
    Quote Quote  
  8. Now that you mention it, it does look like the LT only version. SD should be around 50mb/sec, but I'm getting 30mb/sec (LT rates).

    I'm not sure if this doc is even related, but I found it on FFMPEG.org. It lists all the prores versions, but I don't know if I can choose which to use.

    http://ffmpeg.org/doxygen/trunk/proresenc_8c.html
    Guiboche
    Quote Quote  
  9. Hmm. Maybe I take that back. I tested some other clips, and some of them are larger than 175Mb/s for a 1080p23.976 clip. Might be content related, but from past experience, I find that prores and the equivalent dnxhd version have similar bitrates

    The fourcc from the current ffmpeg prores exports is "apcn" which correlates with prores "standard"

    There is prores 4444 variant as well, but I don't think it's supported by ffmpeg yet (for decoding either)


    ffmpeg's dnxhd encode is 8bit version, but it looks like the prores encode is the true 10-bit. Have to do some more tests to confirm this
    Quote Quote  
  10. Hmmmm. Not sure what to make of it.

    The prores export seems to cause more banding - this suggests the 10bit data truncated somewhere from a 10bit source when looking at gradients



    EDIT: might be a windows QT prores decoder issue

    v210 => ffmpeg prores => look using quicktime = banding

    but v210 => ffmpeg prores => ffmpeg v210 , there is no extra banding when examined through quicktime , and amplified difference masks only show the normal compression losses
    Last edited by poisondeathray; 3rd Nov 2011 at 15:43.
    Quote Quote  
  11. Originally Posted by poisondeathray View Post
    Hmmmm. Not sure what to make of it.

    The prores export seems to cause more banding - this suggests the 10bit data truncated somewhere from a 10bit source when looking at gradients



    EDIT: might be a windows QT prores decoder issue

    v210 => ffmpeg prores => look using quicktime = banding

    but v210 => ffmpeg prores => ffmpeg v210 , there is no extra banding when examined through quicktime , and amplified difference masks only show the normal compression losses
    The Windows QT decoder has a notorious history of never displaying the correct colours anyhow. Haha.

    To confirm this is indeed the NORMAL prores version (not, HQ or any others).

    I was able to convert a clip ON A PC to Apple Prores then successfully import it into Final Cut Pro with no problems. YAY!

    Big deal indeed!
    Guiboche
    Quote Quote  
  12. The different "flavours" (not 4444) are available with -profile

    Profile values are 0,1,2,3- where 3 is HQ mode. (0 is proxy).

    eg. -vcodec prores -profile 2 - this will produce normal mode.

    Note that bitrates are higher than for Apple one (about 30%), but also quality is better. Speed is not that great, because it's not multithreaded yet- but I assume it will be.
    http://forum.doom9.org/showthread.php?p=1538476#post1538476

    If you scroll down in the main thread, apparently some multithreading is implemented now, if you have a recent compile
    Quote Quote  
  13. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    Too bad there exists no VfW interface for the damn codec ( ¿yet? )
    Quote Quote  
  14. I had to encode some video for the Tribeca film festival. The requirements are:

    Quicktime ProRes 422 HQ (.mov) 1920x1080, 23.98psf, 25p, 50i, 59.94i Audio: 24 bit, 48Hz, Little Endian, Dual Channel (LtRt)

    I achieved this (I think) in Windows 7 with FFMPEG and the following string:

    ffmpeg -i INPUT.mov -vcodec prores -profile:v 3 -acodec pcm_s24le OUTPUT.mov

    FFMPEG is quite a remarkable piece of software.
    Last edited by sdnsdf; 5th Jun 2012 at 00:08. Reason: Correction to the ffmpeg string changed a "1" to a "l" and "profile" to "profile:v".
    Quote Quote  
  15. Member
    Join Date
    Mar 2012
    Location
    Seattle, WA
    Search PM
    We needed to render my son's Sony Vegas-edited film to ProRes 422 format for festivals. We figured out a workflow that takes the film straight from the editor. It should work for Windows Adobe Premiere, too. Here is a YouTube tutorial showing the rendering step. There are also full written instructions.



    Instructions: http://slugco.com/meta/ProResOnWindows/

    - Carl
    Quote Quote  
  16. Member
    Join Date
    May 2012
    Location
    Finland
    Search Comp PM
    The YouTube video tutorial above helped a lot, thanks! I'm using Sony Vegas 11 Pro as well so that really did the trick!

    I'm just wondering what's the correct switch for ProRes422 HQ profile, because once I put the "-profile 3" on the command line, I get a warning message in yellow color:

    "Please use -profile:a or -profile:v, -profile is ambiguous"

    My target is to end up with a .mov file that'll contain ProRes422 HQ profile 1080P video @ 25FPS and an uncompressed 16-bit/48kHz stereo audio track.

    The string I use in ffmpeg is:

    ffmpeg -i inpufile.avs -r 25.000 -vcodec prores -profile 3 -acodec copy outputfile.mov

    As for now, the main issue I'm experiencing is that I seem to be unable to have FrameServer/ffmpeg render the output file's audio at a 48kHz sample rate.

    The "-acodec copy" switch is to have uncompressed PCM stereo audio in the output file, matching the original project audio settings. However, what worries me is that the audio isn't being rendered nor recognized by ffmpeg as being 48 kHz, even though I've set the main sample rate from project properties within Vegas to 48kHz. I'm wondering if this is a bug/flaw in FrameServer itself, since the "Render As"-menu in Sony Vegas shows FrameServer's audio output at 44.1kHz sample rate although the project is with a 48kHz sample rate.

    Also, ffmpeg recognizes the audio stream coming from Frameserver as 44.1kHz instead of 48kHz so it's not just the Vegas render menu that seems to show an incorrect project sample rate. Would be nice to know if someone has a workaround to this one. My only guess is that there's a bug in FS that causes the output sample rate to get stuck in 44.1kHz.

    It's possible to force ffmpeg to change the output sample rate to 48kHz by adding -ar 48000 switch into the command line, but I don't think that's a good idea since ffmpeg recognizes the input stream as 44.1kHz - this would probably just lead to audio sync problems.

    If anyone has any hints or suggestions to this issue, I'd highly appreciate all help I can get!
    Last edited by LensLude; 10th May 2012 at 18:50.
    Quote Quote  
  17. Originally Posted by LensLude View Post
    I'm just wondering what's the correct switch for ProRes422 HQ profile, because once I put the "-profile 3" on the command line, I get a warning message in yellow color:

    "Please use -profile:a or -profile:v, -profile is ambiguous"
    In some ffmpeg builds, the syntax might be slightly different.

    It might be -profile hq

    For example, ffmbc uses this syntax for prores
    http://code.google.com/p/ffmbc/wiki/ProResEncoding



    For the audio sampling rate, I'll have a quick look and report back
    Quote Quote  
  18. Originally Posted by LensLude View Post

    As for now, the main issue I'm experiencing is that I seem to be unable to have FrameServer/ffmpeg render the output file's audio at a 48kHz sample rate.

    The "-acodec copy" switch is to have uncompressed PCM stereo audio in the output file, matching the original project audio settings. However, what worries me is that the audio isn't being rendered nor recognized by ffmpeg as being 48 kHz, even though I've set the main sample rate from project properties within Vegas to 48kHz. I'm wondering if this is a bug/flaw in FrameServer itself, since the "Render As"-menu in Sony Vegas shows FrameServer's audio output at 44.1kHz sample rate although the project is with a 48kHz sample rate.

    Also, ffmpeg recognizes the audio stream coming from Frameserver as 44.1kHz instead of 48kHz so it's not just the Vegas render menu that seems to show an incorrect project sample rate. Would be nice to know if someone has a workaround to this one. My only guess is that there's a bug in FS that causes the output sample rate to get stuck in 44.1kHz.

    It's possible to force ffmpeg to change the output sample rate to 48kHz by adding -ar 48000 switch into the command line, but I don't think that's a good idea since ffmpeg recognizes the input stream as 44.1kHz - this would probably just lead to audio sync problems.

    If anyone has any hints or suggestions to this issue, I'd highly appreciate all help I can get!

    It's working for me, audio is detected as 48Khz in ffmpeg

    I know you said you did this already, but make sure in vegas' project properties, audio tab, that it is set to 48Khz and don't forget to push apply and ok

    Another way you can check is open the dummy avi with avisynth using AVISource() and use info() to verify that it is indeed 48Khz
    Image Attached Thumbnails Click image for larger version

Name:	fs.jpg
Views:	10131
Size:	23.3 KB
ID:	12386  

    Quote Quote  
  19. Member
    Join Date
    May 2012
    Location
    Finland
    Search Comp PM
    Originally Posted by poisondeathray View Post
    It's working for me, audio is detected as 48Khz in ffmpeg

    I know you said you did this already, but make sure in vegas' project properties, audio tab, that it is set to 48Khz and don't forget to push apply and ok

    Another way you can check is open the dummy avi with avisynth using AVISource() and use info() to verify that it is indeed 48Khz
    Yeah, I indeed made sure that audio is set to 48khz and applied the changes, but still no luck. If I may ask, what version of Vegas are you using? Is it the 32 or the 64-bit version? How about ffmpeg, what build/version do you use? Thanks for the help.
    Quote Quote  
  20. I did that test on 32bit build of vegas 9

    ffmpeg from zeranoe
    http://ffmpeg.zeranoe.com/

    If it's a bug with that build of vegas or frameserver, you can export a lossless intermediate from vegas (e.g. lagarith with uncompressed audio) , then use ffmpeg
    Quote Quote  



Similar Threads