VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 24 of 24
Thread
  1. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    I do use mencoder allot but some times I want to use ffmpeg.
    and I did download the latest from Zeranoe.

    libxvid does not work anymore.
    -vcodec libxvid but it say unknown decoder.
    how to use xvid.
    how to enable libxvid.

    I also have -b for bitrate but it say please use -b:a or -b:v
    what do they mean.

    can anyone help me please
    Quote Quote  
  2. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by PsyDonias View Post
    how to enable libxvid.
    Hi
    Use command:-
    Code:
    ffmpeg -codecs
    It's enabled if this is on the list:-

    EV libxvid libxvidcore MPEG-4 part 2
    Quote Quote  
  3. Member
    Join Date
    Sep 2008
    Location
    United States
    Search Comp PM
    looks like a decoder problem not encoder.


    x264, xvid are generally enabled in all ffmpeg versions
    Quote Quote  
  4. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    Originally Posted by bat999 View Post
    Originally Posted by PsyDonias View Post
    how to enable libxvid.
    Hi
    Use command:-
    Code:
    ffmpeg -codecs
    It's enabled if this is on the list:-

    EV libxvid libxvidcore MPEG-4 part 2

    this line is with.
    EV libxvid libxvidcore MPEG-4 part 2

    so how can i solve the problem.


    Originally Posted by chicken264 View Post
    looks like a decoder problem not encoder.


    x264, xvid are generally enabled in all ffmpeg versions

    the line say EV that say Encoder and video codec.




    Codecs:
    D..... = Decoding supported
    .E.... = Encoding supported
    ..V... = Video codec
    ..A... = Audio codec
    ..S... = Subtitle codec
    ...S.. = Supports draw_horiz_band
    ....D. = Supports direct rendering method 1
    .....T = Supports weird frame truncation
    ------
    Quote Quote  
  5. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by PsyDonias View Post
    so how can i solve the problem.
    What problem?
    Quote Quote  
  6. Member
    Join Date
    Oct 2010
    Location
    England
    Search Comp PM
    Originally Posted by PsyDonias View Post
    libxvid does not work anymore.
    -vcodec libxvid
    This command is used to set the encoding codec.

    but it say unknown decoder.
    As chicken264 has said, the error looks to be a decoding issue.

    To get more help you need to post all the ffmpeg parameters you're using, and also the actual error message that it's returning.

    I also have -b for bitrate but it say please use -b:a or -b:v
    It looks like the ffmpeg developers are changing the command line options again... -b:a and -b:v don't work for me. Try -vb for the video bitrate and -ab for the audio bitrate. This works on my version of ffmpeg (Oct 2011).

    For example -vb 2000k -ab 192k
    Quote Quote  
  7. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    This is the ffmpeg line

    ffmpeg.exe -b 2000k -vcodec libxvid -acodec ac3 -ab 448k -ac 6 -y -vf scale=720:400 -i input.mkv "output.avi"

    it maybe should look like this for the bitrate and now how to get libxvid to work.

    ffmpeg.exe -vb 2000k -vcodec libxvid -acodec ac3 -ab 448k -ac 6 -y -vf scale=720:400 -i input.mkv "output.avi"
    Quote Quote  
  8. Member
    Join Date
    Sep 2007
    Location
    Europe
    Search PM
    The command position has become more critical in recent FFmpeg versions.

    You have -vcodec before the input. Try it this way...

    ffmpeg.exe -i input.mkv -vb 2000k -vcodec libxvid -acodec ac3 -ab 448k -ac 6 -y -vf scale=720:400 "output.avi"
    This is perhaps also why it says "unknown decoder" because everything before the input now concerns the source (input).

    You can also try to use -codec:v which is the new syntax where v stands for video, so -codec:a is for audio.
    Quote Quote  
  9. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    thanks will try that.
    That could explain thing that it should be in the right order.
    Chris should it be like this.
    -codec:v 2000 or -codecc:v=2000
    Quote Quote  
  10. Member
    Join Date
    Sep 2007
    Location
    Europe
    Search PM
    -codec:v libxvid and -b:v 2000k for video.

    -codec:a ac3 and -b:a 448k for audio.

    You can even use -c:v libxvid and -c:a ac3 but I prefer to use -codec for clarity.
    Quote Quote  
  11. Member
    Join Date
    Oct 2010
    Location
    England
    Search Comp PM
    Originally Posted by Chris K View Post
    You can even use -c:v libxvid and -c:a ac3 but I prefer to use -codec for clarity.
    Is there a page with a complete list of these changes and on what versions of ffmpeg they apply to?

    I'm using ffmpeg 0.8.5 (Oct 3 2011 gcc-4_5-branch revision 160292) and it doesn't recognise the new syntax.
    Quote Quote  
  12. Member
    Join Date
    Sep 2007
    Location
    Europe
    Search PM
    Originally Posted by intracube View Post
    Is there a page with a complete list of these changes and on what versions of ffmpeg they apply to?

    I'm using ffmpeg 0.8.5 (Oct 3 2011 gcc-4_5-branch revision 160292) and it doesn't recognise the new syntax.
    http://ffmpeg.mplayerhq.hu/ffmpeg.html#Video-Options

    It says...

    ‘-vcodec codec (output)’

    Set the video codec. This is an alias for -codec:v.
    I use a 0.8.5-git revision of a few days ago and for me all three variants work; -vcodec, -codec:v and -c:v
    Quote Quote  
  13. Member
    Join Date
    Oct 2010
    Location
    England
    Search Comp PM
    Originally Posted by Chris K View Post
    http://ffmpeg.mplayerhq.hu/ffmpeg.html#Video-Options

    It says...

    ‘-vcodec codec (output)’

    Set the video codec. This is an alias for -codec:v.
    I use a 0.8.5-git revision of a few days ago and for me all three variants work; -vcodec, -codec:v and -c:v
    Thanks for that.

    I spent some time with Google, but it was persistent in ignoring my search string and returning unrelated pages.

    It's getting particularly bad at searching for strings with unusual symbols, snippets of code, etc. Quoting doesn't help at all. It's a shame there isn't a 'search for exactly what I've enter' option.
    Quote Quote  
  14. Member
    Join Date
    Sep 2007
    Location
    Europe
    Search PM
    Originally Posted by intracube View Post
    It's getting particularly bad at searching for strings with unusual symbols, snippets of code, etc. Quoting doesn't help at all. It's a shame there isn't a 'search for exactly what I've enter' option.
    I know! I tried it with error messages e.g. given by compilers. Also hardly had any success. Perhaps you have to escape certain characters. Did not try that yet.
    Quote Quote  
  15. Member
    Join Date
    Sep 2008
    Location
    United States
    Search Comp PM
    uploading part of your video may solve the problem quickly.
    Quote Quote  
  16. Member
    Join Date
    Oct 2010
    Location
    England
    Search Comp PM
    Originally Posted by Chris K View Post
    I know! I tried it with error messages e.g. given by compilers. Also hardly had any success. Perhaps you have to escape certain characters. Did not try that yet.
    I also tried explicitly adding a '+', but it didn't help much:
    ffmpeg +"-codec:v"

    The search string above brings up the ffmpeg docs as the first hit. Looking at the cached page (which has search terms highlighted) shows this:
    Name:  google_ffmpeg_search.jpg
Views: 3726
Size:  12.5 KB

    "codec v" isn't what I searched for. Stranger still, the only bit of text on that page highlighted in blue is...

    Click image for larger version

Name:	google_ffmpeg_search_02.jpg
Views:	3170
Size:	7.1 KB
ID:	9321

    Altavista does a better job of finding relevant pages in this instance.
    Quote Quote  
  17. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    Chris thanks.


    chris you maybe also know how to use advanced xvid options with ffmpeg like mpg quant and other stuff.
    Quote Quote  
  18. Member
    Join Date
    Sep 2007
    Location
    Europe
    Search PM
    Originally Posted by PsyDonias View Post
    you maybe also know how to use advanced xvid options with ffmpeg like mpg quant and other stuff.
    Xvid is very poorly supported in FFmpeg. I tried -mpeg_quant 1 but MediaInfo still says matrix: default. It's also FFmpeg that decides which profile to use depending on certain other settings. I tried -mpeg_quant 1 -profile x and with any number I use it switches over from Simple@L3 to Streaming Video@L1. No idea what's happening and how to use it.

    You can however use the -intra_matrix and -inter_matrix commands to set a custom matrix.
    Quote Quote  
  19. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    ok I see.
    I know ffmpeg is very limited. I mosly use mencoder but some times I want to use ffmpeg for a few resons.
    so it is good to know how to use ffmpeg to.

    Thanks for all your help.

    and it did help to have the command in the right order.
    Quote Quote  
  20. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    this has been very helpful for me so I thank for that.
    Now I have two more questions.

    1. if I want to have a silent video convert it with no audio how do I do that

    if I do it without any audio codec I tells some error
    ffmpeg.exe -i "Myinputfile.mp4" -b:v 2000k -codec:v libxvid -aspect 9:5 -y -vf scale=720:400 -vtag XVID "myoutputfile.avi"

    and second how can I use an external soundfile.
    if I have an mp3 or ac3 file on the hdd and want it to be added with no reencoding to the output file.
    like a command -externalaudiofile path\myaudiofile.ac3
    Quote Quote  
  21. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by PsyDonias View Post
    ...
    1. if I want to have a silent video convert it with no audio how do I do that

    if I do it without any audio codec I tells some error
    ffmpeg.exe -i "Myinputfile.mp4" -b:v 2000k -codec:v libxvid -aspect 9:5 -y -vf scale=720:400 -vtag XVID "myoutputfile.avi"
    ...
    Hi
    You need to use "-an" in the command.
    Like this:-
    Code:
    ffmpeg.exe -i "Myinputfile.mp4" -b:v 2000k -codec:v libxvid -aspect 9:5  -y -vf scale=720:400 -vtag XVID -an "myoutputfile.avi"
    Quote Quote  
  22. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    ok thanks.

    its for some home recorded And I don´t want the original sound that was not good some people talking.
    then I want to use and external sound with some music. you maybe know how to do that.
    Quote Quote  
  23. Member bat999's Avatar
    Join Date
    Feb 2008
    Location
    United Kingdom
    Search Comp PM
    Originally Posted by PsyDonias View Post
    And I don´t want the original sound that was not good some people talking.
    then I want to use and external sound with some music.

    Hi

    Use your command with "-an" to create the new file without audio (myoutputfile.avi).

    Then find a music file, a few seconds longer than the video file (soundtrack.mp3).

    Then mux the two like this:-
    Code:
    ffmpeg -i myoutputfile.avi -i soundtrack.mp3 -c copy -shortest mynewoutputfile.avi
    Last edited by bat999; 4th Dec 2011 at 18:39.
    Quote Quote  
  24. Member
    Join Date
    Jul 2010
    Location
    Sweden
    Search PM
    ok
    it was that simple to specify two input.
    thanks.
    Quote Quote  



Similar Threads