VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 17 of 17
Thread
  1. Hi guys hows it going. I'm looking at taking my Death Note DVD rips and encoding them for use and storage on my computer. I didn't expect this to be a particularly difficult task however it would seem that I was very wrong about this. I have spent numerous days on this single problem and it is getting quite frustrating. I am going to try and detail everything I have done/tried so that there is no misunderstanding of facts.

    Overview of what I have done:

    1. I Re-authored the DVD discs with DVD Shrink v3.2 and trimmed the main video file to keep the VOB files for each individual episode (without the Intro/Outro). I did this with no compression so it was a direct copy. I have uploaded a short segment of the VOB file via mediafire here.

    2. I then proceeded to demux the video/audio tracks using DGIndex v1.5.8 and under the video tab I set the Field Operation as "Honor Pulldown Flags".

    3. I then imported the resulting .m2v video file into TMPGEnc Video Mastering Works v5.0.6.38 and applied my desired color/sharpening filters. I plan on encoding each episode using TMPG.

    4. The m2v file is reported as having an interlaced framerate of 29.97 fps and after inspecting the fields I can conclude that the the video was originally filmed at 23.976 fps and has been Telecined up to 29.97 fps (no surprise, this is what you would expect from an anime that aired on TV). The interlacing order is Top Field First (TFF).

    Just to be clear, what I see on the video is this pattern:

    AA
    BB

    BC
    CD

    DD
    EE
    FF

    FG
    GH

    HH

    The Problem

    The problem lies in encoding the video to 23.976 without any judder/artifacts. TMPG has its own de-interlacing filter under the filter tab and I have tried every combination of settings under the de-interlacing filter (theres 50 combinations) and NONE of them have a non-judder image throughout the entire episode. Some settings would result in perfect 23.976 progressive frames in certain scenes but other scenes would be a total mess. This is the first time I have had this problem in TMPG and so this led me to believe that the video is the problem and not TMPG.

    After closer inspection of the video file I found that after every scene change (by scene change I mean a 'camera cut') the pattern of the 3:2 pulldown is broken! The new scene still has the same 3:2 pattern as outlined above however it is not consistent with the previous scene. For example this might happen:

    AA
    BB

    BC
    CD

    (scene change)
    DE
    EF

    FF
    GG
    HH


    You can see here that the 3:2 pattern is broken, this happens at every single scene change. This is why a simple Inverse Pulldown filter will not work, the pattern is inconsistent. I have just started trying to learn Avisynth and have attempted to use some of the standard IVTC filters without any success. I have read numerous posts across the internet in an attempt to find someone with a similar problem that yielded an acceptable solution but I havent been able to find one yet.


    And so I turn to you, my knowledgeable internet brethren, in the hope that a solution to this problem might be found.
    Last edited by Corpsecreate; 6th Oct 2011 at 04:08.
    Quote Quote  
  2. By honoring the pulldown flags in step 2, you have created the problem you are trying to solve. Reverse that, and you should get the original video you are attempting to re-create.
    Quote Quote  
  3. I have reversed that option and I still had plenty of problems. How do you suggest I go about performing the IVTC if I do not honor the pulldown flags? By Avisynth or a TMPG filter?
    Quote Quote  
  4. For this type of pattern, "automatic" filters like TIVTC will get 98% perfect , but there will be occasional duplicate frames surrounding some of the scene changes

    To get it absolutely perfect, you need manual IVTC, maybe with yatta to help speed it up . Occasionally you will have to fill in a frame (maybe with mvtools2/mflowinter). That's a lot of tedious work
    Quote Quote  
  5. Since it's hard telecined you have to make the D2V project file using 'honor pulldown flags'. Your mistake is in trying to use TMPGEnc for the IVTC. It's the simplest thing in the world for any AviSynth IVTC. I used TIVTC for the job and it did it (the sample) perfectly:

    TFM()
    TDecimate(Mode=1)
    Quote Quote  
  6. manono: I got 2/837 duplicates with tfm().tdecimate(mode=1)

    at frames 252,253 and 482,483 on that sample

    I fiddled with various decimate modes, but I noticed you only swap the position of the duplicates (it might come before or after the scenechange; e.g. it might be 481,482 instead)
    Quote Quote  
  7. Yes, I saw the dupes. You can thank the edits for that, the pattern breaks Corpsecreate mentioned. That doesn't mean TIVTC didn't do its job correctly.
    Quote Quote  
  8. I've been fiddling around with a conditional filter to fill in the dupes. It's based on mug funky's fill drops script (auto dupe detection), and john meyer's modified fill drops script

    It only works for this particular sample, only because with mode=1, the duplicates occur AFTER the scene change on those 2 sections (because mvtools is used to interpolate and replace the 2nd duplicate). So on a longer sample you might still get problems

    If the duplicate occurs BEFORE the scenechange (e.g. with TFM.TDecimate() on 481,482), then you will get a blended frame of the before scene and after scene. In this case you would want to replace the 1st of the duplicate pair instead of the 2nd , because mvtools would interpolate from the third last frame of the scene and the last frame of the scene to replace the 2nd last frame

    One of the avisynth gurus might be able to make a blockstatement IF, AND so 2 conditions are met . Maybe with gscript / scriptclip or those other functions. So replace the 1st of the dupe pair IF before a scenechange , but replace the 2nd of a dupe pair IF after a scenechange . This is beyond my programming skills but probably trivial for someone like gavino

    I left show=true in the function to show where a dupe is detected as true for debugging and adjusting the threshold. The difference detection threshold can be adjusted as well. Right now it's "0.5", but it can be adjusted

    Code:
     
    MPEG2Source("VTS_01_1.d2v", cpu=0)
    AssumeTFF()
    TFM()
    TDecimate(mode=1)
    FillDrops2()
     
     
    function filldrops2 (clip c)
    {
    even = c
    super_even=MSuper(even,pel=2)
    vfe=manalyse(super_even,truemotion=true,isb=false, delta=1)
    vbe=manalyse(super_even,truemotion=true,isb=true,delta=1)
    filldrops_e = mflowinter(even,super_even,vbe,vfe,time=50)
    ConditionalFilter(even, filldrops_e, even, "YDifferenceFromPrevious()", "lessthan", "0.5", show=true)
    }
    Last edited by poisondeathray; 6th Oct 2011 at 11:12.
    Quote Quote  
  9. Originally Posted by manono View Post
    Since it's hard telecined you have to make the D2V project file using 'honor pulldown flags'. Your mistake is in trying to use TMPGEnc for the IVTC. It's the simplest thing in the world for any AviSynth IVTC. I used TIVTC for the job and it did it (the sample) perfectly:

    TFM()
    TDecimate(Mode=1)
    I havent tested this script with the sample but I tried this on the whole clip. The result still had quite a lot of judder in most high motion scenes.

    Another interesting thing I have noticed is when I playback my avs script in MPC, the judder is not consistent. Sometimes a particular scene will be bad but if I click back and rewatch the scene its fine. I would think this has something to do with the filters ability to 'lock onto' the 3:2 pattern?
    Last edited by Corpsecreate; 6th Oct 2011 at 12:25.
    Quote Quote  
  10. I can only speak for the sample. If there are any real 29.97fps parts, then of course they'll play jerky. If you want to upload a section you don't think IVTC's well, go ahead. AviSynth IVTCs don't work by 'locking onto' a pattern. TMPGEnc's does, which is why no one with any sense has been using it to IVTC anime for what... 10 years or so? If the pattern changes, you're screwed.
    Quote Quote  
  11. Member rickydavao's Avatar
    Join Date
    Jun 2007
    Location
    Victoria, Canada
    Search Comp PM
    Having converted the Death Note DVD's to mkv previously, I might be able to shed some light. I personally use avisynth with animeivtc to get the job done. For example:

    MPEG2Source("VTS_01_1.d2v")
    Animeivtc(mode=1, aa=0, precision=3, killcomb=2)

    Animeivtc can be a bit tricky to learn. The example above, exactly as written, worked well for me with Death Note. However, the fun's just starting. While the opening credits will work as above, the closing credits will not, as they are truly interlaced. So if you use the script above for the entire episode, the closing credits with have some jerkiness and some interlacing artifacts. If you can live with this, great. If not, you will have to encode the closing credits separately (just the credits, do not include the "Next Episode" segment following them) using:

    animeivtc(mode=3, cbob=4, edimode="eedi2", degrain=2, pattern=2)

    This form of animeivtc takes quite a bit longer to process, but if you do your cutting right, you can used these encoded credits afterwards for most of the episodes (since it's always the same). So now basically you'd be encoding the episode, ending credits, and next episode separately, and joining them (1+2+3) when you're done to get the complete episode.

    The only issue would be to get animeivtc working as it has several dependencies that all need to be put into your avisynth folder. I cheated a bit to do this ... I downloaded and installed XviD4PSP ver. 5, and then copied all of it's avisynth plugins from the XviD4PSP directory to my Avisynth plugins directory (since XviD4PSP used animeivtc), and then uninstalled XviD4PSP afterwards. Other users may have a simpler solution for you.
    Quote Quote  
  12. He removed the opening, the preview, and the end credits. He's only working with the individual episodes.
    Quote Quote  
  13. On that sample clip you get similar duplicates in the same areas as TIVTC using the animeivtc settings you suggested

    Maybe that clip isn't representative of other episodes ?
    Quote Quote  
  14. Member rickydavao's Avatar
    Join Date
    Jun 2007
    Location
    Victoria, Canada
    Search Comp PM
    Hmmm. Well, here's my encoding using the settings I outlined above (I'm not an avisynth expert by any means, I just tend to fiddle with the settings until I get something that I can live with ). It's the same clip that the OP posted, but converted from my own copy of the DVD. The only problem that I see (visually) are the two medium speed pans, one of the bridge and the other of the train, which look jerky, but are jerky to begin with on the original DVD. I see this a lot on anime DVD's. Anyways, let me know what you think.
    Image Attached Files
    Quote Quote  
  15. Ricky - Your sample exhibits the same problem, but the duplicates are in slightly different location at 251,252, 484,485

    I mean it's not a huge issue IMO - you can barely see it watching normal speed - but if he wants it "perfect", he needs to use yatta or manual IVTC

    The reason as manono said, is that it was edited as interlaced fields, not progressive frames. So on some scenes at the scenechange there is an orphaned field
    Quote Quote  
  16. So I have encoded all of episode 1 at a really low bitrate with:

    Code:
    TFM()
    TDecimate(mode=1)
    And you can download it here. Could someone check to see if the segment that is shown in the sample has judder depending on playback? What I mean by that is, sometimes when you play it it will be fine, other times it wont. I have this problem and I have no idea why this would be happening.
    Quote Quote  
  17. Originally Posted by poisondeathray View Post
    I mean it's not a huge issue IMO
    And in my opinion it's not an issue at all since those few stray dupe frames aren't even noticeable at those scene changes during real-time playback. Besides, that's not what Corpsecreate is talking about - a few dupes at scene changes. He's talking about jerkiness during playback of whole scenes or parts of scenes. And that issue has nothing at all to do with the IVTC script. It plays smooth as silk for me. If he sometimes gets jerky playback it's for some other reason.

    He even said himself that he might get jerkiness during playback and then when he plays it again it plays smoothly. Those symptoms aren't the result of a bad IVTC. And, based on what I've seen, you don't need AnimeIVTC for something as simple as this, particularly when the opening and closing parts aren't being kept.
    Quote Quote  



Similar Threads