VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 19 of 19
Thread
  1. I use VirtualDub for analysis of high speed videos. I have been training another user to do the same work. My computer runs the 64 bit version and his runs 32 bit. For some reason the 32 bit version does not properly display the input frames. I have been running both side by side on my machine and I have the same error. See the screens below:

    64 bit
    Click image for larger version

Name:	64 bit.jpg
Views:	724
Size:	63.9 KB
ID:	8936



    32 bit
    Click image for larger version

Name:	32 bit.jpg
Views:	678
Size:	59.5 KB
ID:	8937

    Video inputs are the same. All settings are the same. The only difference that I have been able to find is the MJPEG codec appears to be different between the two versions of VD. I cannot for the life of me figure out what is going on.

    Does anyone have a guess as to what is going on here? I have struggled with this all morning. Any input would be appreciated.
    Quote Quote  
  2. VH Wanderer Ai Haibara's Avatar
    Join Date
    Jan 2006
    Location
    Somewhere on VideoHelp...
    Search Comp PM
    Are the codecs roughly the same between the 32-bit version and the 64-bit version? It might be better, in this case, to install both the 32-bit and 64-bit versions of ffdshow, and enable MJPEG handling in their codec configuration, just so that there's a better chance of all things being equal between the 32-bit and 64-bit environments.
    If cameras add ten pounds, why would people want to eat them?
    Quote Quote  
  3. Try this in VirtualDub:

    Options -> Preferences -> Display (left pane) -> disable "Use DirectX....". Exit VirtualDub and restart it.
    Quote Quote  
  4. Thanks for the ideas. I will give them a try tomorrow and feed back the results.
    Quote Quote  
  5. I tried the Use DirectX change first, but this did not change the problem.

    I have installed both versions of ffdshow, but I don't know how to change the codec that VirtualDub uses. The plugins for VirtualDub were installed. How can I force the software to use them?

    Current info for each file is shown below.


    32 bit
    Click image for larger version

Name:	32 bit.jpg
Views:	633
Size:	36.3 KB
ID:	8949


    64 bit
    Click image for larger version

Name:	64 bit.jpg
Views:	589
Size:	36.4 KB
ID:	8950
    Quote Quote  
  6. Your screenshots are of different frame numbers between the versions. What do they look like on the same frame ? Vdub reports the same frame count

    The other difference looks like aspect ratio. Right click the input & output pane for the display and make sure they are setup the same way
    Quote Quote  
  7. I copied the ffdshow plugin into the VirtualDub plugin directory, but it did not change the decoding codec listed in the file info. <confused!>
    Quote Quote  
  8. Originally Posted by poisondeathray View Post
    Your screenshots are of different frame numbers between the versions. What do they look like on the same frame ? Vdub reports the same frame count
    I see 686 frames listed on each of the file information screenshots. At which value are you looking?

    [EDIT] The screenshots from yesterday and today are from different but similar video files, if that's what you are seeing. I didn't bring all the files home with me.
    Quote Quote  
  9. Originally Posted by iggogg View Post
    Originally Posted by poisondeathray View Post
    Your screenshots are of different frame numbers between the versions. What do they look like on the same frame ? Vdub reports the same frame count
    I see 686 frames listed on each of the file information screenshots. At which value are you looking?

    [EDIT] The screenshots from yesterday and today are from different but similar video files, if that's what you are seeing. I didn't bring all the files home with me.

    Yes, framecount is the same, but your individual screenshot is on a different frame . Try comparing the same frame. Look at the bottom right hand corner, it tells you the frame number . Or look where the slider is 398 vs. 598

    Also I edited my reply above, check it and make sure the aspect ratio display is setup the same way
    Quote Quote  
  10. Okay screenshots below are of the same frame. Looks right.

    I double checked aspect ratios. They were on free adjust and I like to set pane layout to autosize the frames. I turned that off and checked some other aspect ratios on both and did not get any change other than in proportion.

    32 bit
    Click image for larger version

Name:	32 bit.jpg
Views:	168
Size:	119.8 KB
ID:	8952


    64 bit
    Click image for larger version

Name:	64 bit.jpg
Views:	179
Size:	125.2 KB
ID:	8953

    Thanks for the suggestions so far. I'm really stumped on this one. I've used the software for this type of work in the past and never encountered this disparity.
    Quote Quote  
  11. BTW, I know that the versions are different. Originally I tried the stable version of 32 bit on my colleagues machine and it had the same error. When I put it on my computer I went up to 1.10 to see if it would make a difference. So far, completely the same.
    Quote Quote  
  12. Did you reset the AR? Even though it's a different frame and different shot, the clue is in the stretched letters

    Right click => reset to exact size , and right click 1:1 square pixel . Do this for both

    I can simulate what you see by using free adjust . For example your trainee might have inadvertently bumped the setting
    Quote Quote  
  13. You can uninstall or change the priority of vfw codecs by using vcswap . If the 32-bit version is screwed up, I would start by uninstalling picvideo . picvideo is proprietary and not free .

    If you wanted to use ffdshow, you would disable the other VFW mjpeg codecs that you have installed on your system (perhaps using vcswap), then enable "mjpeg" in the ffdshow VFW configuration (set to libavcodec) . This has to be VFW, not the directshow configuration . These are 2 separate video subsystems. vdub uses VFW
    Quote Quote  
  14. Originally Posted by poisondeathray View Post
    Did you reset the AR? Even though it's a different frame and different shot, the clue is in the stretched letters

    Right click => reset to exact size , and right click 1:1 square pixel . Do this for both

    I can simulate what you see by using free adjust . For example your trainee might have inadvertently bumped the setting
    Couldn't get it to work:

    32 bit
    Click image for larger version

Name:	32 bit.jpg
Views:	311
Size:	49.2 KB
ID:	8954
    Quote Quote  
  15. You have to reset it before setting to 100% . The setting is cut off in your screenshot. I'm assuming you tried that first

    Also your screenshots are not 1:1 there is some scaling going on. It's unclear if you are doing this , your screenshot application is doing this, or if vdub is doing this. ie. If this is a 480x360 video, for example your 64-bit screenshot is a lot larger than that. Make sure both vdub versions are reset , set to 100% then 1:1 to start with

    If those display changes don't work , then try uninstalling and swaping out the mjpeg codec mentioned above . You don't have to uninstall it, vcswap can "disable" it so another mjpeg decoder with higher priority can take over. Or you might want to uninstall it completely - it's up to you
    Quote Quote  
  16. Originally Posted by poisondeathray View Post
    You can uninstall or change the priority of vfw codecs by using vcswap . If the 32-bit version is screwed up, I would start by uninstalling picvideo . picvideo is proprietary and not free .

    If you wanted to use ffdshow, you would disable the other VFW mjpeg codecs that you have installed on your system (perhaps using vcswap), then enable "mjpeg" in the ffdshow VFW configuration (set to libavcodec) . This has to be VFW, not the directshow configuration . These are 2 separate video subsystems. vdub uses VFW
    This worked!! Putting the codecs to ffdshow has saved the day! Bless you for your persistence with this issue this morning. This is a huge help for me. I just had to disable the Morgan codecs.
    Quote Quote  
  17. Cheers

    Whoops, I though it was Pic Video MJPEG decoder, when it clearly says "Morgan" in your screenshot

    I was thinking that is weird because Pic Video has a decent reputation around here . So it seems "Morgan" was the culprit in your case
    Quote Quote  
  18. I've never seen codecs make a difference like this. We use the videos from this camera all the time, but only vdub has had this kind of problem with them. Anyway, solved now. Again, much appreciated.
    Quote Quote  
  19. Small clarify...
    VirtualDub can decode a few formats (such as MJPEG and DV) using internal decoder.
    If there is no proper codec installed (in system), VirtualDub uses internal decoder (of course only for specific formats).
    In VirtualDub configuration is option to force use of internal decoder - Options > Preferences... > AVI > Prefer internal video decoders over installed third-party codecs (MJPEG and DV)
    VideoAudio.pl - Serwis o technologii wideo & audio
    Quote Quote  



Similar Threads