VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Anyone here using Excel with hyperlinks to video files please?

    Using Tools > Folder Options from an Explorer window I can associate MP4 video files in XP with various programs. Such as Windows Media Player, Media Player Classic, VLC, etc. D-clicking or using Open With then plays these video files.

    But in Excel 2000 when I then try to open a hyperlink to such a file, I get the unhelpful message "An unexpected error has occurred."

    So far this seems to be confined to MP4 types. MPG work OK. What is the likely explanation please? Are MP4s perhaps outside Excel 2000's scope for some reason? Any particular syntax or sepecial parameters I could experiment with in the File Types dialog to fix this? Currently I have MP4 associated with VLC, but I've tried WMP and Media Player Classic, with same problem.

    --
    Terry, East Grinstead, UK
    Quote Quote  
  2. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    MP4 works on mine, but I have v2003.

    Could be:
    1. The kind of link you're using - specify steps
    2. The associated player (but it sounds like you've already checked that. How?)
    3. The path is not usable (network drive? spaces in the link?)

    Scott
    Quote Quote  
  3. Thanks Cornucopia.

    Your point #3 about spaces prompted me to try quotes around the entire hyperlink, which has triggered a new line of enquiry.

    This was what I had entered originally:
    Click image for larger version

Name:	ExcelMP4-1.jpg
Views:	1602
Size:	56.9 KB
ID:	8266


    After saving the spreadsheet, and re-opening the Edit Hyperlink dialog, Excel actually displays that as
    ..\..\My Videos\PROJECTS\Flight-Simon-14Aug2011\20110814FlightSimon-2.mp4

    Now, prompted by your post, I changed the hyperlink to
    "C:\Docs\My Videos\PROJECTS\Flight-Simon-14Aug2011\20110814FlightSimon-2.mp4"

    When I then tried to open the hyperlink to play the MP4 I got this:
    Click image for larger version

Name:	ExcelMP4-2.jpg
Views:	671
Size:	29.0 KB
ID:	8267

    The first part of that weird looking hyperlink
    C:\Docs\Touch_Pro2 My Documents\MyTP2Misc\"C:\Docs\My Videos\PROJECTS\Flight-Simon-14Aug2011\20110814FlightSimon-2.mp4"
    happens to be the folder that contains the spreadsheet itself
    C:\Docs\Touch_Pro2 My Documents\MyTP2Misc\DVD-Index.xls
    which must be a big clue. It's as if Excel is treating the 'base' as the folder containing the spreadsheet.

    If I look at File > Properties I see this:
    Click image for larger version

Name:	ExcelMP4-3.jpg
Views:	1389
Size:	32.6 KB
ID:	8268


    I feel close, but still haven't yet got my head around it! Any thoughts please?

    --
    Terry, East Grinstead, UK
    Quote Quote  
  4. Member
    Join Date
    Jul 2009
    Location
    Spain
    Search Comp PM
    See http://office.microsoft.com/en-us/excel-help/set-the-base-address-for-the-hyperlinks-i...005202555.aspx

    Originally Posted by terrypin View Post
    After saving the spreadsheet, and re-opening the Edit Hyperlink dialog, Excel actually displays that as
    ..\..\My Videos\PROJECTS\Flight-Simon-14Aug2011\20110814FlightSimon-2.mp4
    And does that hyperlink work?
    ".." refers to the parent directory so ..\.. is the same as C:\Docs when interpreted with respect to the spreadsheet folder (which is the default hyperlink base).
    Quote Quote  
  5. Thanks Gavino.

    No, I guess I should have added that it doesn't work.

    But first, to make sure I understand this addressing stuff properly, from that page you referenced:
    "You can override the hyperlink base address by using the full, or absolute, address for the hyperlink in the Insert Hyperlink dialog box."

    So when I entered the full address
    C:\Docs\My Videos\PROJECTS\Flight-Simon-14Aug2011\20110814FlightSimon-2.mp4
    it seems I was right to expect that to work. Despite the inclusion of a space, the addition of quotes was apparently not only unnecessary but scrambled the whole thing. And presumably that's regardless of whether there's a base entered in the Properties or not.

    However, I'm coming to the conclusion that all that is irrelevant and that this is an Excel 2000 limitation. Because I converted a couple of MP4s to MPGs and the hyperlinks to those worked. I'd still like to hear from anyone else with Excel 2000 though, to be 100% sure of this!

    --
    Terry, East Grinstead, UK
    Quote Quote  
  6. Member
    Join Date
    Jul 2009
    Location
    Spain
    Search Comp PM
    I suspect it might be a Registry problem, as it reminds me of a similar problem I once had opening mp3 file attachments in Outlook Express, when I had .mp3 associated with VLC.

    If you're comfortable using RegEdit, check the following.
    Look at HKEY_CLASSES_ROOT\.mp4
    For the (Default) value, it might show something like "VLC.mp4"
    Go then to HKEY_CLASSES_ROOT\VLC.mp4\shell

    You might find you have a key called "play", but not one called "open".
    If so, you need to create "open" and "open\command", copying them from "play" and "play\command".

    It's worth a try and since you're not modifying any existing entries, can't do any harm. (Famous last words )
    If it doesn't work you can always delete the newly added entries.
    Quote Quote  
  7. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    AFA spaces, I would remove it from the equation by making a copy of the mp4 and calling it "TESTFILE.MP4" and putting it in the C: root.

    Then, test to see which app is responsible for opening the file by double-clicking on it that copy.

    Now, try a link with quotes and a link without quotes. Do ANY work?

    Change the extension of "TESTFILE.MP4" tom MPG, redo the links and see if it works now...
    This would test to see if the system was only workng with certain extensions (it's a bit of a cheat). Of course, your default player for MPG could be different from your default player for Mp4, so things might not act the same.

    All my installed copies of Excel are 2002 or newer right now, so I couldn't test it myself.

    Does MS say anything about this?

    Scott
    Quote Quote  
  8. Thanks both. Will get back on the case in the morning (it's Friday 19 August 2011, 19:59 here) but meanwhile here's what that registry section looks like:

    Click image for larger version

Name:	ExcelMP4-4.jpg
Views:	208
Size:	47.8 KB
ID:	8270

    And there's no key called
    HKEY_CLASSES_ROOT\Quicktime.mp4\

    MP4 is currently associated with Media Player Classic (in Folder Options > File Types) so I can't make much sense of any of that.

    Click image for larger version

Name:	ExcelMP4-5.jpg
Views:	149
Size:	85.0 KB
ID:	8271



    --
    Terry, East Grinstead, UK
    Quote Quote  
  9. Before finally giving up on this tonight I ensured QuickTime was associated only with QT files. In particular I did not check the box for MPEG-4 (MP4). And in XP's Folder Options > File Types I have MP4 associated with Media Player Classic. D-clicking an MP4 from a folder correctly opens it in MPC. And same for a shortcut targeted to the MP4 file.

    But bizarrely the Excel 2000 hyperlink now insists on opening QT! (FWIW, it doesn't actually play until I click the QT play icon.) Same after closing and re-opening the spreadsheet. Beats me...

    --
    Terry, East Grinstead, UK
    Quote Quote  
  10. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    Now that you mention it, the PC I tested on had QT installed and it was the registered player for MP4, so when it opened up, it was QT that it opened up into.

    BTW, the whole "not playing until [PLAY] pressed" thing is common for QT player (IIRC, the movie has to be saved with "autostart" flag - not the default and certain not for MP4).

    Scott
    Quote Quote  
  11. Member
    Join Date
    Jul 2009
    Location
    Spain
    Search Comp PM
    Originally Posted by terrypin View Post
    But bizarrely the Excel 2000 hyperlink now insists on opening QT!
    That strengthens my suspicion that it is a registry problem, since you showed earlier that HKEY_CLASSES_ROOT\.mp4 had a value of "QuickTime.mp4".

    Not sure how to fix it though if, as you say, HKEY_CLASSES_ROOT\QuickTime.mp4 does not exist.
    Perhaps de-install QuickTime?
    Quote Quote  
  12. Thanks all appreciate your sticking with this.

    I was wrong about there being no Quicktime.mp4 entry, sorry. I didn't look far enough down that (very!) long part of the tree.

    But it's all very confusing. My default now (the bold entry set in Folder Options > File Types) is MPC. No mention of VLC at present. Yet, after refresh, that section of the registry looks like this:

    Click image for larger version

Name:	ExcelMP4-6.jpg
Views:	1403
Size:	34.4 KB
ID:	8283

    And my Google research shows that QT is well known for hi-jacking file associations. Here's one of many relevant threads:
    https://discussions.apple.com/thread/2335629?start=0&tstart=0

    Like several of those contributors, I too only use QT because my iPad ownership forces me to use iTunes, an application I loathe.

    As a side question, what players do others here prefer for default association with MP4 please?

    --
    Terry, East Grinstead, UK
    Quote Quote  
  13. Member
    Join Date
    Jul 2009
    Location
    Spain
    Search Comp PM
    Originally Posted by terrypin View Post
    I was wrong about there being no Quicktime.mp4 entry, sorry. I didn't look far enough down that (very!) long part of the tree.
    OK, I see you do already have an entry for Quicktime.mp4\shell\open\command.
    If that is set to call QuickTime, you could change it to call MPC instead.
    Quote Quote  
  14. Thanks Gavino, I'll maybe try that. But actually, now that I've switched on its option to immediately play the file, instead of just opening it and waiting for me to click the Play button, I'll probably live with QT for MP4s for a while, Seems pretty stable and plays smoothly. And one little thing I like is that the hotkey for a capture is the intuitive Ctrl+C; with other players I always seem to forget it and have to go looking!

    --
    Terry, East Grinstead, UK
    Quote Quote  



Similar Threads