VideoHelp Forum

Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 4 of 4
  1. Hello,

    I recently tried to remux stream files from a BD film, with only the streams I wanted, into an MKV.

    I followed the same process I'd used for countless other rips. I used BDInfo to scan the BDMV folder. I then opened the appropriate mpls file in TSmuxer. I selected only the streams I wanted, then used the demux option to copy these streams to my HDD. I then remuxed these streams together, into a MKV container, using mkvmerge.

    Everything seemed fine, except for the audio. The video and both subtitle streams are in sync, but the audio is not. It seems fine at first, but as the movie progresses, the audio delay gets worse and worse (so not simply a constant offset issue that I could fix by "delaying" the audio by a negative amount using mkvmerge).

    I've tried everything I can think of.

    I originally thought it may be an issue with the mkvmerge muxing process, so I simply used Tsmuxer to create a .m2ts file as opposed to just demuxing the streams from the BDMV folder. This gave me the same result however.

    I then decided to remux each individual m2ts file in the BDMV folder (there are 3, which together make the film) into MKVs. Same problem.

    I then tried simply appending the three m2ts files to each other. This failed also, I get the same out of sync issue.

    So it seems muxing, demuxing, appending or modifying the files in significant way will cause the audio to become out of sync.

    Why is this ocurring?

    It is worth noting that the video is set at 24FPS, rather than the common 23.976FPS I see with blu rays.

    I'd greatly appreciate any help with this problem.


    Quote Quote  
  2. Try stripping out the main movie with Clown_BD instead of tsMuxer. I've found on occasion that you can get sync problems if the title is split into multiple m2ts files, and tsMuxer is not reliable for joining them. You can then use the elementary streams from the demux folder, if that's how you want to do it.

    Appending or joining is a different story. Often the video and audio streams have a slightly different runtime, or "overhanging edges". So after the join it's suddenly out-of-sync. The solution is to lop a little off the end. Clown_BD can do that too, there is a checkbox for removing the last second from the movie, which should fix the problem (almost) invariably.

    Good luck.
    Pull! Bang! Darn!
    Quote Quote  
  3. Thanks for your suggestion.

    I did try using Clown_BD to demux, them mkvmerge to remux. It worked great!

    So it does indeed seem to be a bug with tsmuxer. Is there any known reason why this occurs, or is it unknown? Have I set something incorrectly?

    As Clown_BD seems only to be some sort of a front end GUI, I'm guessing it's safe for me to simply just use eac3to instead?
    Quote Quote  
  4. Sure, the essential part of Clown_BD is eac3to.

    As to tsMuxer, the latest version is two years old. The root of the problem, I *think*, is, as I said, multiple m2ts files. When using Clown_BD to extract, I've often examined the log files and found error messages like "sync discontinuity", "sync byte missing", "clipping detected", among others, but there's a few off the top of my head. Eac3to corrects those problems, tsMuxer does not. Mind you, give it a clean stream and tsMuxer is fine.

    If I were a cynic, I'd say that those errors are deliberately introduced to make it difficult for hobbyists like me to play with the files. Or maybe that's not so cynical, I dunno. But that just makes it a little more interesting. It is obvious that standalone players are not affected by those errors, it's when you try to repackage the movie that the errors become a pain in the butt.

    Glad you got it fixed. Good luck.
    Pull! Bang! Darn!
    Quote Quote  

Similar Threads