VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 6 of 6
  1. Member
    Join Date
    Nov 2005
    United States
    Search Comp PM
    I'm experiencing noticeable choppy/stuttery video playback on my HTPC. It only happens on x264/h.264/AVC 1080p files and only when there is movement within the screen like 'pan&scan' or objects moving around. It's looks like the video has inverse telecine on and moving objects and camera movement produce stuttery playback. A few examples of videos that I recently noticed this issue are "Planet Earth's" Intro Birds scene (90s-120s), Gaga's "telephone" music video intro of prison bars (30s-50s), Yellowcard's "hang you up" music video where it's noticeably choppy and stuttery almost all the time. The audio is fine. It's the video that seems to 'skip' frames instead of showing all frames.

    Anyways, how do I stop the stuttering and get smooth playback?

    My hardware setup:

    CPU is AMD Phenom X3 8400 2.1 Ghz
    Onboard Graphics Video is 'Nvidia GeForce 8200' 256 MB ram (it's actually listed as 'Nvidia GeForce 9200' after I updated with the latest Nvidia 270.61 drivers)
    GSkill 4 GB DDR2 (2 x 2GB)

    My software setup is:

    Windows 7 Ultimate x64
    MPC-HC x64
    AC3 filter 1.63b
    Haali Media Splitter 1.10.348.15
    Quicktime (not sure which version I have)
    I have never previously installed other 'codec packs.' I did however uninstall CoreAVC anyway because I don't need it and video playback seems to be worse with it.

    Below I have accumulate as much properties config data as possible to help the troubleshooting process a lil' easier.

    My MPC-HC settings (the primary and only method I used so far to watch videos):

    Internal Filters1

    Internal Filters2

    I have no external filters.

    MPC Video Decoder


    Renderer Settings > Output Range: 0-255
    Renderer Settings > Presentation: Enable Frame Time Correction
    Renderer Settings > Color Management Enabled
    Renderer Settings > VSync Disabled
    Renderer Settings > GPU Control: All three options are selected (Flush GPU before VSync; Flush GPU after Present; Wait For Flushes)

    In the meantime, I will try another alternate way of watching videos by researching this site. It looks promising.

    EDIT: I changed output to "EVR Sync" and under "EVR Sync Settings" I selected Sync video to display. Frequency adjustment was set to about 0.0012, Target sync offset to ~13 ms for my display refresh cycle (60Hz), and Control limits to 2.0 ms.

    The stuttering or jitter have almost completely stopped.

    Thread is solved.
    Last edited by Stealth3si; 27th Apr 2011 at 15:55. Reason: SOLVED
    Quote Quote  
  2. Hmm, I had the same problem and your solution seemed to work except that the lines in the jitter graph are all over the place and I'm getting thousands of sync glitches. Could this be because the source video has variable frame rate? Also, can anyone explain exactly what the values under EVR Sync Settings represent?
    Quote Quote  
  3. Member
    Join Date
    Nov 2005
    United States
    Search Comp PM
    I think it has to do with the source video but I could be wrong. I tested this on different videos and the lines on some are steady while others are not. Either way, the lines are parallel to each other and I think as long as they're the same it's ok. I'm not sure though. As for the sync glitches, I'll have to test it later. You find more about the values under EVR Sync Settings here.
    "A computer is never finished, you just run out of money."
    Quote Quote  
  4. Awesome, thanks for the link.
    Quote Quote  
  5. Member
    Join Date
    Oct 2009
    United States
    Search Comp PM
    Okay, I have searched high..... and low...... and sideways....... and this thread describes my situation better than any other one that I have found.

    I have a good computer that is about a year old..... i7 quad core processor, radeon 7700 series video card..... tons of memory....

    But yet, when I play 1080p videos h.264 I still get constant jitter throughout. I have tried everything that I can think of..... My main video player has always been MPCHC..... and VLC is my 2nd favorite. I have updated the versions and tweaked the settings every way that I can think of...... but no joy

    Any ideas?


    Quote Quote  
  6. I'm a Super Moderator johns0's Avatar
    Join Date
    Jun 2002
    Search Comp PM
    Post in a new thread,after 128 posts you should know better.
    I think,therefore i am a hamster.
    Quote Quote  

Similar Threads