VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date
    Feb 2011
    Location
    Prospect Heights, IL
    Search PM
    I am in the process of converting The Sopranos from DVD to mp4. On my TV downstairs, a 55" LED, the videos do not fill the entire screen. I have about 4 inches of black on each side. It almost looks like it's displaying in 4:3. But upstairs, on my 47" LCD, it looks fine.

    I have been using the darx and dary variables in my avs script in MeGUI, setting them to 16 and 9. So I would figure that my video would fill up the screen.

    I don't know if my process is partially to blame. I deinterlace using TFM and a d2v file in VirtualDub, then save as avi using Lagarith. Then I edit my avs script to just include the darx, dary, and the AVI source. I realize saving as avi from VirtualDub is somewhat of a wasted step as I can just let MeGUI do the deinterlace. However, when I do this, My TV downstairs basically freezes up after each episode and I have to turn it off and on again to get to the next episode, and my TV upstairs will not fast forward. If I feed the lossless avi into MeGUI, everything works fine. I'm ok with the extra step, it doesn't bother me.

    I used GSpot to get the size information from the videos in each step, maybe it can shed some light:

    original DVD rip
    pic: 720x480
    sar: 1.5(3:2)
    par: 1.185(32:27)
    dar: 1.778(16:9)

    Lagarith avi
    pic: 720x480
    sar: 1.5(3:2)
    par: 1.00(1:1)
    dar: 1.5(3:2)

    MeGUI mp4
    pic: 720x480
    sar: 1.5(3:2)
    par: blank
    dar: 1.777(~16:9)

    Here is the script that I use for VirtualDub and MeGUI:

    #global MeGUI_darx = 16
    #global MeGUI_dary = 9
    LoadPlugin("C:\DVDTools\AviSynth\Plugins\DGDecode.dll")
    MPEG2Source("C:\Movies\The Sopranos\S05\E01\E01.d2v")
    LoadPlugin("C:\DVDTools\AviSynth\Plugins\TIVTC\TIV TC.dll")
    TFM(D2V="E01.d2v")
    TDecimate()
    #AVISource("C:\Movies\The Sopranos\S05\E01\E01.avi")

    For MeGUI I just switch commenting out the particular lines.

    Could my problem be that the mp4 file is not reporting a PAR? If so, how can I change that? I don't do any cropping to the video because I think there may be only 4 pixels worth of black border on each side in the original DVD rip. Or should I crop and Lanczos resize to 720x480? I figure that if the DVD player will output the video in a size that fills the screen, then I should be able to achieve the same thing when converting to mp4.

    Or do I need to use a different GUI/encoder? One with more control over the picture size? Any help will be greatly appreciated. Thanks.
    Quote Quote  
  2. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    I'll start the ball rolling on this one then someone can fill in the bits I miss out.

    The reason that one tv is showing the mp4 as almost 4:3 is because the mp4 is almost 4:3 - 720*480 pixels is. as reported, 3:2

    The dvd player alters the display for a dvd according to the flag either 4:3 or, as in this case, 16:9 but the frame is always 720*480 irrespective (just see 'what is a dvd' to understand that bit)

    To get that 16:9 image properly displayed on mp4 your frame has to be 720*360.

    Why one tv is (almost) ok and the other not is probably down to some settings on the tv itself where it is stretching the image to fill the screen.
    Quote Quote  
  3. in mpeg4 terminology the sar is the sample aspect ratio, or the w:h of the pixels. In mpeg2 terminology this was the par , or pixel aspect ratio. Gspot is reporting the par

    you can write aspect ratio information at either the container level, or the bitstream level

    some devices and players may ignore one or the other. bitstream is usually safest

    First check that your TV is set properly that your're not using some forced display mode or aspect ratio setting.


    I'm not sure which method used when you use the megui aviysnth darx/y thingy

    You can use yamb to set the container flags, or when encoding use --sar x:y in the command line box to write into the bitstream.

    For 16:9 NTSC, you would use either sar 40:33 (or 32:27) . The 1st value is based on 704width, the 2nd is based on 720width

    The 1st thing I would do is use yamb to remux and set the flag see if that helps

    If not, you can re-write bitstream flags using a special ffmpeg build
    http://forum.doom9.org/showthread.php?t=152419

    If none of these work, it's a playback issue with your hard ware. Then alternatively you can resize and encode using square pixels if your tv or device doesn't accept any flags
    Quote Quote  
  4. Member
    Join Date
    Feb 2011
    Location
    Prospect Heights, IL
    Search PM
    Forcing SAR to 40:33 fixed the problem.
    Quote Quote  



Similar Threads