VideoHelp Forum

+ Reply to Thread
Results 1 to 24 of 24
Thread
  1. Member
    Join Date
    Feb 2011
    Location
    netherlands
    Search Comp PM
    Hi folks,

    Is there anyone who can tell me why Windows mediaplayer (V12) does not load the subtitles (.srt) when playing a mp4 file?
    I've been looking for days now on the internet but i can 't find a clue.

    I have installed the K-Lite codec pack including ffdshow, Haali etc. My operating system is Windows 7.

    Windows mediaplayer classic has no problem with mp4 and subtitles. But I need to use windows mplayer because i integrated it as an active-x control in a program.

    Hope someone knows the solution.

    Strannoboy
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Try disable windows 7 built in mp4 support with Preferred Filter Tweaker.
    Quote Quote  
  3. Member
    Join Date
    Sep 2007
    Location
    Europe
    Search PM
    You may also need to enable subtitles in FFdshow.
    Quote Quote  
  4. Member
    Join Date
    Feb 2011
    Location
    netherlands
    Search Comp PM
    Thanks for answering my question. Disabling windows 7 built in mp4 support did the job.
    I still wonder why it took me so long to find out. Next time I start my quest here on this site.
    Quote Quote  
  5. Originally Posted by Baldrick View Post
    Try disable windows 7 built in mp4 support with Preferred Filter Tweaker.
    COuld you show me the steps please ?
    I have the exact same problem
    and have no clue how to disable the windows 7 built with the program u mentioned

    Thanks
    Quote Quote  
  6. Member
    Join Date
    Feb 2011
    Location
    netherlands
    Search Comp PM
    Sorry Baldrick, i did not read my post for a while. Are you still interested in the answer?
    Quote Quote  
  7. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    DOn't you mean Chaand?
    Quote Quote  
  8. Just use VLC to view, its free, does the job & a lot of other things.
    Quote Quote  
  9. Member
    Join Date
    Feb 2011
    Location
    netherlands
    Search Comp PM
    Sorry, yesi I meant Chaand of course!
    Quote Quote  
  10. yeah sure
    sorry for not replying earlier
    sort of gave up really and got busy
    Quote Quote  
  11. Member
    Join Date
    Feb 2011
    Location
    netherlands
    Search Comp PM
    1) download FFdshow
    2) download K-Lite Codec Pack 7.0.0 Full version
    3) in the folder "Tools" run winDSFilter Tweaker.exe
    4) and disable windows 7 built in mp4 support: Check ffdshow (Mp4v)

    If you don't want to install K-Lite Codec Pack try link above (Preferred Filter Tweaker).
    Might work too.

    Of course name of. mp4 file and .srt file should be the same and must be kept in the same folder.
    open movie (.mp4 file) with Windows media player. subtitles should appear now.
    if not, click on ffdshow in taskbar and activate subtitles.
    also right click in windows media player while video is running and chech status of subtitles.
    Quote Quote  
  12. in wmp right click> lyrics,caption,subtitles> on if available.
    Quote Quote  
  13. Member
    Join Date
    Sep 2011
    Location
    Larisa
    Search Comp PM
    for those of you who still has problems with the subtitles, just open the video with "WINDOWS MEDIA CENTER" and not with "WINDOWS MEDIA PLAYER".

    don't forget to download and install the "directvobsub" program first.
    I hope this helps .....
    Quote Quote  
  14. I have same problem .... i need heeeeeeeelp PLS
    Quote Quote  
  15. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    And have you tried install vsfilter and disable windows 7 built in mp4 support with preferred filter tweaker?
    Quote Quote  
  16. Originally Posted by strannoboy View Post
    1) download FFdshow
    2) download K-Lite Codec Pack 7.0.0 Full version
    3) in the folder "Tools" run winDSFilter Tweaker.exe
    4) and disable windows 7 built in mp4 support: Check ffdshow (Mp4v)

    If you don't want to install K-Lite Codec Pack try link above (Preferred Filter Tweaker).
    Might work too.

    Of course name of. mp4 file and .srt file should be the same and must be kept in the same folder.
    open movie (.mp4 file) with Windows media player. subtitles should appear now.
    if not, click on ffdshow in taskbar and activate subtitles.
    also right click in windows media player while video is running and chech status of subtitles.
    i have do this .. and the sub show ... thanks
    but Directvobsub not open ..
    i need to open it to edit my sub (position , colour ,......... )
    Quote Quote  
  17. Two days ago it was just fine ..
    I do not know what Happened ..
    May be .. i setup something wrong ..

    I think i need something to link directvobsub with windows media player ..
    can you help me ?? and thank you for your interest ...
    Quote Quote  
  18. oooh .. thanks .. it's ok
    I have use preferred filter tweaker and reset (Preferred decoders , tweaks) .. then directvobsub open automatically ..
    thank you again
    Quote Quote  
  19. Member
    Join Date
    May 2013
    Location
    Ecuador
    Search Comp PM
    Originally Posted by strannoboy View Post
    1) download FFdshow
    2) download K-Lite Codec Pack 7.0.0 Full version
    3) in the folder "Tools" run winDSFilter Tweaker.exe
    4) and disable windows 7 built in mp4 support: Check ffdshow (Mp4v)

    If you don't want to install K-Lite Codec Pack try link above (Preferred Filter Tweaker).
    Might work too.

    Of course name of. mp4 file and .srt file should be the same and must be kept in the same folder.
    open movie (.mp4 file) with Windows media player. subtitles should appear now.
    if not, click on ffdshow in taskbar and activate subtitles.
    also right click in windows media player while video is running and chech status of subtitles.
    I have no idea how to go from step 3 to step 4, call me slow or dumb, but I'm at a lost. I would like some help, please.
    Quote Quote  
  20. Member Budman1's Avatar
    Join Date
    Jul 2012
    Location
    NORTHWEST ILLINOIS, USA
    Search Comp PM
    Sure.. After you install K-lite there is a k-lite ->tools selection in start programs:
    Name:  ScreenHunter_04 May. 10 00.52.jpg
Views: 105043
Size:  26.1 KB
    Disable Windows Media Foundation MP4 settings:

    Click image for larger version

Name:	ScreenHunter_04 May. 10 00.54.jpg
Views:	96131
Size:	43.1 KB
ID:	17750 Click image for larger version

Name:	ScreenHunter_05 May. 10 00.54.jpg
Views:	95920
Size:	30.9 KB
ID:	17749
    Then go to K-lite -> configuration -> Video decoders (The Red Icon, NOT the VFW one) and ENABLE the MP4 settings. Notice there are MP41, MP42, MP43 and other MPEG4 that lists the MP4V on the right above those 3. Use Media Info to check which codec is actually used in the video you are trying to watch. This is the one you want to enable.
    Click image for larger version

Name:	ScreenHunter_05 May. 10 01.01.jpg
Views:	96300
Size:	92.9 KB
ID:	17751

    I should also point out that I use Potplayer and it shows subtiltes in mp4 WITHOUT doing all this, automatically as well as picks up the Subtitles named the same as the video in the same folder as mentioned above.. The French subtitles shown below are actually an ASS file labeled 004_French.ass I threw in to show.:
    Name:  ScreenHunter_05 May. 10 01.20.jpg
Views: 104285
Size:  6.5 KB
    Click image for larger version

Name:	ScreenHunter_05 May. 10 01.13.jpg
Views:	7513
Size:	134.4 KB
ID:	17752
    Hope this helps
    Last edited by Budman1; 10th May 2013 at 02:21.
    Quote Quote  
  21. Member
    Join Date
    May 2013
    Location
    Ecuador
    Search Comp PM
    thank you so much! I was missing the mpeg one. I got the subtitles to work. Thanks again!
    Quote Quote  
  22. Member
    Join Date
    Jul 2015
    Location
    Canada
    Search Comp PM
    Okay, my problem is a little different, I'm running Windows 8.1 WMP 12 and no matter what I try subtitles are not showing up. I've been scrolling through the threads, but everything is FFd DDC VVCD and none of it makes sense. I am a complete idiot when it comes to this stuff, so could someone please just tell me in the simplest terms possible how to get .srt subtitles to work on .mp4 for WMP 12? I would prefer not to download anything, but I will if it's absolutely necessary; however, I would need instructions on how to use whatever I download (again, complete novice here).

    Oh, a little more information. I'm trying to get forced subtitles to work for a game of thrones episode for the parts in Dothraki. I'm not sure if getting forced subtitles to work is any different from regular subtitles...
    Quote Quote  
  23. Member
    Join Date
    Oct 2006
    Location
    Malaysia
    Search Comp PM
    Originally Posted by Budman1 View Post
    Sure.. After you install K-lite there is a k-lite ->tools selection in start programs:
    Image
    [Attachment 17748 - Click to enlarge]

    Disable Windows Media Foundation MP4 settings:

    Image
    [Attachment 17750 - Click to enlarge]
    Image
    [Attachment 17749 - Click to enlarge]

    Then go to K-lite -> configuration -> Video decoders (The Red Icon, NOT the VFW one) and ENABLE the MP4 settings. Notice there are MP41, MP42, MP43 and other MPEG4 that lists the MP4V on the right above those 3. Use Media Info to check which codec is actually used in the video you are trying to watch. This is the one you want to enable.
    Image
    [Attachment 17751 - Click to enlarge]


    I should also point out that I use Potplayer and it shows subtiltes in mp4 WITHOUT doing all this, automatically as well as picks up the Subtitles named the same as the video in the same folder as mentioned above.. The French subtitles shown below are actually an ASS file labeled 004_French.ass I threw in to show.:
    Image
    [Attachment 17753 - Click to enlarge]

    Image
    [Attachment 17752 - Click to enlarge]

    Hope this helps
    I had the same problem and I soved this by checking the mp4 checkbox on media foundation tweaks. However, when I do that, all my mp4 videos appear as icons instead of thumbnails. I prefer to have my videos as thumbnails instead of icons so that I can easily differentiate one video from another. How can I enable the subs but still maintain the thumbails? By the way I checked mp4 on both 32-bit and 64-bit.
    I can't live without my computer.
    Quote Quote  
  24. Member Budman1's Avatar
    Join Date
    Jul 2012
    Location
    NORTHWEST ILLINOIS, USA
    Search Comp PM
    It is probably because you lost the thumbnail provider thru Media Foundation. Normally this is picked up by your player like Potplayer or thumbnail provider like Icaros ThumbnailProvider (Part of K=Lite mentioned above but available separately.) https://www.videohelp.com/software/Icaros.
    Quote Quote  



Similar Threads