VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. After AutoGK finished ripping a DVD, instead of 2x700mb avi files, there was only one 460mb avi file which a video bitrate of only 400kbps. Also, it wasn't suppose to crop any pixel because the movie has no black bars, instead it has a presentation with black background, white text and some pictures. This presentation is being displayed in 90% of the movie duration. Remaining 10% has some light in the whole frame.

    I know that if the source dvd has 29.970 fps and its duration is 83:01 - 166 min, the file size of the avi should be 1400mb. I selected "2CDs (1400mb)" in AutoGK, XviD encoder, width 624px, original ac3 audio. Also, I enabled standalone support. With these same settings I've encoded other dvd's and there was no problem.

    After the first pass, in the log window appeared a message: "couldn't adjust settings...."
    Last edited by codemaster; 4th Dec 2010 at 21:37.
    Quote Quote  
  2. Cropping can be adjusted to either scan a larger percentage of the movie, be skipped entirely, or cropped however you like it. Apparently the unusual nature of your DVD threw off AutoGK's Autocrop. These options are in the Hidden Options (CTRL-F9). More info is found in the tutorial:

    http://www.autogk.me.uk/modules.php?name=TutorialEN

    - Sometimes auto crop used with default parameters by AutoGK cannot totally remove black bars or removes too much of a movie material. In this case "Tune auto crop parameters" is very handy. Threshold defines how sensitive auto crop will be: the higher the value the more cropping will be done. To completely disable audio crop you can set threshold to 0. "Number of frames to examine" is useful parameter to change if movie is a mixture of full screen/wide screen shots, so by selecting different frames that auto crop examines you can improve cropping process. "Starting frame" can help auto crop in situation when you have a full screen logo as a part of widescreen movie, in which case autocrop might decide that the whole source is full screen. By selecting a different starting frames you force auto crop not to examine irrelevant starting movie sequence. "Force cropping" option allows you to crop additional pixels after autocrop operation (if you find that you need to always crop several more pixels you can use this option). If you disable autocrop with threshold 0 then "force cropping" option becomes fully manual crop. Remember always to check how movie looks like after you set new auto crop parameters using Preview function of AutoGK.
    As for it being undersized and the message you mentioned, post the log.

    I know that if the source dvd has 29.970 fps and its duration is 83:01 - 166 min, the file size of the avi should be 1400mb.
    Utter nonsense.
    Quote Quote  
  3. at 1400mb avi, the video bitrate is ~1350 kbps
    at 700mb avi, video bitrate is ~600 kbps, too low => I think final size of 1400mb (2x700mb) makes sense for 120 min video

    I will post the log file of the current encode after it finishes, because I deleted the log from previous encode.
    Last edited by codemaster; 4th Dec 2010 at 23:10.
    Quote Quote  
  4. the log, so far:

    [05.12.2010 06:43:32] AutoGK 2.55
    [05.12.2010 06:43:32] OS: Windows Vista (6.1.7600).2
    [05.12.2010 06:43:32] Job started.
    [05.12.2010 06:43:32] Input file: E:\TEMP\encodes\decrypted dvd\VTS_01_0.IFO
    [05.12.2010 06:43:32] Output file: D:\VM\decrypted.avi
    [05.12.2010 06:43:32] Output codec: XviD
    [05.12.2010 06:43:32] Audio 1: Unknown language AC3 2ch
    [05.12.2010 06:43:32] Subtitles: none
    [05.12.2010 06:43:32] Format: AVI
    [05.12.2010 06:43:32] Target size: 1400Mb
    [05.12.2010 06:43:32] Custom resolution settings: fixed width of 624 pixels
    [05.12.2010 06:43:32] Audio 1 settings: Original
    [05.12.2010 06:43:32] Standalone support enabled: MTK/Sigma
    [05.12.2010 06:43:32] Started encoding.
    [05.12.2010 06:43:32] Demuxing and indexing.
    [05.12.2010 06:44:52] Processing file: E:\TEMP\encodes\decrypted dvd\VTS_01_1.VOB
    [05.12.2010 06:44:52] Source resolution: 720x480
    [05.12.2010 06:44:52] Found NTSC source.
    [05.12.2010 06:44:52] Source aspect ratio: 16:9
    [05.12.2010 06:44:52] Analyzing source.
    [05.12.2010 06:50:12] Source is considered to be interlaced.
    [05.12.2010 06:50:12] Output will contain 216981 frames
    [05.12.2010 06:50:12] Using VAQ in XviD
    [05.12.2010 06:50:12] Picking up autocrop parameters.
    [05.12.2010 06:50:12] Audio1 size: 173,757,696 bytes (165.71 Mb)
    [05.12.2010 06:50:12] Overhead: 1,206,656 bytes (1.15 Mb)
    [05.12.2010 06:50:12] Video size: 1,293,042,048 bytes (1233.14 Mb)
    [05.12.2010 06:50:12] Running compressibility test.
    [05.12.2010 06:56:58] Duration was: 6 minutes 45 seconds
    [05.12.2010 06:56:58] Speed was: 26,76 fps.
    [05.12.2010 06:56:58] Compressibility percentage is: 431,51
    [05.12.2010 06:56:58] Switching b-frames off
    [05.12.2010 06:56:58] Chosen resolution is: 624x352 ( AR: 1,77 )
    [05.12.2010 06:56:58] Predicted comptest value is: 322,77%
    [05.12.2010 06:56:58] Running first pass.
    [05.12.2010 08:24:40] Duration was: 1 hour, 27 minutes 42 seconds
    [05.12.2010 08:24:40] Speed was: 41,23 fps.
    [05.12.2010 08:24:40] Expected quality of first pass size: 323,64%
    [05.12.2010 08:24:40] Trying to adjust settings.
    [05.12.2010 08:24:40] No adjustment is possible
    [05.12.2010 08:24:40] Warning: final AVI will likely be undersized.
    [05.12.2010 08:24:40] Running second pass.
    every time it says "Warning: final AVI will likely be undersized", the final avi is a file smaller than 700mb with video bitrate at ~400 kbps. I can't understand the logic of this...
    Last edited by codemaster; 5th Dec 2010 at 00:37.
    Quote Quote  
  5. Originally Posted by codemaster View Post
    I think final size of 1400mb (2x700mb) makes sense for 120 min video
    Again, you don't know what you're talking about. Different movies compress differently. Yours, apparently because it's composed of mostly static images/pictures, has to be one of the most compressible movies of all time.
    05.12.2010 08:24:40] Expected quality of first pass size: 323,64%
    [05.12.2010 08:24:40] Trying to adjust settings.
    [05.12.2010 08:24:40] No adjustment is possible
    [05.12.2010 08:24:40] Warning: final AVI will likely be undersized.
    Anything over 100% can't reach the size requested. You fixed the width at 624. GKnot is crippled and not able to get the size you want (and it could only have made it a bit larger by increasing the resolution, if you had let it, and never even reach a full single CD). You've saturated the codec and there's no way for it to even fill a single CD, much less 2 CDs. Just be happy that, after you fixed the cropping problem, it looks as good is it possibly can.
    Quote Quote  
  6. now I understand why AutoGK gives an avg video bitrate of 423 kbps and avi file size of 538mb for 120min. This is a DVD wich contains a lecture comprised of a 4:3 slideshow type presentation with black background, centered whiting a 16:9 video, also with black background. Alot of black, alot of data between keyframes can be removed during compression. Even the source DVD has only 3,11GB for 120 min. The same lecture on Vimeo, encoded in H.264 at 360p, also has video avg bitrate ~500kbps.

    Click image for larger version

Name:	decrypted.avi_snapshot_00.11.51_[2010.12.05_16.40.12].jpg
Views:	398
Size:	27.3 KB
ID:	4567

    because it saw black at the top, bottom, left and right, and scenes in wich there is light in the whole frame are rare, it cropped too much, but after I've set treshold to 0 and nr of frames to examine = 1000, it didn't crop anything, or almost anything, I'm not sure...
    Last edited by codemaster; 5th Dec 2010 at 08:42.
    Quote Quote  



Similar Threads