VideoHelp Forum


Try StreamFab All-in-One and rip streaming video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 18 of 18
Thread
  1. Hi,

    I've started a similar thread a while ago (see https://forum.videohelp.com/threads/323713-DVD-Video-stutters-in-Windows-Media-Player-a...but-not-in-VLC), but now I am step further in localising the problem.

    I've got an interlaced DV file. As long as I play it without deinterlacing, it runs smoothly. But when deinterlacing is activated, either in VLC or the Windows Media Player, the video stutters.
    Even when I transcode the file with AVStoDVD and mark it as interlaced, the created DVD image stutters in both VLC and Windows Media Player.
    When I don't mark it as interlaced, I can run the image without problems (but with interlacing). But when I put it into my standalone DVD player, it stutters again (maybe because the DVD player deinterlaces it?).

    I'd be very glad if you could help me with some of your ideas since I'm starting to get frustrated.

    Yours
    Kado
    Quote Quote  
  2. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    What are your PC specs and Windows version?

    You should be able to play DV video in VLC. If your computer is reasonably speedy, use Video/Deinterlace/Yadif. This would be a real time software deinterlace. You can also set Yadif in VLC preferences as a default.

    What do you want to do with this video? If DVD is the goal, you will need to encode to MPeg2.
    Encode to 720x480i/29.97 (or 720x576i/25) at >8000 Kb/s (ave) bit rate. A progressive DVD player or progressive TV will easily deinterlace it in hardware.
    Last edited by edDV; 10th Aug 2010 at 15:47.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  3. Originally Posted by edDV View Post
    What are your PC specs and Windows version?

    You should be able to play DV video in VLC. If your computer is reasonably speedy, use Video/Deinterlace/Yadif. This would be a real time software deinterlace. You can also set Yadif in VLC preferences as a default.

    What do you want to do with this video? If DVD is the goal, you will need to encode to MPeg2.
    Encode to 720x480i/29.97 (or 720x576i/25) at >8000 Kb/s (ave) bit rate. A progressive DVD player or progressive TV will easily deinterlace it in hardware.
    Deinterlacing a different DV file with VLC works without problems. I'm running Windows Vista in the 64 bit edition on an Intel Core i3-530. So I guess it shouldn't be a matter of speed.

    As mentioned above I've already transcoded the DV file to a DVD and ran that on a standalone player. But unfortunately it stutters when playing.
    Quote Quote  
  4. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by Kado View Post
    Originally Posted by edDV View Post
    What are your PC specs and Windows version?

    You should be able to play DV video in VLC. If your computer is reasonably speedy, use Video/Deinterlace/Yadif. This would be a real time software deinterlace. You can also set Yadif in VLC preferences as a default.

    What do you want to do with this video? If DVD is the goal, you will need to encode to MPeg2.
    Encode to 720x480i/29.97 (or 720x576i/25) at >8000 Kb/s (ave) bit rate. A progressive DVD player or progressive TV will easily deinterlace it in hardware.
    Deinterlacing a different DV file with VLC works without problems. I'm running Windows Vista in the 64 bit edition on an Intel Core i3-530. So I guess it shouldn't be a matter of speed.

    As mentioned above I've already transcoded the DV file to a DVD and ran that on a standalone player. But unfortunately it stutters when playing.
    You PC is speedy enough.

    Is this camcorder DV video? How was it encoded?

    What MPeg2 encoder was used for the DVD? What settings?
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  5. Originally Posted by edDV View Post
    You PC is speedy enough.

    Is this camcorder DV video? How was it encoded?

    What MPeg2 encoder was used for the DVD? What settings?
    The video has been captured with a Sony handycam. This handycam stored it's videos on a miniDVD and I've copied it directly from there. I've got to say that the stuttering affects the original DV file and the one created with Adobe Premiere Pro later. Just to mention that I've already burnt multiple other (edited) DV files and there was never any problem.

    For enconding I've used AVStoDVD. I've tried ffdshow and FFmpeg. Both of the times the video ran smooth on my computer as long as not deinterlaced, but stutterd on the standalone DVD player.

    Here some settings for ffdshow:
    ... -b 8500 -1 -hq -novbr -scene -trell -aspectratio 4:3 -nointerlaced -mpeg2mux noaudio -dc 10 -priority 5 -auto -close
    This settings got me the best results. When instead of -nointerlaced I marked the video as interlaced, it even stuttered in Windows Media Player.
    Quote Quote  
  6. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    MiniDV or MiniDVD?

    I recall MiniDVD records direct to MPeg2. So import to a Premiere DV project would force a transcode to DV.

    If so, MiniDVD is top field first, DV is bottom field first.

    Does the "stutter" occur only during motion?

    If so you have a field order reversal somewhere in the process chain.
    Last edited by edDV; 10th Aug 2010 at 16:42.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  7. Originally Posted by edDV View Post
    MiniDV or MiniDVD?

    I recall MiniDVD records direct to MPeg2. So import to a Premiere DV project would force a transcode to DV.

    If so, MiniDVD is top field first, DV is bottom field first.

    Does the "stutter" occur only during motion?

    If so you have a field order reversal.
    The video was recorded on MiniDVD an yes, only motions "stutter".

    But as I've said, it doesn't matter which file I transcode, the stuttering occurs in the original DV file and in the one created by Adobe Premiere.
    Quote Quote  
  8. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by Kado View Post
    Originally Posted by edDV View Post
    MiniDV or MiniDVD?

    I recall MiniDVD records direct to MPeg2. So import to a Premiere DV project would force a transcode to DV.

    If so, MiniDVD is top field first, DV is bottom field first.

    Does the "stutter" occur only during motion?

    If so you have a field order reversal.
    The video was recorded on MiniDVD an yes, only motions "stutter".

    But as I've said, it doesn't matter which file I transcode, the stuttering occurs in the original DV file and in the one created by Adobe Premiere.
    It sounds like a field order reversal somewhere in your processing chain.

    It could be

    1. MiniDVD (MPeg2) import to Premiere DV project template.
    2. Premiere export to encoder
    3. Encoder settings

    Check the MiniDVD import clips in the bin or on the timeline (right click properties). See if they are interpreted TFF or BFF.

    If The Premiere project was set to DV format (BFF) all downstream encoders should be set to BFF.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  9. Originally Posted by edDV View Post
    It sounds like a field order reversal somewhere in your processing chain.

    It could be

    1. MiniDVD (MPeg2) import to Premiere DV project template.
    2. Premiere export to encoder
    3. Encoder settings

    Check the MiniDVD import clips in the bin or on the timeline (right click properties). See if they are interpreted TFF or BFF.

    If The Premiere project was set to DV format (BFF) all downstream encoders should be set to BFF.
    Already thank you for your help so far.

    I couldn't find the information which field comes first in Premiere, but I could find it with GSpot. According to GSpot, both the source AVI and Premiere's exported AVI are BFF. Is that bad?
    Quote Quote  
  10. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    Originally Posted by Kado View Post
    Originally Posted by edDV View Post
    It sounds like a field order reversal somewhere in your processing chain.

    It could be

    1. MiniDVD (MPeg2) import to Premiere DV project template.
    2. Premiere export to encoder
    3. Encoder settings

    Check the MiniDVD import clips in the bin or on the timeline (right click properties). See if they are interpreted TFF or BFF.

    If The Premiere project was set to DV format (BFF) all downstream encoders should be set to BFF.
    Already thank you for your help so far.

    I couldn't find the information which field comes first in Premiere, but I could find it with GSpot. According to GSpot, both the source AVI and Premiere's exported AVI are BFF. Is that bad?
    You need to experiment where the "jitter" starts.

    I'd start at your Premiere export file. Does it "jitter"? If so reverse the field order in your export settings.

    If some of the clips still jitter, the problem is at the source import.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  11. Originally Posted by Kado View Post
    Even when I transcode the file with AVStoDVD and mark it as interlaced, the created DVD image stutters in both VLC and Windows Media Player.
    When I don't mark it as interlaced, I can run the image without problems (but with interlacing). But when I put it into my standalone DVD player, it stutters again (maybe because the DVD player deinterlaces it?).
    If you have a DV file, which is natively interlaced, you should always encode it as interlaced, UNLESS you are trying to edit it, since many filters requires progressive content.

    Using AVStoDVD leave interlaced settings on (it should be on by default if source is interlaced) and check resulting DVD with the external DVD player (not VLC/MPC/WMP).

    If you see stuttering on the ext DVD player, post here the AVStoDVD project .log file.



    Bye
    MrC

    AVStoDVD Homepage
    Quote Quote  
  12. Originally Posted by _MrC_ View Post
    If you have a DV file, which is natively interlaced, you should always encode it as interlaced, UNLESS you are trying to edit it, since many filters requires progressive content.

    Using AVStoDVD leave interlaced settings on (it should be on by default if source is interlaced) and check resulting DVD with the external DVD player (not VLC/MPC/WMP).

    If you see stuttering on the ext DVD player, post here the AVStoDVD project .log file.



    Bye
    Hi, _MrC-.

    Here is the content of my .log file:

    ...
    Last edited by Kado; 8th Jan 2011 at 13:13. Reason: Privacy concerns
    Quote Quote  
  13. Could you leave the 'Interlaced Encoding' option ON and retry to run the project?



    Bye
    MrC

    AVStoDVD Homepage
    Quote Quote  
  14. Originally Posted by _MrC_ View Post
    Could you leave the 'Interlaced Encoding' option ON and retry to run the project?



    Bye
    Ok, I'll try it. But as far as I can remember I've already did that, and it didn't change anything.

    But I've found another solution that works pretty well on my hardware DVD player. In this one I deinterlace the file in AVStoDVD using an AVISynth function. Whether I leave the 'Interlaced Encoding' option on or off doesn't seem to matter to this way.
    Last edited by Kado; 8th Jan 2011 at 13:12. Reason: Privacy concerns
    Quote Quote  
  15. Okay, I've tried it again to verify it: Just marking the interlaced encoding option as on (with the parameter -interlaced) doesn't change anything. I have to deinterlace it with AVISynth to remove the "greasing" or stuttering of motions.

    Does that make any sense to you?
    And what would be a good way to deinterlace the video with AVISynth besides the LeakKernelDeint() function?

    Originally Posted by edDV View Post
    You need to experiment where the "jitter" starts.

    I'd start at your Premiere export file. Does it "jitter"? If so reverse the field order in your export settings.

    If some of the clips still jitter, the problem is at the source import.
    The jittering occurs even when I encode the source DV files. So I guess it starts there.
    Quote Quote  
  16. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    For Premiere here is what I'd do.

    First use mediainfo to confirm whether the source format is TFF or BFF. Set a Premeire project equal to the source format.

    If TFF, set project to TFF, export TFF amd encode TFF.

    If BFF, set project to BFF, export BFF amd encode BFF.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  17. Your MiniDVD camcorder captured TFF. That was converted to a DV AVI file without reversing the field order -- giving you a DV AVI file with TFF video. But DV AVI is always supposed to be BFF. So everything that plays or further edits the file assumes it's BFF. You need to reverse the field order before encoding as DV AVI. Or convince your editor that the DV AVI file is TFF (usually by overriding the source field order after importing the file).

    MediaInfo will always tell you a DV AVI file is BFF. It doesn't look at the actual content. Open the Video with VirtualDub. Add the Bob Doubler filter. Select the TFF option. Step through the video using the right arrow key. If you see smooth motion the video is TFF. I you see jerky (2 steps forward, one step back) motion it's BFF. If you see every pair of fields is a duplicate it's progressive. If you see a repeating pattern of 2 identical fields followed by 3 identical fields it's telecined film.
    Quote Quote  
  18. Thank you, edTV. Thank you, jagabo. I marked the files as TFF and now it works.

    I also thank you, _MrC_, for your efforts.
    Quote Quote  



Similar Threads