VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 12 of 12
Thread
  1. Member
    Join Date
    May 2008
    Location
    Australia
    Search Comp PM
    Hi Guys,

    I've been doing a stack of editing with files encoded with the Cedocida codec and have encountered a rather large problem.

    *Some* of the files play back all "jittery" in Windows Media Player AND when burnt to DVD as a movie. Play them in something like VLC, however, and they're fine.

    Obviously I'd love to just play the edited vision through VLC all the time, but often that's not possible so I need to burn the footage to DVD - which is where I encounter the problem.

    On the surface all the Cedocida encoded files are exactly the same (same source type ripped from DVD and encoded the same way) but a number of them have issues which the rest of them do not.

    By "jittery" I mean the vision is still visible, but something is off - giving it a type of strobe effect or something. To do with framerates/bitrates perhaps?

    Any ideas?
    Quote Quote  
  2. BuskerAlley.com zoobie's Avatar
    Join Date
    Feb 2005
    Location
    Colorado Rocky Mountains
    Search Comp PM
    sounds like the field order got reversed on some clips
    Quote Quote  
  3. Member
    Join Date
    Jan 2007
    Location
    Republic of Texas
    Search Comp PM
    Zoobie hit the nail on the head--reversed field order. Cedocida is not the problem. Rather, you had the wrong field order selected either in your editing program or whatever encoder you used to deploy Cedocida. Don't blame the codec.
    Quote Quote  
  4. Member
    Join Date
    May 2008
    Location
    Australia
    Search Comp PM
    Right. Thanks for clearing that up.

    The problem only started existing when I started using Cedocida, so I naturally assumed it might have been something there.

    If I'm using VirtualDub to do the encoding, how do I swap the field order?

    And how do I tell which way I need to have it each time?
    Quote Quote  
  5. Member
    Join Date
    Jan 2007
    Location
    Republic of Texas
    Search Comp PM
    Select a field reorder filter in VirtualDub. I like this one that you can download here: http://home.earthlink.net/~tacosalad/video/fldorder.htm

    Always experiment with a short, 10-second clip that has a lot of motion in it. That way, the encoding time is brief, and you can go by trial and error until you get something that looks right.

    Also, download GSpot. It will tell you if your source video is Interlaced or Progressive, and if interlaced, whether it is top or bottom field first.

    DV-AVI files are usually bottom field first, and that is the default of Cedocida and other DV codecs.
    Last edited by filmboss80; 4th Aug 2010 at 10:15. Reason: Added info about GSpot.
    Quote Quote  
  6. Reverse field order: crop one scanline from the top of the frame and add one to the bottom. Use the Bob Doubler to verify field order. DV should always be BFF.
    Quote Quote  
  7. Member edDV's Avatar
    Join Date
    Mar 2004
    Location
    Northern California, USA
    Search Comp PM
    The Cedocida codec is DV format. DV format is always lower field first. Normally one would set the output codec encoder to to lower field first.
    Recommends: Kiva.org - Loans that change lives.
    http://www.kiva.org/about
    Quote Quote  
  8. Member
    Join Date
    May 2008
    Location
    Australia
    Search Comp PM
    Gspot tells me that both clips are interlaced and bottom field first, as they should be. Even though one clip plays fine and the other plays back all strange.

    But, when using filmboss' suggestion of the field re-order filter it corrects the issue when using the "A to B" setting.

    Strange that Gspot never showed any difference between the files though.
    Last edited by BertRito; 4th Aug 2010 at 17:25. Reason: More info.
    Quote Quote  
  9. Gspot tells me that both clips are interlaced and bottom field first, as they should be. Even though one clip plays fine and the other plays back all strange.
    Gspot cannot tell you the field order of the actual content . There may also be a field order swap somewhere in your clips


    On the surface all the Cedocida encoded files are exactly the same (same source type ripped from DVD and encoded the same way) but a number of them have issues which the rest of them do not.
    Same source DVD or different DVDs ?

    Were they telecined ? interlaced ?

    How did you bring them into vdub and , what did you do in vdub before export using cedocida ?



    Maybe you can post a clip that demonstrates what you mean by "jitterly playback". You might be referring to something else
    Quote Quote  
  10. As poisondeathray pointed out, GSpot cannot determine the field order of the actual video, just what the file/video header says or what it assumes. All DV is supposed to be BFF so GSpot always reports BFF for DV AVI files. If you started with a TFF video and encoded with Cedocida (without changing the field order) the DV AVI file is flagged and interpreted as BFF, even though the frames are really TFF.
    Quote Quote  
  11. Member
    Join Date
    May 2008
    Location
    Australia
    Search Comp PM
    Basically it's the same sort of footage, split over two discs. One disc would come out fine, the other with the jittery playback.

    I assume that could mean the first disc was originally encoded as BFF (works fine) and the second disc as TFF (playback issues)? It's the way the discs were encoded in the first place, right?

    My encoding process is basically this - VOB2MPG to rip the DVD, VirtualDub MPG2 to encode to Cedocida. The only settings I use in VirtualDub are to change the encoding to Cedocida and change the audio to IMA ADPCM.

    Sample can be found here - http://rapidshare.com/files/411084558/Sample.avi

    I will process the entire file and make sure that works fine using the field order swap. If that works then I'm happy.

    EDIT: Looks like the file is fixed by using the field swap. Good result. Thanks guys.
    Last edited by BertRito; 4th Aug 2010 at 18:55.
    Quote Quote  
  12. That AVI can be fixed in VirtualDub by applying the Field Delay (BFF to TFF mode) then assuming the video is BFF.

    By the way, VirtualDub has screwed up the chroma channels from your original VOB files. This is because it doesn't handle interlaced YV12 video correctly. If you open your VOB files with AviSynth and convert to YUY2, then use VirtualDub to produce the DV AVI the colors won't be screwed up. The best way to do this is to produce an index file with DgIndex, then use Mpeg2Source() in AviSynth:

    Mpeg2Source("filename.d2v", upConv=1) #upConv=1 forces YUY2 output
    Crop(0,1,-0,-0) #convert TFF to BFF by cropping one line off the top
    AddBorder(0,0,0,1) #and adding one line to the bottom

    Then open that AVS script in VirtualDub and compress with Cedocida.
    Last edited by jagabo; 4th Aug 2010 at 19:55.
    Quote Quote  



Similar Threads