VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 2 of 2
  1. Member
    Join Date
    Jun 2010
    FT Mill, SC
    Search Comp PM
    I recently just bought a dazzle which came with Pinnacle Pro 8. Here's the problem: For 2 weeks, the dazzle worked fine. Then yesterday, I plug it in and it says "Device requires USB 2.0"

    Why it did this? IDK!

    Help would be much appreciated.

    P.S. - I also can't get my microphone port on the front of my laptop to work and I really need it to do cartoon voiceovers coz that's my thing, if anyone could help out on that, it would be appreciated as well. Thank You!
    Quote Quote  
  2. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Search Comp PM
    I'm guessing your laptop does have USB 2.0? If so, not sure why the program would not see it. Check your USB ports in Device Manager. 'Control Panel>System>Device Manager'. If you scroll down to your USB listings and open them, you should see the word 'Enhanced'. That's a USB 2.0 port. You can try uninstalling the controller and rebooting to reinstall and that should reset it if that's the problem. The only other thing I can suggest is to uninstall, then reinstall the Dazzle programs.

    With the microphone port, have you used it before with that mic? If it worked before, probably something in your audio settings. Those are also in 'Control Panel>Sound>Microphone'. If you haven't used that mic, make sure it's compatible with your mic inputs.

    And welcome to our forums.
    Quote Quote  

Similar Threads