VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. I bought the first season of Star Wars the Clone Wars on blu-ray and I'm trying to convert them to MP4 to play on my Xbox. I've done this successfully with several blu-ray disks before, but these are giving me fits. I've tried ripping them with DVDFab HD and AnyDVD HD, no problem there. When I take the m2ts files into RipBot, at the Blu-ray Structure window, it shows up as having no audio, no chapters and no subtitles available (video shows up as VC-1, 1080p24 / 1.001 (16:9)), but when I play the m2ts files in MPC or PowerDVD all of those things are present and working fine. I hit OK in RipBot and I get "Please Wait... Gathering Information" at the encoding screen (which also shows no audio) followed by the following error: "AviSynth Error - DirectShowSource : Timeout waiting for graph to start. (C:\temp\RipBot264temp\job1\getinfo.avs, line 2)".

    I've also tried using Handbrake on the m2ts files and it gives me an error that Handbrake has stopped working. I've also tried using Clown_BD to convert the m2ts file into a TS (which works fine, even shows the audio and subtitle tracks) and then tried to use Handbrake to convert that, but the same error occurs. The real kicker is it doesn't do this with every episode on the disc. 3 out of 7 episodes on disc 1 encoded just fine, and 3 of 8 on disc 2 did as well. Plus I've done other BD movies with zero problems so I'm pretty confused as to what the problem is.

    Anyone encounter an error like this before and know how to work around it? Are there any sort of dump files or information I can post here that might help? Any assistance would be greatly appreciated.
    Quote Quote  
  2. Maybe try using BDinfo to identify the playlist file (*.mpls) for each episode. Then select an *.mpls in tsMuxer to extract an episode. Repeat for each episode.
    Pull! Bang! Darn!
    Quote Quote  
  3. I tried what you suggested last night and I got a dozen or so errors on various m2ts files saying the disc was copy-protected or damaged asking if I wanted to continue the scan. When it was all finished scanning, none of the mpls files it listed contained any of the episodes, not even the ones I got to work properly. I tried this on the discs themselves and the ripped content on my drive, both had the same results. I know the discs aren't damaged because I can watch the episodes directly from the disc or by viewing the m2ts files in MPC or PowerDVD.
    Quote Quote  
  4. Just tried using BD Rebuilder with no luck. Here's the log. AVCHDCoder also gave me an error "Errorcode 0x0401: An error occurred while encoding video."

    -----------------------
    [19:00:21] BD Rebuilder v0.33.04 (beta)
    - Source: STAR_WARS_CLONE_WARS_S1_BOX
    - Input BD size: 19.25 GB
    - Approximate total content: [03:04:38.650]
    - Target BD size: 0.64 GB
    - Windows Version: 6.1 [7600]
    - MOVIE-ONLY mode enabled
    - Audio Settings: AC3=1 DTS=1 HD=0 Kbs=640
    [19:00:25] PHASE ONE, Encoding
    - [19:00:25] Extracting A/V streams [VID_00117]
    - Error in attempt to extract audio/subs.
    - File name C:\USERS\TRONATHON\DOCUMENTS\STAR_WARS_CLONE_WARS_ S1_BOX\BDMV\STREAM\00120.M2TS already exists.
    [19:00:26] - Failed to retrieve audio, aborted
    Quote Quote  
  5. Did you try extracting each episode with ClownBD first, *direct from original disc*, then re-encoding with BDRB? Or did you go from the rip with BDRB? I've found ClownBD to be very good at extracting a titleset accurately when nothing else will. The files you got with ClownBD are probably good, excepting perhaps only the audio.

    As to the errors you got in BDRB, what is the audio format? If it's True-HD or DTS-HD, that could be a problem. Libavcodec cannot decode all the information in either. Often, if you re-encode the audio while extracting with ClownBD, that can solve the failure to extract audio problem in BDRB. Specify audio output as AC3, or audio core only. Not sure how core will work, I always re-encode to AC3, as my target is BD 5/9. That method has worked for me on occasion when nothing else did.

    Worth a shot. Good luck.
    Pull! Bang! Darn!
    Quote Quote  
  6. I had tried ripping it to the drive with both DVDFab and AnyDVD, both whole disc and movies-only, and then tried to convert with Clown_BD, BD Rebuilder, Handbrake, RipBot or AVCHDCoder. None of them work, each of them gives one error or another. I've gotten 3 episodes on disc one to work simply by ripping with DVDFab, converting to TS with Clown_BD, then converting to MP4 in Handbrake... but none of the others work. The audio format on the disc is AC3, so I just set Clown_BD to leave it unchanged.

    I tried what you just recommended with trying to extract the episodes from ClownBD directly from the disc and within a few seconds it errors out after you hit next at Step 1. Here's the Log, it says this via mpls or BD/HD-DVD:

    eac3to v3.18
    command line: "C:\Users\Tronathon\Downloads\Clown_BD_v0.76\eac3t o\eac3to.exe" "D:\BDMV\PLAYLIST\00000.mpls" 1) -progressnumbers -LOG="C:\Users\Tronathon\Documents\Clone Wars\LOGS\eac3to_PASS2_LOG.LOG"
    ------------------------------------------------------------------------------
    The format of the source file could not be detected. <ERROR>

    Totally lost as to what's going on. I'd think if it were purely a copy-protection issue, or an audio issue, NONE of the episodes would work, but I can't figure out why certain episodes work and others don't. I've been wracking my brain over this for about a week now and it's really starting to get aggravating. I really appreciate the assistance though
    Quote Quote  
  7. I'm out of ideas.
    Pull! Bang! Darn!
    Quote Quote  
  8. Don't know if this provides any insight, but I just tried DVDFab's "Blu-ray to Mobile" mode and it actually managed to convert all the episodes on one disc into an MP4 file all in one pass, however it clumped all the episodes into one 3 hour-long file with no chapters, and the audio is horribly out of sync. That's the best I've managed to do, though.
    Quote Quote  



Similar Threads