VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. Member
    Join Date
    Apr 2010
    Location
    Burnley
    Search Comp PM
    I have an AVI that starts off ok but then goes out of sync, Ive been looking around the net for solutions and tried numerous things to resolve the out of sync problem

    I downloaded avidemux and opened the avi and it came up with the follwing 2 prompts:

    Build VBR time map?

    Avidemux detected VBR MP3 audio in this file. For keeping the audio/video in sync, time map is needed, build it now? Yes / No

    Packed Bitstream Detected

    Do you want me to unpack it? yes / No

    I clicked ok to both, I then pressed play in avidemux and it was absolutely perfect, I saved it and it starts ok but then gradually goes out of sync.

    I do have Sound Forge and I opened the avi in that but I havent got a clue on how to change it, if anyone can help I would be truly grateful

    Can someone give me some instructions on how to sort it

    Thankyou
    Last edited by Baldrick; 6th Apr 2010 at 11:15. Reason: Updated the title.
    Quote Quote  
  2. Saved it how? In Copy mode (for both audio and video) or did you recompress?
    Quote Quote  
  3. Member
    Join Date
    Apr 2010
    Location
    Burnley
    Search Comp PM
    Yeah in copy mode

    I cant understand how it plays perfectly in sync in avidemux but when I save it it goes back to the way it was
    Quote Quote  
  4. Because the VBR time map lets it keep the audio and video in sync. The map isn't included in the output in Copy mode. Try reencoding the audio with CBR.
    Quote Quote  
  5. Member
    Join Date
    Apr 2010
    Location
    Burnley
    Search Comp PM
    How do I do that? im not brilliant with this kind of stuff tbh
    Quote Quote  
  6. In the Audio pulldown select MP3 (Lame). Press the Configure button and select the parameters you want. Save.
    Quote Quote  
  7. Member
    Join Date
    Apr 2010
    Location
    Burnley
    Search Comp PM
    Im getting no where with this

    Can someone help me please

    Ive tried what Jagabo said and its still no better
    Quote Quote  
  8. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    If you have Sound Forge and know the basic functions, use Avidemux to demux the existing audio.
    Open the mp3 in Sound forge and save as a WAVE file.


    Open the avi in the Avidemux and load the WAV as the audio.
    Using the seek pointer review various sections (use the space bar in Virtualdub ). Is it in sync now ?
    If it's OK, set audio to mp3/ CBR (set Video to COPY).
    Save as a new AVI.
    Quote Quote  
  9. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    I took a look at the file. The sync is pretty good at the beginning and end, but is perhaps 1/2 second out in the middle
    I would convert the file to PCM audio (since it's only 20 minutes) and use this for your further editing.
    Open the original file in Avidemux set audio to PCM and save the new avi.

    I think you're going to have to cut the file into two, find a a convenient place somewhere in the middle
    and save each half into two new files. It's possible each section will need the audio to be time stretched slightly and/or
    shifted to make it fit.

    When you've fixed both pieces, you can join it back together.
    Quote Quote  
  10. Member
    Join Date
    Apr 2010
    Location
    Burnley
    Search Comp PM
    That sounds easy!!
    Quote Quote  
  11. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Think of it as a learning opportunity.

    Here's some further reading:
    https://forum.videohelp.com/threads/257022-How-to-fix-audio-synch-problem-in-AVI-file
    Last edited by davexnet; 8th Apr 2010 at 10:43.
    Quote Quote  



Similar Threads