VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 8 of 8
  1. Hi,

    Is it possible to play embedded DVB Subtitles (as bitmap) in a MPEG trasport stream with MPC? Any response will be appreciated..

    Thank you in advance
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Search Comp PM
    I don't think so. But MPCHC(beta version) supports DVB subtitles

    Revision 1335 - Directory Listing
    Modified Wed Nov 11 19:16:30 2009 UTC (3 months ago) by casimir666
    Added : support for DVB subtitles
    Quote Quote  
  3. Member
    Join Date
    Jul 2007
    Search Comp PM
    DVBViewer supports playback of both DVB subtitles and teletext subtitles in MPEG ts streams.
    Quote Quote  
  4. Originally Posted by Baldrick View Post
    I don't think so. But MPCHC(beta version) supports DVB subtitles
    Yes, I know that mpc-hc is supposed to support DVB subtitles (after version v1.3.1335.0) But I couldnt find out how should I configure the player to be able to playback DVB subs. Have anyone ever achieved to see DVB subs with mpc-hc?
    Quote Quote  
  5. Member
    Join Date
    Jul 2007
    Search Comp PM
    I forgot to mention that VLC support DVB subtitles.
    Quote Quote  
  6. yes fk, I know VLC does the job. For some reason we need to use MPC-HC as player. So I need to find a way to see DVB subs with MPC_HC.
    Quote Quote  
  7. Member Budman1's Avatar
    Join Date
    Jul 2012
    Search Comp PM
    I know this is an old thread but in case anyone still needs the info and reads this. I installed MPC-HC and tried a TS video with DVB subs.
    ID : 8197 (0x2005)
    Complete name : C:\Users\Bud\Desktop\test\The Secret Caribbean.ts
    Format : MPEG-TS
    File size : 43.8 MiB
    Duration : 1mn 48s
    Overall bit rate mode : Variable
    Overall bit rate : 3 389 Kbps

    ID : 520 (0x208)
    Menu ID : 8261 (0x2045)
    Format : MPEG Video
    Format version : Version 2
    Format profile : Main@Main
    Format settings, BVOP : Yes
    Format settings, Matrix : Custom
    Format settings, GOP : M=3, N=12
    Codec ID : 2
    Duration : 1mn 47s
    Bit rate mode : Variable
    Bit rate : 3 028 Kbps
    Maximum bit rate : 15.0 Mbps
    Width : 704 pixels
    Height : 576 pixels
    Display aspect ratio : 16:9
    Active Format Description : Letterbox 16:9 image, with alternative 14:9 center
    Frame rate : 25.000 fps
    Standard : PAL

    ID : 521 (0x209)
    Menu ID : 8261 (0x2045)
    Format : MPEG Audio
    Format version : Version 1
    Format profile : Layer 2
    Codec ID : 3
    Duration : 1mn 48s
    Bit rate mode : Constant
    Bit rate : 192 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Delay relative to video : -291ms
    Stream size : 2.47 MiB (6%)
    Language : English

    ID : 523 (0x20B)
    Menu ID : 8261 (0x2045)
    Format : DVB Subtitle
    Codec ID : 6
    Duration : 1mn 44s
    Delay relative to video : 1s 632ms
    Language : English

    ID : 256 (0x100)
    Menu ID : 8261 (0x2045)
    Duration : 1mn 48s
    List : 520 (0x208) (MPEG Video) / 521 (0x209) (MPEG Audio, English) / 523 (0x20B) (DVB Subtitle, English)
    Language : / English / English

    Turning on and off subtitles had no effect. I already have directvobsub installed but that didn't help either. The only way I finally found to get subtitles to show was by setting Play --> Filters --> Lav splitter source and select the subtitles. Lav splitter was installed as part of my K-Lite codec pack but are available from their download site . I have not installed from this way, only from the codec pack.
    Click image for larger version

Name:	ScreenHunter_227 Oct. 21 01.27.jpg
Views:	271
Size:	314.7 KB
ID:	14361

    Subtitles show as :
    Click image for larger version

Name:	ScreenHunter_228 Oct. 21 01.42.jpg
Views:	244
Size:	251.9 KB
ID:	14362
    The setting seems to reset every time I ope MPC-HC but at least it works in case anyone is still looking.
    Last edited by Budman1; 21st Oct 2012 at 02:47. Reason: Trim excess
    Quote Quote  
  8. Thank you Budman! You know what, I was still looking for this solution. Now after almost 3 years I got the solution. Thank you indeed..
    Quote Quote  

Similar Threads