VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Banned
    Join Date
    Jan 2010
    Location
    Cyprus
    Search Comp PM
    I have some movies and their external greek subtitles in .srt format. I have in my pc Windows Vista Ultimate Greek and when I open the avi file the Greek fonts of the greek subtitles are unreadable. I use the VLC media player.
    I also opened the .srt file of the subtitles and the greek fonts there are also unreadable(just like these----Μετάφραση και). What can I do to fix this problem? What do I have to change so that I can see the correct greek fonts while playing the avi file?
    Quote Quote  
  2. Rancid User ron spencer's Avatar
    Join Date
    May 2005
    Location
    Ish-ka-bibble
    Search Comp PM
    this is news? better fix
    'Do I look absolutely divine and regal, and yet at the same time very pretty and rather accessible?' - Queenie
    Quote Quote  
  3. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Moving you to our subtitle section.
    Quote Quote  
  4. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    You're not going to like what you have to do to make this work.

    First you have to determine what format the subtitles are in. Are they in Unicode or some Greek code page? If they are in Unicode then that means that VLC doesn't support Unicode. I have no idea if it does or not. If they are not in Unicode, then you have to go to Control Panel -> Date, Time, Language and Regional Options -> Regional and Language Options -> Advanced and under "Select a language to match the language version of the non-Unicode programs you want to use" you have to pick Greek. Reboot. If you are lucky, the subtitles will now work. However, many of your programs may now display garbage characters when you try to use them as they are now trying to use Greek fonts for anything installed that is not in Unicode.

    You may also check to see if various Greek packages are installed under "Advanced" (get to it as I said above) and install any that are missing. If you install all the Greek packages there is some chance that you may be able to read the subtitles without having to do what I talked about above.
    Quote Quote  
  5. Member
    Join Date
    Mar 2012
    Location
    Cyprus
    Search Comp PM
    Geia sou Ioakim!

    The above post may be correct, but it seems unnecessary to change the way your operating system behaves for all programs and files, instead of changing the way that one file behaves

    A bit of history: Greek code pages were a complete mess up to 95, due to the fact that every brainiac invented a code page of his own and there was never an authority in Greece to say, guys, this is how we're gonna do it. Then windows95 came with full Greek support, that defaulted to -one- Greek code page, commonly known today as windows modern Greek. That was awesome at the time and solved the issue somewhat because windows was used by almost 100% of users at the time. But the real solution came with the creation of unicode (utf-8) the one codepage to rule them all! One code page that had every character for every major language, including Greek. Problem is, Windows XP wasn't using unicode, or at least it didn't default to it. And to this day XP is a huge chunck of the install base, which means creators of .srt files may use many obscure code page types :/

    Ok, so now the solution. What you need to do is pretty straight forward. Convert your srt files to unicode. It will work across programs, and across platforms. This tutorial presumes that you use windows, and have ms office installed. But I've done the same on a Mac, its the same thing.

    1. Open you file in Word. A modal comes up that asks you "which damn codepage is this suppost to be?" You choose any codepage that make the previewed text appear in proper greek.



    2. You go to "Save As..." and hit "Save". Make sure the "Save as type:" dropdown is set to "Plain Text (*.txt)





    3. The file conversion dialog should come up, asking you in which code page you wish to save this. Scroll the little list almost to the bottom, and choose "Unicode (UTF-8)"



    5. Go to the file you just saved, and rename it, changing its extention from .txt to .srt That's it! Your new .srt is now in unicode.
    If you don't see any file extensions, it is because the default setting on both Windows and OS X is to hide them. To show file extentions is a simple setting on Windows Explorer/Finder, google it. It is also a good practice in general to have file extentions showing anyway

    So, there you have it! Turn any weird code page encoding to Unicode and the problem solved
    Quote Quote  
  6. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    3 points:

    1) No need for Winword.exe --- Wordpad or even Notepad should be sufficient in this case ;

    2) I don't know what you mean by "XP does not use Unicode" or something Even Windows 95 was half-assed regarding Unicode, however proper UTF-8~to~UCS-2 mapping was fully-functional in Word 97, IE 4 and Netscape Comunicator

    3) You're two years late

    Originally Posted by aenaon View Post
    Geia sou Ioakim!

    The above post may be correct, but it seems unnecessary to change the way your operating system behaves for all programs and files, instead of changing the way that one file behaves

    A bit of history: Greek code pages were a complete mess up to 95, due to the fact that every brainiac invented a code page of his own and there was never an authority in Greece to say, guys, this is how we're gonna do it. Then windows95 came with full Greek support, that defaulted to -one- Greek code page, commonly known today as windows modern Greek. That was awesome at the time and solved the issue somewhat because windows was used by almost 100% of users at the time. But the real solution came with the creation of unicode (utf-8) the one codepage to rule them all! One code page that had every character for every major language, including Greek. Problem is, Windows XP wasn't using unicode, or at least it didn't default to it. And to this day XP is a huge chunck of the install base, which means creators of .srt files may use many obscure code page types :/

    Ok, so now the solution. What you need to do is pretty straight forward. Convert your srt files to unicode. It will work across programs, and across platforms. This tutorial presumes that you use windows, and have ms office installed. But I've done the same on a Mac, its the same thing.

    1. Open you file in Word. A modal comes up that asks you "which damn codepage is this suppost to be?" You choose any codepage that make the previewed text appear in proper greek.



    2. You go to "Save As..." and hit "Save". Make sure the "Save as type:" dropdown is set to "Plain Text (*.txt)





    3. The file conversion dialog should come up, asking you in which code page you wish to save this. Scroll the little list almost to the bottom, and choose "Unicode (UTF-8)"



    5. Go to the file you just saved, and rename it, changing its extention from .txt to .srt That's it! Your new .srt is now in unicode.
    If you don't see any file extensions, it is because the default setting on both Windows and OS X is to hide them. To show file extentions is a simple setting on Windows Explorer/Finder, google it. It is also a good practice in general to have file extentions showing anyway

    So, there you have it! Turn any weird code page encoding to Unicode and the problem solved
    Last edited by El Heggunte; 11th Mar 2012 at 20:16. Reason: better wording
    Quote Quote  
  7. Member
    Join Date
    Mar 2012
    Location
    Cyprus
    Search Comp PM
    Good to hear that you can do it with wordpad and notepad Care to give a quick walkthrough on it?
    Quote Quote  
  8. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    Originally Posted by El Heggunte View Post


    3) You're two years late
    I think I complain more than anybody around here about grave robbing, but this is one of the rare times when I think it was very appropriate to update an old thread. However, my experience has been that many subtitle programs will NOT accept Unicode subtitles. It's worth a try for sure, but if it fails then people will have to fall back to the my suggestions earlier in the thread.

    Cyrillic has somewhat similar issues to Greek with multiple incompatible code pages existing I've done a little subtitle work in Russian (OCR stuff) and it's a real bitch to get it working on non-Cyrillic versions of Windows. In theory Win 7 Ultimate should be better at this, but I haven't needed to do any non-English subtitle OCR since I installed Win 7 so I have not tried that yet.
    Quote Quote  
  9. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    Originally Posted by jman98 View Post
    Originally Posted by El Heggunte View Post
    3) You're two years late
    I think I complain more than anybody around here about grave robbing, but this is one of the rare times when I think it was very appropriate to update an old thread. However, my experience has been that many subtitle programs will NOT accept Unicode subtitles. It's worth a try for sure, but if it fails then people will have to fall back to the my suggestions earlier in the thread.

    Cyrillic has somewhat similar issues to Greek with multiple incompatible code pages existing I've done a little subtitle work in Russian (OCR stuff) and it's a real bitch to get it working on non-Cyrillic versions of Windows. In theory Win 7 Ultimate should be better at this, but I haven't needed to do any non-English subtitle OCR since I installed Win 7 so I have not tried that yet.
    Me neither is against due updates to old threads. My main complaints in this case are:

    1) aenaon recommended a very-inconvenient tool ( not everybody has, or likes to use, Microsoft Word, especially the versions with the stupid and annoying "ribbon interface" ) ;

    2) aenaon gave a helping hand to misinformation Technically, Unicode and UTF-8 are NOT "codepages", to begin with, and Microsoft themselves apparently "love" the whole codepage-hell thing IF Unicode is to be taken seriously, THEN there is NO good-reason to assign a specific "language" to a .DOC file, for example
    Quote Quote  



Similar Threads