If you are experiencing DVD preview issues (no sound or no video) when using VOB2MPG, please read the following...

Firstly, if you can't play the DVD in Windows Media Player, you will have very little chance of being able to do so in VOB2MPG. It uses the same technology. Server operating systems typically don't allow this.

Secondly, VOB2MPG's DVD Preview works fine on fresh installs of XP, Vista & Windows 7. 32bit and 64 bit. However, over time, tweaks, codecpacks or other installed programs may have updated the default DirectShow filters and preferences and this is often the cause of any issues.

In order to overcome issues, VOB2MPG has two DVD Player controls (Type 1 & Type 2). Type 1 is the orignal control which attempts to build the DirectShow graph (used to play DVDs) manually. Type 2 is a newer control based on Microsoft's Video Control, which delegates the building of the DirectShow graph to the Microsoft control.

Type 2 is the default.

If you have an issue with either Type - try the other one. This can be done in the Settings or from the VOB2MPG Start Menu. (If you do change this then you will need to restart VOB2MPG to see the effect).

(Note: If the choice of Type 1 or Type 2 DVD control causes an application failure - VOB2MPG will not use it at all)

You can always tell which DVD Control Type you are using be hovering your cursor over the "type" label as shown:

If you continue to have issues, read on.

No Audio

This is 99% down to the fact that you have no AC3 DirectShow filter on your PC. Install AC3Filter and restart VOB2MPG to solve the problem.

No Video

Again this is down to no MPEG2 DirectShow filter (or the one you have not working correctly). I recommend installing the DScaler5 Mpeg2 filter. Again restart VOB2MPG (and you may also be wise to reboot).

Windows 7

As stated previously, a fresh Win 7 installation (32 & 64 bit) offers no problems for the DVD Preview. If however you have issues AND you have done the above recommendations and are still having issues, you may have to do an extra step... Run Preferred Filter Tweaker and set the MPEG2 preferred option to DScaler5 MPEG-2 decoder (assuming you have already installed it) - and reboot.


You may need to increase the merit of the DScaler5 DirectShow filter:

- Using DirectShow Filter Manager:
- Double Click on DScaler Mpeg2 Video Decoder
- Set it's MERIT to the maximum:

Reboot your PC....