VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    Hi folks,

    First of all apologies if this is in the wrong forum section, i was unsure of the correct area to post it.

    I bought a camcorder, the Samsung SMX-F30 model. I bought it because i had some urgent interviewing to do this week and the idea of recording on to SD cards sounded good, and more importantly fast. I have some experience using codecs and encoding etc but as i havent been in the game for a while i hadnt heard of this H.264 codec but thought that would be easily sorted out.

    Well, over the last few days of testing i've had no luck with this codec at all. When i imported some video files from the camera i had no problem playing them in Sony Vegas and WMP, problem is they squash the widescreen down to 4:3. The Cyberlink software that came bundled with the camera is the only one which plays them automatically in widescreen. This confused me as i thought all programs would play them back the same way. The footage is also a little jerky at times too when panning,

    I downloaded quicktime 7 as i thought that might help, but unfortunately it didnt. It also squashed the file. To be honest its not so much the media players that bother me , it more important that i get it to play properly in Vegas as i have some editing to do urgently.

    Oh and i also uninstalled the Codec pack i had installed as i read they may conflict with each other, From then on i just downloaded the codecs i needed.

    If anyone could be of any help it would be much appreciated. I listed all the info i could think of, if i missed something that would help, let me know and i'll get it up right away.

    Thanks very much.
    Quote Quote  
  2. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    Windows Media Player is not a good indicator of anything, unfortunately. It's regard (or otherwise) for things like aspect ratio are pretty hit and miss.

    For Vegas, make sure you set the project settings to 16:9 (File-> Properties), preferably before loading the footage onto the timeline.
    Read my blog here.
    Quote Quote  
  3. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    Hi there,

    Thanks for the reply.

    I tried again, ensuring i changed project properties. I chose PAL widescreen. Unfortunately, i got the same result.

    One thing i did notice though, was that when i right clicked on the individual clips on the timeline and changed their ratios in clip properties, they then played back in widescreen.

    Im sure when doing this the quality is a bit jerky and that though right clicking individual clips (of which there are many) might improve the situation in the back of my mind it seems like a short cut and i would like to get to the root of the problem. Be it codecs etc...

    Any more help/suggestions would be much appreciated.

    Thanks again.
    Quote Quote  
  4. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    Then it would seem to be an issue with identifying correctly the aspect ratio of the clip. This isn't completely surprising, given the wide ranging interpretation of the standards for H.264 based cameras.

    You don't say which version of Vegas you are using, but if it is an older version it may simply not know how to deal with these clips. Even the later versions don't recognise all cameras as new camera come out all the time. right-clicking the clips and setting them to the correct aspect ratio might be the only solution you have for the moment.
    Read my blog here.
    Quote Quote  
  5. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    I am using Vegas Pro 9.0. I guess this workaround may be my only option and it's just a simple ratio correction. I'm sure my quality could be a touch better as well though.

    I should have maybe researched H.264 more thoroughly. I thought they may have even included the codec.
    Quote Quote  
  6. Member
    Join Date
    Jun 2003
    Location
    United States
    Search Comp PM
    Samsung's implementation of the wide-screen flag is bad. I know this because I have the MX20 camcorder. I drop the videos into MPEG Streamclip and export them as H264/MP4 or Quicktime>DV (depending on what I intend to do with them afterwards). If DV, I set the 16:9 flag and set my sequence accordingly in FCP. If H264, I set the resolution to 640x360; the MX20 is a SD camcorder. I deinterlace if I'm going to H264. If going to DV (for FCP editing) I've been told to leave the deinterlacing to FCP.

    I would imagine Vegas has the same sort of deinterlacing features (if you need them).
    Quote Quote  
  7. sony vegas doesn't like any samsung camera's video. samsung doesn't play by the rules and won't play royalties so they use their own codecs that don't exactly conform to the standards.


    there's a trick in vegas that might help. import one video. right click on the file properties. make your changes. click save. now try importing the others. it "should" remember and adjust all similar files.

    good luck.
    Quote Quote  
  8. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    Thanks for the samsung info, thats interesting. I really should have done some research.

    mini2dvd: i tried the trick, i was praying it would work, but alas it didnt. Though maybe i have to make more changes in clip properties. I was a bit scared to try anything else, all i changed was the ratio. Would there be anything else to consider?

    rumplestiltskin: The method you suggested with MPEG Streamclip seems like it maybe what i should do to but im unsure of which settings to use.

    Basically i want to:
    import some H.264 files into Sony Vegas -
    sync them up with the audio and render -
    then import the rendered takes for a little editing -
    and ultimately put them on to DVD.

    Any advice on what would be the best conversion pre-vegas would be great.

    Thanks.
    Quote Quote  
  9. Member
    Join Date
    Jun 2003
    Location
    United States
    Search Comp PM
    I do not know Vegas but, from how it's described in the Tools section here, it appears as though it works with H264 just fine. If so, open the video with MPEG Streamclip and select "Export to MPEG4...". Choose H264 from the popup menu (it should already be selected). I use "100%" for the quality. Set the bitrate (I use 3500kbps but you'll have to decide what you need). Set the actual output frame size (use multiples of 16) as if the wide-screen flag doesn't exist (because, in the case of the Samsung, it doesn't). Save.

    MPEG Streamclip permits you to select portions of the video (using the "i" and "o" keys so you may run a number of tests on that short portion. Don't forget to clear the i/o points before doing the whole video.

    What do you mean by "sync them up with the audio"? Isn't the A/V sync'd?

    Your camcorder is the new version of mine.
    Quote Quote  
  10. You might try less destructive methods before you attempt to re-encode for importing; and if you do re-encode I would try to use a lossless method instead of a lossy method

    Try re-wrapping and setting the proper flag e.g. yamb into .mp4 setting the PAR

    It might help if you provide more information on your source files (e.g. use mediainfo)

    Your playback issues may be related to your PC specs. You might be dropping frames on playback if your PC is too slow, causing the issues during panning
    Quote Quote  
  11. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    rumplestiltskin: Sorry i forgot to mention, i recorded the audio seperately with a clip mic. It's weird because in general editing use the footage does work fine in Vegas, it just doesnt retain the widescreen and the playback doesnt seem quite as smooth as it should do, though maybe on a high quality render that would be fine.

    poisondeathray: I definately would like the end dvd version to be the highest quality it could be and having my footage on SD card i thought would make that simpler. Any way of avoiding extra steps and saving quality and time (given the amount of clips/footage i have) would be great. I downloaded mediainfo, heres the readout it gave me. Hope this helps.

    Thanks again.

    General
    Complete name : C:\Documents and Settings\New Folder\SDV_0023.MP4
    Format : MPEG-4
    Format profile : JVT
    Codec ID : avc1
    File size : 10.3 MiB
    Duration : 15s 560ms
    Overall bit rate : 5 566 Kbps
    Encoded date : UTC 2003-01-31 16:06:00
    Tagged date : UTC 2003-01-31 16:06:00

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 15s 560ms
    Bit rate mode : Variable
    Width : 720 pixels
    Height : 576 pixels
    Display aspect ratio : 5:4
    Frame rate mode : Constant
    Frame rate : 25.000 fps
    Standard : PAL
    Stream size : 10.1 MiB (97%)
    Encoded date : UTC 2003-01-31 16:06:00
    Tagged date : UTC 2003-01-31 16:06:00

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format version : Version 4
    Format profile : LC
    Format settings, SBR : Yes
    Format settings, PS : No
    Codec ID : 40
    Duration : 15s 360ms
    Bit rate mode : Constant
    Bit rate : 122 Kbps
    Nominal bit rate : 128 Kbps
    Channel(s) : 2 channels
    Channel positions : L R
    Sampling rate : 48.0 KHz
    Resolution : 16 bits
    Stream size : 228 KiB (2%)
    Encoded date : UTC 2003-01-31 16:06:00
    Tagged date : UTC 2003-01-31 16:06:00
    Quote Quote  
  12. Is this supposed to be 16:9 ?
    You can see from mediainfo that the DAR is set to 5:4

    Open your video in yamb, highlight the video track, select properties, under the pixel aspect ratio select 16:9 PAL (If it doesn't give you that option enter custom value 64:45), press ok & next

    All this does is "re-package" your video , no quality loss, and no time spend re-encoding (should be very quick to re-wrap as opposed to re-encoding)

    Unfortunately if you have many videos, I don't know of a batch method, although theoretically there could be one based on mp4box (since it's a command line app)

    If that doesn't work, and your final format goal is DVD, you should be able to edit and do everything in 5:4 in vegas, because the 16:9 flag is set later anyways when encoding to DVD. The only issue with this is you must compensate for the AR with titles/graphic and such
    Quote Quote  
  13. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    Yeah i noticed myself it said 5:4, thought that was strange. In the camcorder settings there are only two setting 4:3 standard and16:9 widescreen. Even stranger that sony vegas, wmp, quicktime and VLC all squash the image down. The bundled camera software (Cyberlink Mediashow) is the only software that plays it 16:9 by default. Maybe that why they bundled that software, because they programmed it to work with theyre codec. What do i know though.
    Quote Quote  
  14. Member
    Join Date
    Sep 2008
    Location
    United Kingdom
    Search Comp PM
    All sorted and done with now. Thanks for all the help. I just changed the clips individually.
    Quote Quote  



Similar Threads