VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. I have played hundreds of avi's with srt subtitles with Media Player Classic and never had a problem. But now I got an avi (see G-spot screenshot of this avi) that when I put the srt file in the same folder as the avi, the avi won't play. The avi plays fine if there is no srt subtitle file, or if the srt file is not named correctly (ie, video.avi/video1.srt). But if the srt file is not named correctly, of course there are no subtitles. The avi will also not play (when srt file in same folder) with Real Player. However, the avi will play correctly with subtitles using KM Player or VLC Player. I tried reinstalling
    ffdshow_rev1120_20070423_clsid, but that did not help. Other avi/srt on my computer still play fine. I think the srt file is fine. I inputed the srt file into Time Adjuster and there were no errors with the srt file.
    I am focusing in the strange picture size (see red circle in screenshot) of this problem avi. Could this be the cause of the problem? How can I get this avi/srt to play with Media player Classic? I was able to use DVDFlick and convert to DVD with subtitles, no problem, but I still want to know why this avi/srt will not play with Media Player Classic. Any ideas would be greatly appreciated.

    Quote Quote  
  2. I just made a quick test xvid video at 548x226 and MPCHC played it fine with SRT subs. Try using your SRT subs with another video. If they work with another video then maybe it's something about the 548x226 video. If they don't work then maybe there's something wrong with the subs.
    Quote Quote  
  3. Tried the subfile with another video and the video and subs played fine (of course wrong subs). I think there is something about the avi pic size (548x226) that can't handle rendering the subs.
    Quote Quote  
  4. Is there a software that can change the avi pic size without changing any other parameters? I would like to try that. That would prove that the pic size is the cause of the problem. Or could you please post a short video clip with the above pic size (548x226)? Then I can see if it works for me.
    Quote Quote  
  5. Here's a ~1 minute clip at 548x226, 23.976 fps Xvid + 128 kbps MP3 audio:

    548x226.avi
    Quote Quote  
  6. Thanks for the video. Confirmed (on my computer) that 548x226 will not play in Media Player Classic, Real Player or Win-amp if there is matching srt or sub file in folder. Will play fine (but no subtitles) if no srt file, or if srt file is missnamed. However,
    KM Player plays the clip fine with subtitles. Screenshot 1 shows trying to play, but video stays at 0. Screenshot 2 shows missnamed srt and video plays fine (screenshot can't render picture). Note automatically resized picture frame in screenshot 2. Thanks to KM Player, I was able to play my avi video and see subtitles, check and adjust subtitles timing before making DVD. Conclusion: strange picture sizes will not allow for subtitles on some computers. Best to avoid strange picture sizes. Not sure if my Vobsub or FFdshow is outdated and causing this problem.



    Quote Quote  
  7. What sub overlay program are you using? Try updating it. Also try using a different Divx/Xvid decoder.

    And yes, it's best to avoid using mod2 frame sizes.
    Quote Quote  



Similar Threads