VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    Aug 2006
    Location
    United States
    Search Comp PM
    Hi,

    I'm on Mac OX 10.5 Intel using ffmpegx v. 0.0.9x
    Have no problems converting mkv and other files.

    Need help for .rmvb files:
    I've followed all the instructions:
    - downloaded the essential codecs package (Intel) - essential-macosx-x86-20060611
    - opened and copied the codecs folder and changed its name to reallib.
    - installed it inside HD/library/application support/ffmpegX

    When I launch ffmpegX and place a .rm folder inside, it no longer hangs as it used to.
    I read somewhere in this forum that it will only convert into .avi divx file using mencoder so I chose that option.
    I chose film rate since the original 2300 made no sense?
    It will not convert and keeps on will the blue candy cane. It did that for .avi as well.

    Please help if possible. Thanks.

    Here is the information from progress:

    Encoding started on Wed Jun 17 00:37:57 PDT 2009
    FIXME:Hardenabling SSE and SSE2 without detection
    MEncoder dev-CVS-060307-04:23-4.0.1 (C) 2000-2006 MPlayer Team
    Mac OSX static build for ffmpegX
    CPU: Intel Pentium III Katmai/Pentium III Xeon Tanner (Family: 6, Stepping: 6)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    FAAD: compressed input bitrate missing, assuming 128kbit/s!
    success: format: 0 data: 0x0 - 0x61d9bf2
    REAL file format detected.
    Stream description: Audio Stream
    Stream mimetype: audio/x-pn-realaudio
    Stream description: Video Stream
    Stream mimetype: video/x-pn-realvideo
    Stream mimetype: logical-fileinfo
    VIDEO: [RV40] 704x396 24bpp 23.000 fps 0.0 kbps ( 0.0 kbyte/s)
    [V] filefmt:11 fourcc:0x30345652 size:704x396 fps:23.00 ftime:=0.0435
    ================================================== ========================
    Error: dlopen(/Library/Application Support/ffmpegX/reallib/drvc.so, 1): no suitable image found. Did find:
    /Library/Application Support/ffmpegX/reallib/drvc.so: unknown file type, first eight bytes: 0x7F 0x45 0x4C 0x46 0x01 0x01 0x01 0x00
    Error: dlopen(/Library/Application Support/ffmpegX/reallib/drv4.so.6.0, 1): image not found
    anced Audio Coding)
    AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
    Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
    ================================================== ========================
    xvid: using library version 1.2.-127 (build xvid-1.2.0-dev)
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [scale w=704 h=400]
    MP3 audio selected
    =========
    Opening video decoder: [realvid] RealVideo decoder
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    Selected video codec: [rv40mac] vfm: realvid (Mac OS X RealPlayer 9 RV40 decoder)
    ================================================== ========================
    VDec: vo config request - 704 x 396 (preferred colorspace: Planar I420)
    VDec: using Planar I420 as output csp (no 0)
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    SwScaler: FAST_BILINEAR scaler, from Planar YV12 to Planar YV12 using MMX2
    videocodec: XviD (704x400 fourcc=44495658 [XVID])
    xvid: par=0/0 (vga11), displayed=711x400, sampled=704x400
    xvid: CBR Rate Control -- bitrate=1454kbit/s
    Writing header...
    ODML: vprp aspect is 16:9.
    Writing header...
    ODML: vprp aspect is 16:9.
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    1 duplicate frame(s)!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    Skipping frame!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    Skipping frame!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    A-V:0.035 [1240:128]
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    1 duplicate frame(s)!
    Quote Quote  
  2. Member
    Join Date
    Aug 2006
    Location
    United States
    Search Comp PM
    Thanks. The blue candy cane continues in Progress but a file is made quite quickly. And it works. Hurrah!
    Quote Quote  
  3. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by Dolly
    I chose film rate since the original 2300 made no sense?
    Well spotted, that some setting didn't make sense. But the NTSC Film framerate may not be the best matching framerate and could be a cause for lots of "duplicate frame(s)" messages in the log. Try to find the true source file framerate, using Clip Info in RealPlayer. Then use that framerate as target framerate in ffmpegX.
    Quote Quote  
  4. Member
    Join Date
    Aug 2006
    Location
    United States
    Search Comp PM
    @ Case. Clip Info did not show framerate. ffmpegX showed it as 2300. I had read somewhere that ffmpegX will only convert .rm files (first take out vb) into Divx at the NTSC value of 29.97. So I used that rate, ignored the candy cane, and the Divx file was completed quickly. Which I then converted into a .avi file. Both using mencoder option. A bit of muddling and experimenting but it worked out.
    Quote Quote  



Similar Threads