VideoHelp Forum

+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Hello,

    I am relatively new to ffmpegX, and would really appreciate any help!!!

    I have subtitles in French (.ass and .srt formats), and I am trying to hardsub them onto an .avi file. The subtitles look perfect in the preview, but in the encoded video some of characters consistently get turned into underscores. Specifically, a few of the ' characters turns into _. This only happens for some of the ' characters - I can't figure out why. All the ' characters appear to be the same in the subtitle file.

    I set the subtitles font to Arial and text encoding to UFT-8 (which is the encoding used when the subtitles were originally created). I have tried other fonts and text encoding, but the French accents, etc. get even more screwed up.

    Is there a problem with my original subtitle file? Should I convert it to a different format, or use different encoding (in Jubler)?
    Or is the problem with my settings in ffmpegX?

    Thank you for any help!!!
    Quote Quote  
  2. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    The underscore character is often used for missing characters. There must be some code that can't be mapped to a character in your subtitle file.
    Perhaps convert to ISO Latin 1 (ISO 8859-1), as that character set contains all characters for Western European languages, including French. That should clear it.
    Quote Quote  
  3. Thank you for your reply, and apologies for this belated response!

    I have tried converting the UTF-8 subtitle file (.ass and .srt versions) to ISO Latin 1 (ISO 8859-1) using Jubler's "save as" command, but Jubler says "use proper text encoding" and won't save the file.

    I also tried opening the UTF-8 subtitle files using Text Edit (Japanese version), but it says the files can't be opened because the text encoding is not compatible with Japanese.

    How do I convert UTF-8 subtitle files to ISO Latin 1?

    Thank you!!!
    Quote Quote  
  4. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by atyamamoto
    I also tried opening the UTF-8 subtitle files using Text Edit (Japanese version), but it says the files can't be opened because the text encoding is not compatible with Japanese.
    Check TextEdit Preferences > Open and Save > Plain text file encoding > Opening files. Perhaps that is set to 'Japanese', instead of 'Automatic'. Try setting it to 'Automatic' or 'UTF-8' (temporarily), and then try opening your UTF-8 file again, then try saving using 'Western (ISO Latin 1)' text encoding.
    Quote Quote  
  5. Thank you so much for your very specific instructions.

    Here's the preference settings in text editor that I've tried, and the results:

    #1 Preference settings
    Open files: Automatic
    Save files: Automatic

    Result for .ass file: Can't open file b/c text encoding isn't compatible with Japanese Mac OS

    Result for .srt file:
    - File opens and text looks OK, but when I go to the "save as" window, ISO Latin 1 is greyed out (only Mac, UTF, and Windows encodings can be selected).
    - In the pulldown menu I did the "customize" option and selected all encoding options, and now ISO Latin 1 can be selected
    - But, after I click "save as," I get a dialog box saying "text encoding ISO Latin 1 is not compatible" and it refuses to save.

    #2 Preference settings
    Open files: UFT-8 (I am 99% sure this is the encoding for the original files)
    Save files: ISO Latin 1

    Results for .ass file: Same as .str file above

    Results for .srt file: Same as .str file above

    #3 Preference settings
    - Opening files: ISO Latin 1
    - Saving files: ISO Latin 1

    Results for .ass file: Can open the file, but the accented characters are all gibberish (i.e. MaƮtre)

    Results for .srt file: Same as .srt file above

    Do you have any idea what I might be doing wrong?!

    #4 Another attempt:

    - I set preferences to "automatic" for open and save, opened .srt file and saved as Windows Latin 1 (thinking this might be similar to ISO Latin 1...).

    - In ffmpegx I loaded the subtitles and set text encoding to CP1252 (this is ISO Latin 1, correct?), font set to Arial (I don't know what the original font is...)

    - I encoded the file, and all of the French characters are good, EXCEPT for '. It consistently gets turned into _

    What could I be doing wrong...? Is this happening b/c my OS is set up for Japanese (but that shouldn't matter, right...?) I'd post a query on the ffmpegx forums in French but I don't know the language at all.

    Thank you!!!!
    Quote Quote  
  6. Hello again -

    Just an update on my situation here.

    I just successfully did the French hardsubs using Submerge - for some reason, the French text is fine (none of the characters are turned into _).

    On Submerge I exported to Digital Video (dv) which created a huge file (3.4GB for a 16 min video). Then, I encoded it into a smaller file using ffmpegX.

    Is this a totally idiotic workflow? I would still like to do the whole thing on ffmpegx - any advice would be greatly appreciated!!!
    Quote Quote  
  7. Member
    Join Date
    Jun 2003
    Location
    United States
    Search Comp PM
    Submerge - why not simply flatten the movie (keeping the same format)? It only takes a minute (instead of hours), and the format (and quality) remain the same.

    (I'm assuming your source video was avi.)
    Quote Quote  
  8. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by atyamamoto
    In ffmpegx I loaded the subtitles and set text encoding to CP1252 (this is ISO Latin 1, correct?), font set to Arial (I don't know what the original font is...)
    CP1252 refers to a proprietary Latin character set, but it is not ISO. For ISO Latin 1, select ISO 8859-1.
    .ass (Advanced Sub Station Alpha) allows for specification of a preferred font, although conversion apps may choose to ignore that.
    .srt (SubRip) doesn't specify a font.
    Quote Quote  



Similar Threads