VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 30 of 30
Thread
  1. Member
    Join Date
    Mar 2009
    Location
    Finland
    Search Comp PM
    Hi, a newbie question below

    in http://homepage.mac.com/major4/dvd_sub.html is a nice guide
    HOW TO MAKE A DVD WITH SELECTABLE SUBTITLES ON MAC OSX WITH FFMPEGX

    Problem:
    I follow the guidelines but end up encoding an MPG FILE as result but in burning chapter the Toast is reading dvd directories AUDIO_TS and VIDEO_TS...

    What is the correct target format to create these DVD directories, obviously not "DVD ffmpeg" or "DVD mpeg2enc" (like written in guide).
    Quote Quote  
  2. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    I understand you copy-and-pasted the subject title, but please edit it to words with lower case letters, which is much easier to read.

    When the encoding (using "DVD ffmpeg" or "DVD mpeg2enc") goes well, and the "Author as [DVD (VIDEO_TS)]" checkbox is set in the Options tab, then ffmpegX should do one more step and create a VIDEO_TS folder from the MPG file.
    If it doesn't produce this authored folder, then perhaps some part of the conversion didn't succeed. Please provide the Process Information log for us to check for errors. You may access this log by clicking the blue (i) in the ffmpegX Progress window after a conversion.
    Quote Quote  
  3. Member
    Join Date
    Mar 2009
    Location
    Finland
    Search Comp PM
    Thanks for reply, title edited to lowercase.

    You must be right, something went wrong during encoding. I'll check and post the log when I return home to my Mac.

    Just guessing but perhaps the problem is with sub/srt mismatch described elsewhere in this forum... (I understood that ffmpegX would not support .sub filetype, instead it needs .srt subtext file...)
    Quote Quote  
  4. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by ulmis
    I understood that ffmpegX would not support .sub filetype, instead it needs .srt subtext file.
    A little more complex: the .sub filename extension is used by more than one subtitle format: VOBSub (image-based), SubViewer (text-based), MicroDVD (text-based) and MPSub (text-based). The important thing is that ffmpegX creates its selectable subtitles from a text-based source. VOBSub (.idx+.sub) is a quite common subtitle format for DVD rips, as it is easy to create and doesn't need spell checking (as the subs are images of text) or unusual text encoding. One the other hand, SubRip (.srt) is the most common text-based subtitle format, and readily available (1, 2) if you need to download it for a particular title.
    Quote Quote  
  5. Member
    Join Date
    Mar 2009
    Location
    Finland
    Search Comp PM
    Hi there,

    I made another trial with .sub file and now everything went OK!

    I am not able to say why my first encoding failed because I didn't save the log

    Obviously I had some other options setup differently or the phase of the moon was incorrect.
    Anyway, my .sub-file was not the reason for failure.

    It would be great if ffmpegX could report errors / warnings more clearly, now it is a little bit too easy to close the log and find later that everything was not OK. But otherwise really userfriendly program, of course.

    Thanks for your valuable help.
    Quote Quote  
  6. Member
    Join Date
    Mar 2009
    Location
    United States
    Search Comp PM
    New at this. I'm trying to combine (w/ffmpegX 0.0.9y) an AVI file with it's subtitles to put on a DVD eventually. The folder has the AVI file, a idx file, and a sub file. The AVI plays fine w/subs from the folder but I'm unable to to get the sub file to combine as a single standalone file that I can burn. Help
    Quote Quote  
  7. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    You can encode to DVD using the DVD mpeg2enc preset with Decode with mplayer activated. That seems to be the only setting that supports idx/sub for input in ffmpegX. The subtitles will not be selectable if you do this, but permanent part of the video.
    If you want selectable subtitles, the you should find a matching .srt subtitle file.
    Quote Quote  
  8. Member
    Join Date
    Mar 2009
    Location
    United States
    Search Comp PM
    Like I said, I'm new to this software. So I drag the AVI file to the "Drop File Here" window under the "Summary Source Format" window. The go to "Video" menu and select "MPEG2[.MPG] (mpeg2enc)". Then to the "Options" menu and select "Decode with mplayer." I've tried this but it's not working. Are there any subtitle setting under the "Filters" menu I should be setting like I have to for the .srt files? or any other setting I should be making. BTW this folder started out as a .rar foldder with an AVI, idx, and sub file in a folder after the .rar file was decompressed. I don't need selectable subtitles; it's a Korean film with a english subtitle.
    Quote Quote  
  9. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by georgebaron007
    Are there any subtitle setting under the "Filters" menu I should be setting like I have to for the .srt files?
    Yes, you should use the "Load subs" button, and select the .idx file.
    Quote Quote  
  10. Member
    Join Date
    Mar 2009
    Location
    United States
    Search Comp PM
    Well I solved my own problem by importing the AVI file to Quicktime Pro, did a "save as" command then selecting "Save as a self contained movie." The subs came out perfectly. I used Visual hub to "stitch" and burn the DVD.
    Quote Quote  
  11. Member
    Join Date
    Sep 2009
    Location
    Malaysia
    Search Comp PM
    Originally Posted by Case
    You can encode to DVD using the DVD mpeg2enc preset with Decode with mplayer activated. That seems to be the only setting that supports idx/sub for input in ffmpegX. The subtitles will not be selectable if you do this, but permanent part of the video.
    If you want selectable subtitles, the you should find a matching .srt subtitle file.
    Hi. I'm new. I have the same issue. I tried the above.

    And I also tried
    Originally Posted by Case
    Yes, you should use the "Load subs" button, and select the .idx file.
    But nothing happened. The subtitle did not appear when I tried to preview.

    If I have selected the *.idx file, where should the *.sub file go? From what I gather around (which is confusing me), both the files worked together, no?
    Quote Quote  
  12. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by maruz
    But nothing happened. The subtitle did not appear when I tried to preview.
    Please note that ffmpegX has confusingly TWO preview buttons, which have each a different use. Use the Preview button in the lower right of the Filters tab to see your subtitles. (The upper right Preview button is for previewing the already converted video output while the conversion is in progress.)

    Originally Posted by maruz
    If I have selected the *.idx file, where should the *.sub file go? From what I gather around (which is confusing me), both the files worked together, no?
    The *.idx file is an index file which points to the *.sub file. They should be in the same folder.
    Quote Quote  
  13. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    I`m having related issues, so I posted here.

    I`ve been following the online guide: I drop in the avi file, I select and preview the subtitles and all is fine. I select either format from the drop down menu (DVD ffmpeg or DVD mpeg2enc) and press encode. I end up with an avi.ff.mpg file (with a quicktime icon when I put it on the desktop), which when I select it I get a message saying `cannot be opened as is not a movie file`.

    When I put it into toast 8 titanium, selected from `files`, it just has the mpeg and no video and audio files separately.

    I realise I should have a movie.DVD file somewhere, but I only have the mpeg - when I tried to locate the movie.DVD file using the magnifying glass icon, it just says `file not found`.

    I had 9gb available when I started the process.

    Newbie issue I`m sure. for newbie I am. Help me onegaiitashimasu!
    Quote Quote  
  14. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Btw, when I created a dmg in toast and mounted it in VLC I get double-speed audio, no subs!
    Quote Quote  
  15. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by AoV View Post
    I end up with an avi.ff.mpg file (with a quicktime icon when I put it on the desktop), which when I select it I get a message saying `cannot be opened as is not a movie file`.
    QuickTime Player cannot play MPEG-2 files, if you do not have the $20 QuickTime MPEG-2 Playback Component installed. Even if you did, QuickTime Player won't be able to play the AC3 audio in mpeg files (it's a video decoder only). Try playback in e.g. VLC or MPlayer.

    Originally Posted by AoV
    When I put it into toast 8 titanium, selected from `files`, it just has the mpeg and no video and audio files separately.
    In the ffmpegX menu is a command for keeping elementary streams. This has an effect on DVD mpeg2enc, but not on DVD ffmpeg.

    Originally Posted by AoV
    I realise I should have a movie.DVD file somewhere, but I only have the mpeg - when I tried to locate the movie.DVD file using the magnifying glass icon, it just says `file not found`.
    The DVD folder will be created after a complete and successful conversion. If an error occurred with e.g. the subtitles, then the process will stop and the DVD folder will not be created.
    'Disk full' would also stop the process.
    See the log (blue "i") for details.

    Originally Posted by AoV
    I had 9gb available when I started the process.
    You should really work on clearing some space, as Mac OS X is much faster if the HD isn't nearly full on the boot partition. Fragmentation will be terrible.
    For conversions to DVD, you would need at least 3 DVDs worth of empty space: (1) video + audio elementary streams (2) muxed mpeg (3) VIDEO_TS folder.

    Originally Posted by AoV View Post
    Btw, when I created a dmg in toast and mounted it in VLC I get double-speed audio
    Does this double-speed audio also happen when playing the .mpg file in VLC?
    I have seen that on a few occasions with the DVD ffmpeg preset. Using the DVD mpeg2enc preset fixed that.

    Originally Posted by AoV
    ...no subs!
    As mentioned above, there may have been an error in converting the subs. I would have to see the log to be sure. The selectable subs are not in the .mpg file, even if they were converted okay. Hard subs (always on) are 'burned' in the video, but require mpeg2enc AND 'Decoding with mplayer'.
    Quote Quote  
  16. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Originally Posted by Case View Post
    Originally Posted by AoV View Post
    I end up with an avi.ff.mpg file (with a quicktime icon when I put it on the desktop), which when I select it I get a message saying `cannot be opened as is not a movie file`.
    QuickTime Player cannot play MPEG-2 files, if you do not have the $20 QuickTime MPEG-2 Playback Component installed. Even if you did, QuickTime Player won't be able to play the AC3 audio in mpeg files (it's a video decoder only). Try playback in e.g. VLC or MPlayer.

    -- I usually use vlc. I was just double clicking on the quicktime icon to see what happened.

    Originally Posted by AoV
    When I put it into toast 8 titanium, selected from `files`, it just has the mpeg and no video and audio files separately.
    In the ffmpegX menu is a command for keeping elementary streams. This has an effect on DVD mpeg2enc, but not on DVD ffmpeg.

    Originally Posted by AoV
    I realise I should have a movie.DVD file somewhere, but I only have the mpeg - when I tried to locate the movie.DVD file using the magnifying glass icon, it just says `file not found`.
    The DVD folder will be created after a complete and successful conversion. If an error occurred with e.g. the subtitles, then the process will stop and the DVD folder will not be created.
    'Disk full' would also stop the process.
    See the log (blue "i") for details.

    -- I will run the process again and post the log. How much of the log do you need to see to work out what the problem might have been?

    Originally Posted by AoV
    I had 9gb available when I started the process.
    You should really work on clearing some space, as Mac OS X is much faster if the HD isn't nearly full on the boot partition. Fragmentation will be terrible.
    For conversions to DVD, you would need at least 3 DVDs worth of empty space: (1) video + audio elementary streams (2) muxed mpeg (3) VIDEO_TS folder.

    -- I will try to free up some more space. My Hd is small though and is partitioned as I share with my Japanese wife.

    Originally Posted by AoV View Post
    Btw, when I created a dmg in toast and mounted it in VLC I get double-speed audio
    Does this double-speed audio also happen when playing the .mpg file in VLC?
    I have seen that on a few occasions with the DVD ffmpeg preset. Using the DVD mpeg2enc preset fixed that.

    -- I ran it through twice, using both DVDffmpeg and DVD mpeg2enc - Both times I got the accelerated audio when I ran the mpeg in vlc.

    Originally Posted by AoV
    ...no subs!
    As mentioned above, there may have been an error in converting the subs. I would have to see the log to be sure. The selectable subs are not in the .mpg file, even if they were converted okay. Hard subs (always on) are 'burned' in the video, but require mpeg2enc AND 'Decoding with mplayer'.
    ---Understood.

    ---Thanks masses Case for the response. I`ll free space, try it again and post the log.
    Quote Quote  
  17. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Okay, I tried again, using DVDffmpeg. I have speedy audio and no subs when I open the file in vlc. I also have no movie.DVD file. This time I started the process with almost 18gb free space.

    Here is the log:

    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    Sat Mar 13 08:42:41 JST 2010
    Input #0, avi, from '/Users/Roo/Desktop/Suna no onna (1964) Hiroshi Teshigahara/Suna no onna (1964) Hiroshi Teshigahara.avi':
    Duration: 02:27:18.2, start: 0.000000, bitrate: 1993 kb/s
    Stream #0.0, 23.98 fps(r): Video: mpeg4, yuv420p, 592x448
    Stream #0.1: Audio: ac3, 48000 Hz, mono, 192 kb/s
    Output #0, dvd, to '/Users/Roo/Documents/dvd1.mpg':
    Stream #0.0, 23.98 fps(c): Video: mpeg2video, yuv420p, 720x480, q=2-20, 4000 kb/s
    Stream #0.1: Audio: mp2, 48000 Hz, stereo, 224 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #0.1 -> #0.1
    [ac3 @ 0x54340c]ac3dec: AC3 Source channels are less than specified: output to 1 channels.. (frmsize: 768)
    ffmpeg(255,0xa000d000) malloc: *** vm_allocate(size=1071648768) failed (error code=3)
    ffmpeg(255,0xa000d000) malloc: *** error: can't allocate region
    ffmpeg(255,0xa000d000) malloc: *** set a breakpoint in szone_error to debug

    Obviously something not right! Thanks for the help.
    Quote Quote  
  18. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by AoV View Post
    Input #0, avi:
    Stream #0.0, 23.98 fps(r): Video
    DVD-Video at 23.976 fps should have a so-called "3:2 pulldown" instruction applied to the video, which DVD ffmpeg can't do, but DVD mpeg2enc can ('Set 3:2' in the Options tab). You could add it after conversion to the elementary video stream (.m2v) using the Pull tool, but DVD mpeg2enc's option is so much easier.
    Note that this is a solution to playback of the DVD, and not a conversion error.

    Originally Posted by AoV View Post
    Input #0, avi:
    Stream #0.1: Audio: ac3, 48000 Hz, mono, 192 kb/s
    Output #0, dvd, to 'foo.mpg':
    Stream #0.1: Audio: mp2, 48000 Hz, stereo, 224 kb/s
    [ac3 @ 0x54340c]ac3dec: AC3 Source channels are less than specified: output to 1 channels.. (frmsize: 768)
    You could use the Passthrough option with this audio, as the mono ac3 track is DVD compliant, and audio conversion isn't needed.
    Second: if your source is mono, your output should be set accordingly, not 'stereo'. (Your bitrate may be a bit high, the application isn't functioning optimally, but again, this should not result in errors.)

    Originally Posted by AoV
    ffmpeg(255,0xa000d000) malloc: *** vm_allocate(size=1071648768) failed (error code=3)
    ffmpeg(255,0xa000d000) malloc: *** error: can't allocate region
    ffmpeg(255,0xa000d000) malloc: *** set a breakpoint in szone_error to debug
    ffmpeg tries to allocate about 1GB of virtual memory, but fails. I haven't seen this one before. Not sure if there is anything you can do about it. Try a reboot to free up all memory, and only run ffmpegX - no other apps. If that doesn't work, then go with DVD mpeg2enc, as that will use different code and perhaps avoid this error.
    Quote Quote  
  19. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Okay, thanks loads again. Will run it through again using mpeg2enc, set at 3:2 in the options tab, using the passthrough or set to mono. Re the last point - I did a reboot before I started the last attempt and was only running ffmpegx and nothing more. Will get back to you! Thanks again.
    Quote Quote  
  20. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Hello again Case. Been away, now I`m back.

    This time I had 18.5gb space on my hd, a did a reboot before hand and had opened no other apps before I started. I used mpeg2enc, set the audio at mono, selected the 3:2 option. Usually it takes around 70 mins to encode. This time there was a `bing` saying it had finished after 3 seconds. No movie.DVD file anywhere once again. When I played the file there was only 10 seconds on the file, which being the opening contained no audio - but there was the subbed title! Here is the log:

    Encoding started on Mon Mar 15 22:59:55 JST 2010
    INFO: [yuvscaler] yuvscaler 1.9.0 (15-02-2004) is a general scaling utility for yuv frames
    INFO: [yuvscaler] (C) 2001-2004 Xavier Biquard <xbiquard@free.fr>, yuvscaler -h for help, or man yuvscaler
    /bin/sh: line 1: /Library/Application Support/ffmpegX/mpeg2enc: Malformed Mach-o file
    movtoy4m
    Copyright 2002-2006 Johan Lindström
    All rights reserved..
    ++ WARN: [yuvscaler] Could not infer norm (PAL/SECAM or NTSC) from input data (frame size=720x480, frame rate=24000:1001 fps)!!
    INFO: [yuvscaler] input: frame size: 720x480 pixels (518400 bytes)
    INFO: [yuvscaler] input: chroma: 4:2:0 JPEG/MPEG-1 (interstitial)
    INFO: [yuvscaler] input: frame rate: 24000/1001 fps (~23.976024)
    INFO: [yuvscaler] input: interlace: none/progressive
    INFO: [yuvscaler] input: sample aspect ratio: 1:1
    INFO: [yuvscaler] from 720x480, take 720x480+0+0, NOT_INTERLACED/PROGRESSIVE
    INFO: [yuvscaler] scale to 720x480, 720x480 being displayed
    INFO: [yuvscaler] Scaling uses the RESAMPLE algorithm,
    INFO: [yuvscaler] frame rate: 23.976 fps
    INFO: [yuvscaler] Scaling ratio for width is 1 to 1
    INFO: [yuvscaler] and is 1 to 1 for height
    INFO: [yuvscaler] Specific downscaling routing number 4

    I`m now running it through again using ffmpeg and the audio set to mono, just in case the extra hd space has been a cause of the virtual memory issue.
    Quote Quote  
  21. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by AoV View Post
    /bin/sh: line 1: /Library/Application Support/ffmpegX/mpeg2enc: Malformed Mach-o file
    mpeg2enc is considered "malformed". Perhaps the binary mpeg2enc is faulty, or something went wrong during installation. Try installing mpeg2enc again.
    Quote Quote  
  22. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Thanks for the response. I`ll try installing the binary again.

    Heres the other log for the second run-through:

    Encoding started on Mon Mar 15 23:13:21 JST 2010
    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    Input #0, avi, from '/Users/Roo/Documents/torrentybits/Suna no onna (1964) Hiroshi Teshigahara/Suna no onna (1964) Hiroshi Teshigahara.avi':
    Duration: 02:27:18.2, start: 0.000000, bitrate: 1993 kb/s
    Stream #0.0, 23.98 fps(r): Video: mpeg4, yuv420p, 592x448
    Stream #0.1: Audio: ac3, 48000 Hz, mono, 192 kb/s
    Output #0, dvd, to '/Users/Roo/Documents/torrentybits/Suna no onna (1964) Hiroshi Teshigahara/Suna no onna (1964) Hiroshi Teshigahara.avi.ff.mpg':
    Stream #0.0, 23.98 fps(c): Video: mpeg2video, yuv420p, 720x480, q=2-20, 4000 kb/s
    Stream #0.1: Audio: ac3, 48000 Hz, mono, 192 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #0.1 -> #0.1
    video:3744034kB audio:207145kB global headers:0kB muxing overhead 2.602092%
    bench: utime=5190.941s
    INFO: Locale=C
    INFO: Converting filenames to US-ASCII
    INFO: Detected subtitle file format: subviewer 2.0
    INFO: Opened iconv descriptor. *UTF-8* *ISO-8859-1*
    INFO: Read 0 subtitles
    INFO: Unicode font: 242 glyphs.
    ERR: Couldn't load file /Users/Roo/Documents/torrentybits/Suna no onna (1964) Hiroshi Teshigahara/Suna no onna (1964) Hiroshi Teshigahara.sub.
    Quote Quote  
  23. Member
    Join Date
    Mar 2010
    Location
    Yokohama
    Search PM
    Okay, I re-installed each of the 3 bits - the binary and so forth, then I ran it through again using mpeg2enc and got the same log as above. It took 2 seconds.

    I did it once more, this time using ffmpeg, on mono. Once again no movie.dvd. When I opened the mpeg file in vlc the whole film was there, but no sounds at all. Here is the log:

    /bin/sh: line 1: /Library/Application Support/ffmpegX/mpeg2enc: Malformed Mach-o file
    Tue Mar 16 13:20:32 JST 2010
    INFO: [yuvscaler] yuvscaler 1.9.0 (15-02-2004) is a general scaling utility for yuv frames
    INFO: [yuvscaler] (C) 2001-2004 Xavier Biquard <xbiquard@free.fr>, yuvscaler -h for help, or man yuvscaler
    movtoy4m
    Copyright 2002-2006 Johan Lindström
    All rights reserved..
    ++ WARN: [yuvscaler] Could not infer norm (PAL/SECAM or NTSC) from input data (frame size=720x480, frame rate=24000:1001 fps)!!
    INFO: [yuvscaler] input: frame size: 720x480 pixels (518400 bytes)
    INFO: [yuvscaler] input: chroma: 4:2:0 JPEG/MPEG-1 (interstitial)
    INFO: [yuvscaler] input: frame rate: 24000/1001 fps (~23.976024)
    INFO: [yuvscaler] input: interlace: none/progressive
    INFO: [yuvscaler] input: sample aspect ratio: 1:1
    INFO: [yuvscaler] from 720x480, take 720x480+0+0, NOT_INTERLACED/PROGRESSIVE
    INFO: [yuvscaler] scale to 720x480, 720x480 being displayed
    INFO: [yuvscaler] Scaling uses the RESAMPLE algorithm,
    INFO: [yuvscaler] frame rate: 23.976 fps
    INFO: [yuvscaler] Scaling ratio for width is 1 to 1
    INFO: [yuvscaler] and is 1 to 1 for height
    INFO: [yuvscaler] Specific downscaling routing number 4

    Any ideas?
    Quote Quote  
  24. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by AoV View Post
    video:3744034kB audio:207145kB global headers:0kB muxing overhead 2.602092%
    Video and audio were converted without errors. Did you check the sync?

    Originally Posted by AoV
    INFO: Detected subtitle file format: subviewer 2.0
    ERR: Couldn't load file /Users/Roo/Documents/torrentybits/Suna no onna (1964) Hiroshi Teshigahara/Suna no onna (1964) Hiroshi Teshigahara.sub.
    Your source subtitle file could not be loaded as a valid text-based subtitle, most likely because it isn't text-based SubViewer format, but image-based VobSub format.

    Did the subtitles also come with an *.idx file? (*.idx + *.sub is VobSub format.)
    VobSub in ffmpegX is only supported for hard subbing (DVD mpeg2enc with Decode with mplayer and select the .idx file as subtitle input).

    Originally Posted by AoV View Post
    Okay, I re-installed each of the 3 bits - the binary and so forth, then I ran it through again using mpeg2enc and got the same log as above. It took 2 seconds.

    bin/sh: line 1: /Library/Application Support/ffmpegX/mpeg2enc: Malformed Mach-o file
    Still something wrong with mpeg2enc. Try this copy instead. Upzip before installing. Some users with the same error reported that this solved it for them.
    Quote Quote  
  25. Member
    Join Date
    Apr 2010
    Location
    CHESTER, UK
    Search Comp PM
    Hi another newbie here. I am having similar problems in trying to author a DVD from an .avi file with .srt sub titles (and following the direction on the ffmpegx website) . After converting with either mpeg2 or ffmpeg, I end up with a .mpg file and no *.dvd folders. The information log shows the following;

    Encoding started on Tue Apr 6 13:41:21 BST 2010
    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    Input #0, avi, from '/Users/Music/IPOD Music/THE GIRL WITH THE DRAGON TATTOO [2009] DVD Rip Xvid (8 Subs) [StB]/MÆND SOM HADER KVINDER [2009] DVD Rip Xvid [StB].avi':
    Duration: 02:26:28.7, start: 0.000000, bitrate: 782 kb/s
    Stream #0.0, 25.00 fps(r): Video: mpeg4, yuv420p, 608x240
    Stream #0.1: Audio: mp3, 48000 Hz, stereo, 96 kb/s
    Output #0, dvd, to '/Users/Movies/dragon tattoo/dragon.mpg':
    Stream #0.0, 25.00 fps(c): Video: mpeg2video, yuv420p, 720x576, q=2-20, 4000 kb/s
    Stream #0.1: Audio: ac3, 48000 Hz, 5:1, 448 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #0.1 -> #0.1
    [mpeg2video @ 0x54340c]rc buffer underflow
    video:3787461kB audio:480590kB global headers:0kB muxing overhead 2.558386%
    bench: utime=2680.161s
    INFO: Locale=C
    INFO: Converting filenames to US-ASCII
    ERR: Cannot convert UTF8 string 'ÆND SOM HADER KVINDER [2009] DVD Rip Xvid [StB].srt': Illegal byte sequence

    I do not need the subtitles to be selectable just burned on would be fine. Any help greatly appreciated.

    Steve
    Quote Quote  
  26. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by ses2310 View Post
    After converting with either mpeg2 or ffmpeg, I end up with a .mpg file and no *.dvd folders. The information log shows the following;

    ERR: Cannot convert UTF8 string 'ÆND SOM HADER KVINDER [2009] DVD Rip Xvid [StB].srt': Illegal byte sequence
    The subtitle conversion tool seems to have problems with some special characters in the .srt filename. Try renaming the file to something simple (only us-ascii characters) and encoding again.

    Actually, you don't have to start all over, you may continue where it stopped and take advantage of the already converted video and audio. Use the Author tool in the Tools tab to input the .mpg and renamed .srt to author the DVD folder, with subtitles.
    Last edited by Case; 6th Apr 2010 at 16:03. Reason: Rephrasing for clarity
    Quote Quote  
  27. Member
    Join Date
    Apr 2010
    Location
    CHESTER, UK
    Search Comp PM
    Thanks Case, changing the .srt name as you suggested seems to have done the trick.

    Thanks
    Quote Quote  
  28. Member
    Join Date
    Nov 2010
    Location
    Laval, Q.C.
    Search Comp PM
    Hi guys!

    Having an issue here with ffmpegx encoding .avi to VIDEO_TS folder.
    ffmpegx maybe miss a step. It should do one more step and create a VIDEO_TS folder from the mpg file.
    Can someone here can help me with this issue??
    Quote Quote  
  29. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by NOSFERATOU View Post
    Encoding .avi to VIDEO_TS. ffmpegx maybe miss a step. It should do one more step and create a VIDEO_TS folder.
    If the VIDEO_TS folder wasn't created, and the 'Author as DVD (VIDEO_TS)'-checkbox in the Options tab for that step was still selected (default), then there must have been some error to halt the process.

    The error would be mentioned in the log. You may access this log by clicking the blue "i" in the ffmpegX Progress window. (If you quit Progress.app, then the log is lost.) If an .mpg file was created, then the issue is most likely with the subtitle file. The log could confirm that.

    If the .mpg file is okay and complete, then you may try to continue where ffmpegX left off, by going to the Tools tab, selecting the Author sub-tab, enter your .mpg file (and optionally your subtitle file) and pressing the Author button.
    Quote Quote  
  30. Member
    Join Date
    Nov 2010
    Location
    Laval, Q.C.
    Search Comp PM
    Hello!
    to get the VIDEO_TS folder created, you have to WAIT the end of process. 100% doesn't mean that the all process was conclude!
    Peoples have to WAIT until that FINISH was written! process can take very long!
    It work fine with me now! But!!!...

    But! one thing doesn't, if am pressing Forward button, or any buttons kind, image FREEZE!
    So, have to stop, and play again. Weird!!!
    Can someone here can verified if am the only one with this issue?
    Have tested with my 2 dvd players and conclude same prob.
    Voilà!
    Quote Quote  



Similar Threads