VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
  1. Member
    Join Date
    Jun 2007
    Search Comp PM
    I get the error "AVI Import Filter error: (Unknown) 80040154" when trying to load an avs file. I have no idea what it means and don't know much about avs files. It's generated with GK, and doesn't include any special filters or similar, paths are correct. It worked earlier, but not after I formatted.

    The avs is linked to a d2v file, made from a DVD. I have searched the internet looking for solutions, but it doesn't seem like it is caused by the same thing. I have tried reinstalling different codecs, decoders, filters, whatever. Don't really know much about the definitions and differences between those things, the point is that I have tried reinstalling them. VirtualDub is the latest version, and I'm using Windows Vista
    Quote Quote  
  2. 80040154 means in MS-speak that the program (Virtual Dub) is trying to create an instance of a filter or something similar but Windows can't create it. This is usually because a filter hasn't been registered. You need to identify the filters that are supposed to be used and then use regsvr32 <filter file> for each one to ensure the registry has all the right information.

    On Vista, sometimes filters don't get installed properly when using a normal Windows installer package. This is because the package doesn't allow for Vista's user access control. Usually, though, the installation of the package will fail.
    John Miller
    enosoft - high performance tools for music and video

    Home of the Enosoft DV Processor - Free for personal use!
    Quote Quote  
  3. Of course have installed Avisynth...?
    Quote Quote  
  4. I know this is a very old topic, but I had this problem...

    I thought I had Avisynth rightly installed, so I try to "register the filters".
    There is a good method : install a directshow filter package :

    there is a .bat file inside which make lots of the "regsvr32 <filter file>" (which was the first solution proposed by johnnymalaria)

    but it did not change my problem.
    So I re-installed Avisynth (solution by placio74) and it now works
    so : thank you all
    Quote Quote  
  5. Member
    Join Date
    Mar 2008
    United States
    Search Comp PM
    That didn't work for me 2diablols.

    I had avisynth 2.5.8 and virtual dub 1.9.10 loaded 2 .avs scripts to the job list in Vdub and the third one I get this error:
    AVI Import Filter error: (Unknown) 80040154
    Then I changed it, installed avisynth 2.5.7 and am using virtual dub 1.8.8 loaded a new set of files and after 2 encodes in the job list boom, same error.

    Method's tried already:
    1. Reinstalling Avisynth 2.5.8 after the above.
    2. * AVI Import Filter error: (Unknown) (80040154) - solution: A missing dll might be the problem: msvcr71.dll msvcp71.dll should be in the windows\sytem32 directory or windows\SysWOW64 (Windows 7 64Bit)
    - FIXED - Is not fixed for me...from This link
    3. Tried to replace FFMSindex.exe to reindex. Anyone know of other Avi Decoders/indexers?
    4. Loaded a AVS script with the code: Version () loads fine and shows version. So it's not Avisynth.

    Using all 32bit apps, running on windows 7 64-bits...

    What do I do now?
    Anyone got any ideas cause I'm at a loss... and I need vdub to work over night and can only use vdub for my current project and this isn't going to work for me with this problem.

    Running win7 64bit.

    1.Packed All avisynth plugins into a .rar file.

    2. Uninstalled everything I wanted to use.

    2 1/2. I used an application called CCleaner to clean out my system.

    3. Installed Virtual dub 1.9.10

    4. Installed Avisynth 2.5.7

    Added plugins I will be using and any additional required plugins that are needed to allow the ones I use to function. So in turn my problem was with an avisynth filter I added.

    Created my index's of my files and .avs scripts then loaded each one into Vdub added filters of Vdub and added each file to Queue No problems at all !!!

    Figured It out on my own and hope this helps someone in the future.
    Last edited by sinz; 1st Nov 2010 at 08:27.
    Quote Quote  
  6. I have a new insalation of win7 64 bit and have the same issue. version() results int he same error. I instaled koepis avisynth today, and had the error. Then I found a 64 bit instaland and installed the cmd file and copied over the files a the readme said to do, and same issue. Does nayone know whic hversion(s) etc will work?
    If you want to see what I've done with my videos,
    check out my video work on youtube,
    Quote Quote  
  7. Member
    Join Date
    May 2002
    Search Comp PM
    Just installed windows 8 and had this error. Even though I installed Klite codec pack with the avisynth box checked, it gave me this error.

    I installed Avisynth as suggested and everything is running again.

    Quote Quote  
  8. Dinosaur Supervisor KarMa's Avatar
    Join Date
    Jul 2015
    Search Comp PM
    Apologizes for bumping a 10 year old thread but I came across this thread when trying to fix my issues. I had been living with this error in Virtualdub for months (not being able to open .AVS files in Vdub). I simply reinstalled Avisynth 2.6 32-bit and that fixed the issue for me on a Win7 64bit machine. I already had Avisnyth 2.6 32 installed but it was obviously damaged in some minor way. Hope this helps someone.
    Last edited by KarMa; 15th Aug 2019 at 01:42.
    Quote Quote  
  9. Oh well...
    Quote Quote  

Similar Threads