VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or buy Replay Video Capture or PlayON and record Netflix, HBO, etc! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member lapetite_66's Avatar
    Join Date
    Apr 2006
    Location
    United States
    Search Comp PM
    Hi:

    Just the other day I installed the above mentioned Cyberlink Power Director v7 on my computer. I played around with it a little just to see what I could do. The problem came about when I attempted to use the "Create" function within the software I got the following messages:

    Components initialization failed. There might have been problems during installation. Please reinstall again.

    Creat Disk page initializing error! Components initialization failed. There might have been problems during installation. Please reinstall again.

    I have uninstalled and re-installed four times now with the same error message. Is there some special codec(s) that I need or is it something else entirely.

    Any help would be greatly appreciated.

    Thanks,
    Quote Quote  
  2. you could try the latest update patch. i've used it a few times but it has always been a bit buggy.
    Quote Quote  
  3. Member
    Join Date
    Apr 2009
    Location
    United States
    Search Comp PM
    Originally Posted by lapetite_66
    Hi:

    Just the other day I installed the above mentioned Cyberlink Power Director v7 on my computer. I played around with it a little just to see what I could do. The problem came about when I attempted to use the "Create" function within the software I got the following messages:

    Components initialization failed. There might have been problems during installation. Please reinstall again.

    Creat Disk page initializing error! Components initialization failed. There might have been problems during installation. Please reinstall again.

    I have uninstalled and re-installed four times now with the same error message. Is there some special codec(s) that I need or is it something else entirely.

    Any help would be greatly appreciated.

    Thanks,


    The file(s) in the BurningMgr folder of PowerDirector is damaged. You need to replace them with a non-damaged ones (2 files total). The files are the same for other installations also so you can just copy the files from another installation (including the trial version).
    Quote Quote  
  4. You need the original Burning Manager files from the trial version find them here:

    http://cid-c313ccef48a58781.skydrive.live.com/self.aspx/.Public/BurningMgr.zip

    Originally Posted by lapetite_66
    Hi:

    Just the other day I installed the above mentioned Cyberlink Power Director v7 on my computer. I played around with it a little just to see what I could do. The problem came about when I attempted to use the "Create" function within the software I got the following messages:

    Components initialization failed. There might have been problems during installation. Please reinstall again.

    Creat Disk page initializing error! Components initialization failed. There might have been problems during installation. Please reinstall again.

    I have uninstalled and re-installed four times now with the same error message. Is there some special codec(s) that I need or is it something else entirely.

    Any help would be greatly appreciated.

    Thanks,
    Quote Quote  
  5. ALL YOU NEED TO DO IS DOWNLOAD A DVD MENU. Your Install contained no DVD menu. The program requires at least one DVD menu to funsction!

    It's a fantastic program. I just found the solution elsewhere.

    To get DVD MENU'S login/register in directors zone and then navigate to DVD menus and download one. Double click it and it will install. Then you can burn a disk!!!!!

    Originally Posted by lapetite_66
    Hi:

    Just the other day I installed the above mentioned Cyberlink Power Director v7 on my computer. I played around with it a little just to see what I could do. The problem came about when I attempted to use the "Create" function within the software I got the following messages:

    Components initialization failed. There might have been problems during installation. Please reinstall again.

    Creat Disk page initializing error! Components initialization failed. There might have been problems during installation. Please reinstall again.

    I have uninstalled and re-installed four times now with the same error message. Is there some special codec(s) that I need or is it something else entirely.

    Any help would be greatly appreciated.

    Thanks,
    Quote Quote  



Similar Threads