VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. Member Hittz's Avatar
    Join Date
    Dec 2006
    Location
    United States
    Search Comp PM
    Hello all, lately I've been getting a green frame at the beginning of my videos ONLY AFTER creating an .avs script in either
    AvsP or FitCD. Ive tried uninstalling Avisynth along with my plugins and reinstalling it along with the plugins. The green screen ONLY appears at the beginning of the .avs script (frame 0) but its not there if I open the avi video clip directly in Virtualdubmod or Virtualdub. The green screen is also visible on my dvd's after I encode and author them.
    When I advance the seek bar (using the right arrow on my keyboard) it goes to a black frame. I think this would be normal being Im advancing it but why does it open to a green frame, when there is no green in the original .avi?
    Note: .avs script is able to be viewed fine in Virtualdub(mod) and I have no problems encoding or authoring the script.

    Appears this way after opening an .avs script:



    Appears this way after moving scroll bar with right arrow on keyboard:

    Seek, And You Shall Find.
    Quote Quote  
  2. Member Krispy Kritter's Avatar
    Join Date
    Jul 2003
    Location
    St Louis, MO USA
    Search Comp PM
    Have you tried removing/cutting that frame after creation? It's likely garbage. Editors will likely open the first frame even if it is corrupt, but the players may be going to the first readable frame. If you browse the folder where the file is saved using thumbnail view, does Windows create a green or black thumbnail?
    Google is your Friend
    Quote Quote  
  3. Member Hittz's Avatar
    Join Date
    Dec 2006
    Location
    United States
    Search Comp PM
    I havent tried cutting the frame after making the script, The thumbnail view is black, I even tried viewing other files and they too are black.
    Seek, And You Shall Find.
    Quote Quote  
  4. Member Krispy Kritter's Avatar
    Join Date
    Jul 2003
    Location
    St Louis, MO USA
    Search Comp PM
    Weird, I expected it would be green.
    Google is your Friend
    Quote Quote  
  5. Member Hittz's Avatar
    Join Date
    Dec 2006
    Location
    United States
    Search Comp PM
    Yeah Krispy, this is buggin me out I notice after cutting a sample in the middle of the avi and then making an .avs script, then opening in Virtualdub(mod) it is viewed correctly (NO GREEN) so it seems to be if the clip starts with a black frame the .avs script is viewed as green in VDM at the start (only upon loading the script)
    Seek, And You Shall Find.
    Quote Quote  
  6. Member MysticE's Avatar
    Join Date
    Nov 2003
    Location
    United States
    Search Comp PM
    Why don't you first trim some off the start of the AVI and save (Direct stream copy). Use the 'key frame' icon to advance a bit then mark your 'Start'. See how this 'new' trimmed version behaves.
    Quote Quote  
  7. I'd like to see the script.
    "Shut up Wesley!" -- Captain Jean-Luc Picard
    Buy My Books
    Quote Quote  
  8. Member Hittz's Avatar
    Join Date
    Dec 2006
    Location
    United States
    Search Comp PM
    MysticE, I tried your suggestion on a few different clips and the same thing happens ( the green screen with black borders) when I open the script in VDM it shows green then after I press play it starts where I made the beginning cut.
    My brother has the same motherboard as me with a better processor and I asked him does he get the green at the beginning of a script and he said yes. What gives???

    gadgetguy, here is the script im using made by Fitcd

    # -= AviSynth v2.5.7.0 script by FitCD v1.2.8 =-
    AVISource("C:\Documents and Settings\hittz\Desktop\Test.avi")
    LanczosResize(720,352,0,1,592,318)
    AddBorders(0,64,0,64)
    #Trim(0,5590).FadeOut(150) > I also tried Trim(1,5590)
    ConvertToYUY2() # For VirtualDub or CCE

    I even get the green screen when creating the script in AvsP
    Seek, And You Shall Find.
    Quote Quote  
  9. B-frame decoder lag? See if Mpeg4Modifier can fix it by turning off or on packed bitstream. Otherwise Trim(1,0) should remove the first frame, or Trim(2,0) to remove 2 frames. Or try DirectShowSource() instead of AviSource(). Directshow handles b-frames better.
    Quote Quote  
  10. Member Hittz's Avatar
    Join Date
    Dec 2006
    Location
    United States
    Search Comp PM
    The Trim(1,0) command worked perfectly Jagabo. I was doing that wrong when I tried it. (above) Now when I open the avs scripts in Virtualdubmod there is NO green screen.
    Thanks much Jagabo, and all others who helped in this matter.
    MPEG4 Modifier seems like an interesting tool, Im checking it out now. Thanks


    Seek, And You Shall Find.
    Quote Quote  



Similar Threads