VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date
    Apr 2005
    Location
    Vancouver
    Search Comp PM
    I have a Philips DVP 5140, it's pretty new.
    Plays Divx really great.

    But when I play a DVD or a divx file, there is an echo sound in the audio, especially when people are talking (dialogue)

    Is this a problem with these players? but I read the reviews here and this player is pretty good.

    So is there any way to fix this? Is there an option for this player to turn off this "echo" sound?

    I can't return it since it's about a year old.

    So what can I do?

    https://www.videohelp.com/dvdplayers/philips-dvp-5140/6957
    http://www.amazon.com/Philips-DVP5140-Multiformat-Windows-Support/dp/B000F2KUK8
    Quote Quote  
  2. Member mats.hogberg's Avatar
    Join Date
    Jul 2002
    Location
    Sweden (PAL)
    Search Comp PM
    I had that once, with my first 5.1 audio system. Somewhere in the chain the digital 5.1 audio got slightly delayed (or perhaps the old analog stereo audio had always been slightly delayed, and the 5.1 audio was ahead of it - I never investigated). The solution was to kill the analogue audio (mute the TV) and the echo effect was gone.

    /Mats
    Quote Quote  
  3. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    Is your DVD player connected to your TV via HDMI? I have a Toshiba HD DVD player connected to my HDTV via HDMI and when I use it, I have to mute the TV because I get an echo. My receiver is about 3 years old and at the time I bought it, you could not buy any receivers with HDMI inputs. I have to have the TV pass the sound through to the receiver for it to decode. This is why I have echo - both the TV and the receiver are playing the audio at the same time in this setup.
    Quote Quote  
  4. Member
    Join Date
    Apr 2005
    Location
    Vancouver
    Search Comp PM
    Thanks

    I think I fixed it!

    I went to setup>audio>sound options>3D> from living room to OFF


    Then the sound went back to normal
    Quote Quote  



Similar Threads