VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 12 of 12
Thread
  1. Member
    Join Date
    Sep 2008
    Location
    Italy
    Search Comp PM
    hi, this my first post and I have some problem with ffmpegx 009y on my mac book pro.

    I have an pinnacle usb tv adapter, and EyeTV where I recording some event from tv.
    The video recording is in mpg-2 (mpeg-2, 720x576, 10000 kbps, 25 fps) and audio in mp2, 48000Hz, 192 kbps.

    The problem is when I using mencoder the audio is mute, if use ffmpeg the audio is ok.

    the library is :
    Code:
    macbookpro1:Gara.eyetv antonio$ ls -ltr  /Library/Application\ Support/ffmpegX/
    total 101280
    -rw-r--r--  1 antonio  admin        67 15 Mag  2004 gocrfilter_none.sed
    -rw-r--r--  1 antonio  admin       271 15 Mag  2004 gocrfilter_nl.sed
    -rw-r--r--  1 antonio  admin       361 15 Mag  2004 gocrfilter_fr.sed
    -rw-r--r--  1 antonio  admin       500 15 Mag  2004 gocrfilter_en.sed
    -rwxr-xr-x  1 antonio  admin    281028 15 Mag  2004 gocr
    -rwxr-xr-x  1 antonio  staff    244832 15 Mag  2004 mp2enc
    -rwxr-xr-x  1 antonio  staff    568908 15 Mag  2004 vcdxgen
    -rwxr-xr-x  1 antonio  staff    589400 15 Mag  2004 vcdxbuild
    -rwxr-xr-x  1 antonio  staff    314968 15 Mag  2004 yuvscaler
    -rwxr-xr-x  1 antonio  staff    113352 15 Mag  2004 yuvdenoise
    -rwxr-xr-x  1 antonio  admin     22596 15 Mag  2004 subtitle2pgm
    -rwxr-xr-x  1 antonio  staff    286168 18 Lug  2004 tcextract
    -rw-------@ 1 antonio  admin    501480 16 Apr  2006 mpeg2enc
    -rwxr-xr-x  1 antonio  staff  15869784 29 Apr  2006 mplayer.old
    -rwxr-xr-x@ 1 antonio  staff  15869784 29 Apr  2006 mplayer
    -rwxr-xr-x@ 1 antonio  staff  16655780 29 Apr  2006 mencoder
    -rw-r--r--@ 1 antonio  staff    501480 14 Set 17:34 mpeg2enc.intel
    The check for audio enconding is 'on'.... and I've tried every solution ... but i don't know where is the problem.

    Please, help me

    Ciao
    Quote Quote  
  2. Member
    Join Date
    Aug 2005
    Location
    Palo Alto, California USA
    Search Comp PM
    If you post the contents of the Progress logfile (click on the blue "i" in the Progress window), maybe there's a useful clue to be found.
    Quote Quote  
  3. Member
    Join Date
    Sep 2008
    Location
    Italy
    Search Comp PM
    Originally Posted by tomlee59
    If you post the contents of the Progress logfile (click on the blue "i" in the Progress window), maybe there's a useful clue to be found.
    Yes ... for example
    Code:
    Encoding started on Sun Sep 14 19:39:03 CEST 2008
    MEncoder dev-CVS-060307-04:23-4.0.1 (C) 2000-2006 MPlayer Team
    FIXME:Hardenabling SSE and SSE2 without detection
    Mac OSX static build for ffmpegX
    CPU: Intel  (Family: 6, Stepping: 11)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    success: format: 0  data: 0x0 - 0x68c49850
    TS file format detected.
    DEMUX OPEN, AUDIO_ID: 0, VIDEO_ID: -1, SUBTITLE_ID: -2,
    PROBING UP TO 2000000, PROG: 0
    VIDEO MPEG2(pid=512)NO AUDIO!  NO SUBS (yet)!  PROGRAM N. 0
    Opened TS demuxer, audio: ffffffff(pid 0), video: 10000002(pid 512)...POS=0, PROBE=2000000
    VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  10000.0 kbps (1250.0 kbyte/s)
    [V] filefmt:29  fourcc:0x10000002  size:720x576  fps:25.00  ftime:=0.0400
    The selected video_out device is incompatible with this codec.
    Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [scale w=640 h=352]
    ==========================================================================
    Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
    VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
    VDecoder init failed :(
    Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
    Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
    ==========================================================================
    Forcing output fourcc to 58564944 [DIVX]
    VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
    1 duplicate frame(s)!
    2 to Planar YV12 using MMX2
    videocodec: libavcodec (640x352 fourcc=58564944 [DIVX])
    High quality encoding selected (non real time)!
    Writing header...
    ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
    1 duplicate frame(s)!
    Writing header...
    ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
    Writing header...
    ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
    Quote Quote  
  4. Member
    Join Date
    Aug 2005
    Location
    Palo Alto, California USA
    Search Comp PM
    Ah, yes. Your file is a "transport stream" (TS). Unfortunately, there is a known bug in mencoder not detecting audio in MPEG-TS files.

    If you must use mencoder for some reason, a workaround is to convert the TS file to "ordinary" .mpg using MPEG Streamclip. There's no quality loss -- it just changes the way the audio and video are encapsulated. Then mencoder will work.

    You will need the QT MPEG2 component in order for Streamclip to operate on MPEG2 files, however. If you don't already have it, you'll have to buy it from Apple. It's not expensive.

    Another option is to perform the audio conversion in a separate step (using ffmpegx's audio-to-audio function), then combine the result of that audio conversion with the video conversion to produce your final result. This procedure is more cumbersome, perhaps, but does not require the QT component.
    Quote Quote  
  5. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by tomlee59
    You will need the QT MPEG2 component in order for Streamclip to operate on MPEG2 files, however.
    Actually, MPEG Streamclip doesn't need to decode the MPEG video for this operation, and will work in 'converting' to MPEG without the QT component. You will get the warning that the component is missing, though.
    Quote Quote  
  6. Member
    Join Date
    Aug 2005
    Location
    Palo Alto, California USA
    Search Comp PM
    Thanks, Case -- that's handy to know!
    Quote Quote  
  7. Member
    Join Date
    Sep 2008
    Location
    Italy
    Search Comp PM
    Thanks for the quick answers
    I'll try tomorrow ... I am new about mac world :P ... i works fine in linux but only for server application...
    this forum is very useful for me ... specially for the quality of information like that.

    thanx... i'll know the result.
    Quote Quote  
  8. Member
    Join Date
    Sep 2008
    Location
    United States
    Search Comp PM
    hello guys,

    man, i am struggling with this ffmpeg x the whole day, and reading your posts i get some comfort that i am not alone, but still... cant find my hands and feet in it... am trying to convert some quicktime or AVI files to Flash, in order to upload them to my website. i downloaded the ffmpeg X for Mac, plus the 2 other components, but couldnt really figure out how to install the flvtool 2 ....

    then, i dragged the QT and AVI files into ffmpeg X, and try to convert them, but i got weird files, which wouldnt play, even on the VLC player which i downloaded... (i tried the Invert Mapping check box, but it still didnt work..). here are the messages i get:

    without checking the Invert Mapping box:

    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Sun Sep 14 20:35:59 PDT 2008
    Mac OSX universal build for ffmpegX
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    [mov,mp4,m4a,3gp,3g2,mj2 @ 0x4701fc]negative ctts, ignoring
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Volumes/Aylam-back up disk/clips for website/Autumn Dawn.mov':
    Duration: 00:01:20.3, start: 0.000000, bitrate: 2054 kb/s
    Stream #0.0(eng): Audio: lpcm / 0x6D63706C, 96000 Hz, mono
    Stream #0.1(eng), 29.97 fps(r): Video: h264, yuv420p, 425x318
    Codec type mismatch for mapping #0.0 -> #0.0

    After checking the Invert Mapping box:

    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    [mov,mp4,m4a,3gp,3g2,mj2 @ 0x4701fc]negative ctts, ignoring
    Sun Sep 14 20:36:48 PDT 2008
    m '/Volumes/Aylam-back up disk/clips for website/Autumn Dawn.mov':
    Duration: 00:01:20.3, start: 0.000000, bitrate: 2054 kb/s
    Stream #0.0(eng): Audio: lpcm / 0x6D63706C, 96000 Hz, mono
    Stream #0.1(eng), 29.97 fps(r): Video: h264, yuv420p, 425x318
    Output #0, flv, to '/Volumes/Aylam-back up disk/Autumn Dawn test1.flv':
    Stream #0.0, 29.97 fps(c): Video: flv, yuv420p, 432x324, q=2-15, 200 kb/s
    Stream #0.1: Audio: mp3, 22050 Hz, stereo, 56 kb/s
    Stream mapping:
    Stream #0.1 -> #0.0 [sync #0.0]
    Stream #0.0 -> #0.1 [sync #0.1]
    Unsupported codec (id=0) for input stream #0.0


    any idea what i am doing wrong ??

    thanks so much !!!!
    Quote Quote  
  9. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by Aylam
    any idea what i am doing wrong ??
    Your issue is in no way related to what anto1973 described, so please don't hijack this topic, but instead create your own new topic. We'll be happy to reply there. Thanks.
    Quote Quote  
  10. Member
    Join Date
    Sep 2008
    Location
    United States
    Search Comp PM
    oh sure, sorry for that, i didn't know how to start a new topic. will do that...
    Quote Quote  
  11. Member
    Join Date
    Jun 2007
    Location
    France
    Search Comp PM
    My problem was -- is similar : can't encode through FFMpegX 0.0.9 y from MPEG to AVI using mencoder (under Leopard up to date).

    Here is the road followed :

    I recorded on my internet box a .TS file.
    It came with 2 different language audio tracks.

    With MPEG Streamclip, I converted it to MPEG. It still had the 2 language tracks.

    In FFmpegX, I wanted to do as usual : convert it to .avi with Xvid mencoder.
    I found the proper .srt subtitle file, indicated it to FFMpegX, chose one of the language tracks, applied all the usual settings, and launched the process.

    But it always stops on 16% or something like that.
    the partial .Avi file I get contains the good audio track, the subtitles, but it is partial.

    If I choose the ffmpeg encoder, the process finishes, but I don't get the subtitles imported.

    So, with a MPEG file containing two languages, a .srt subtitle file, what would you suggest to convert to Xvid .avi ?

    thanks a lot

    i-Moi
    Quote Quote  
  12. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Try to 'Fix Timecode Breaks' in MPEG Streamclip, to try to get mencoder over the 16% mark.
    Quote Quote  



Similar Threads