VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Member
    Join Date
    Feb 2008
    Location
    United States
    Search Comp PM
    I used Gui for DVDAuthor (muxman variant) to author my DVD, and everything's fine. I also wish to add an EXTRAS folder for storing a bunch of files that will only be seen on a PC. I'm placing an autorun.bat and autorun.inf in the root that point to EXTRAS\index.html, so a PC with autorun enabled will load the html automatically (which lists the extra files).

    Problem is, ImgBurn is capitalizing all the filenames in the EXTRAS folder, truncating long filenames to 31 characters, and replacing any space characters, # characters, and - characters with underscores. I guess this necessary for UDF?

    I'm using ImgBurn 2.4.2.0 (latest) with default values, compiling an ISO, then opening the completed ISO in WinRar to check.

    Is there a way to avoid this renaming, and still keep the VIDEO_TS compliant with standard DVD video players? Or should I bite the bullet and rename all my files and their HTML references to be compliant?

    Thanks for any help.
    Quote Quote  
  2. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    When you load the DVD into Imgburn, make sure you load the Video_TS folder first so that Imgburn knows you are burning a DVD Video disc, and configures itself accordingly. Then add your extras folder.
    Read my blog here.
    Quote Quote  
  3. Member
    Join Date
    Feb 2008
    Location
    United States
    Search Comp PM
    Tried that. Loaded VIDEO_TS first, then EXTRAS, then the two autorun files.

    It warns me to set the file system to ISO9660 + UDF, and I set the ISO9660 to Level X (219 chars) but it still capitalizes and replaces characters.

    Maybe something to do with building an ISO instead of actually burning?

    Trouble is, I have a DVD on my desk here that I burned about a month ago with ImgBurn, and the filenames are unaltered. Can't remember what settings I used.
    Quote Quote  
  4. Member AlanHK's Avatar
    Join Date
    Apr 2006
    Location
    Hong Kong
    Search Comp PM
    Originally Posted by spamiaint
    Trouble is, I have a DVD on my desk here that I burned about a month ago with ImgBurn, and the filenames are unaltered. Can't remember what settings I used.
    Maybe:
    Advanced tab
    Restrictions
    ISO 9660: Character Set: Standard/DOS/ASCII

    I guess "DOS" would be all caps, try "Standard".
    That's the setting I have, I usually have a "Files" folder of stuff I put on my video DVDs, and the filenames are not changed.
    Quote Quote  
  5. Member
    Join Date
    Feb 2008
    Location
    United States
    Search Comp PM
    I did get a usable result with CDBurnerXP, using it's Video DVD Layout function. The files are all caps but the characters didn't get replaced.

    Thanks both for the tips, I'll try these out together.
    Quote Quote  
  6. Member
    Join Date
    Feb 2008
    Location
    United States
    Search Comp PM
    Ah, in ImgBurn setting the ISO9660 restriction to ASCII solves the problem. No capitalization, no character replacement.
    Quote Quote  



Similar Threads