VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
  1. Hello,

    After I've upgraded and updated my computer I have lost the ability to use DirectDraw Overlay and VMR9.

    It was a major hardware upgrade as I've changed the mobo (from Abit IC7-Max3 to Abit IP35 Pro with 2GB of OCZ PC2-6400), the processor (from P4 2.8GHz HT to Core2Duo E6850) and the graphics card (from GeCube ATI Radeon 9800 Pro to ASUS ATI Radeon HD 3870).

    I had no problem during the installation of the drivers and never got any error nor warning message. Of course I have properly uninstalled the ATi drivers before installing the new ones.
    However I have updated DirectX to the latest version (March 2008) and I haven't installed Catalyst Control Center (and never ever did) but I'm using Ray Adam's ATI Tray Tools instead. The OS is Windows XP 32 bits.
    Everything is running at stock speeds and voltages, no overclocking at all.

    Before the the upgrade/update everything was working fine, I was even able to watch at H264 DVB programs, even though it was sometimes a bit slow and using a lot of CPU.

    But after the upgrade/update, my old bundled version of PowerDVD, which never had any problem, started to complain about DirectDraw Overlay missing:

    In other apps like ProgDVB or Media Player Classic, VMR9 is not working anymore, it automatically switches back to the standard VMR.
    And also in Graphedit I'm not able to load VMR9 anymore, I got this error message:

    I've searched for the error number 0x80040273 (VFW_E_DDRAW_CAPS_NOT_SUITABLE):
    "Either Microsoft DirectDraw has not been installed or the video card capabilities are not suitable. Make sure the display is not in 16-color mode."
    DirectDraw test is working fine in DXdiag and of course I'm using 32 bits colors.

    For a test, I have also completly uninstalled the ATI drivers and ATI Tray Tools, deleted every ATI related file on the HDD and also deleted any ATI related key in the registry. After a reboot, and using the standard VGA driver, I still got the same error message in Graphedit when trying to load VMR9.

    I have reinstalled DirectX again once in VGA standard mode, updated the video drivers to v8.5, reinstalled DirectX again with the ATI drivers, but it didn't help.
    I have the feeling that the update of DirectX may have screwed something, but what and how to fix it ?

    VMR7 is available, can be selected and it's working fine in apps like ProgDVB and MPC - MPC-HC.

    Of course, the idea is not to reinstall from scratch.
    I'm searching for a solution for over one month so any help is appreciated
    Quote Quote  
  2. Member Ethlred's Avatar
    Join Date
    Feb 2008
    United States
    Search Comp PM
    Of course, the idea is not to reinstall from scratch.
    I'm searching for a solution for over one month so any help is appreciated
    Line one hence line two. In other words you made a mistake not reinstalling in the first place.

    New motherboard = reinstall the OS. Sometimes you can get away without it I hear. This does not look like one of those times. Of course you could beat your head against the wall for another month if you want. Spend a few days and save yet another month that at the end of which you have less hair and still have the same problem.

    What you did for the ATI sounds about right. I used to uninstall ATI drivers in Windows ME and 98SE manually. The ATI removal tool is pretty effective these days and I have not had to it manually with XP. Its the motherboard drivers that is most likely the problem. If you insist on doing things the hard way then go into the Device Manager and look for old stuff that shouldn't be there. Run a registry cleaner. Check the inf folder in Windows. I had to go in there for ATI stuff. In ME and 98 if I left the old inf files Windows would just reinstall on reboot before I could install the new drivers. Later that stopped happening. It seems removing the ATI drivers in the Device Manager also removed the INF files. Could be I am remembering this wrong as was quite a while ago. I only remember at all because I wrote it down to help others on the Maximum PC forum.
    Quote Quote  
  3. Thanks for the answer

    Be sure I've cleaned my PC from anything related to ATI before installing the new drivers and the DirectX update.
    And everything is working fine but this damn VMR9 and DirectDraw Overlay. I had no problem at all with any other software and hardware.

    I do believe this is a pure software issue. I have tweaked and optimized this XP for years this is the reason why I want to keep it as long as possible.
    However some of the tweaks I've used might be responsible of the issue. Not to mention that I've disabled a LOT of services (this PC is dedicated to gaming and video) but maybe some of the services should be running while updating video drivers and DirectX ?

    I don't know enough about which processes and internal components are called during video drivers and DirectX installation, so my hope is that some specialists reading this forum could give me some ideas
    Quote Quote  
  4. Member
    Join Date
    Jul 2008
    Search Comp PM
    I have exactly the same problem. I mean I didn't do any updates nor upgrades. But I reinstalled windows (previous format, of course), installed ATI drivers normally (Catalyst 8.6) and VMR9 & DD Overlay were gone. VMR7 works but VMR9 is needed in MPC-HC to apply shaders and to obtain DXVA acceleration on H264 videos.

    I tried to clean the system, uninstalling drivers, cleaning with Driver Cleaner etc etc, deleting registry keys and nothing changed. I also want a solution that doesn't involve formatting and reinstalling again.

    When I enable VMR9 in MPC-HC, nothing happens. Shaders are grayed out and if I try to load subtitles, a dialog box appears saying that I have to enable VMR9. I don't understand why this happens now.

    By the way I also use ATI Tray Tools.


    Solved: I had the /3GB and the /PAE switches in boot.ini. If you remove them, all works fine (don't ask)
    Quote Quote  

Similar Threads