VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 17 of 17
Thread
  1. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    What is the proper procedure to deal with .AVI files with aspect ratio different from the standard DVD (720x480) so that the video will appear CENTERED when playing with a DVD player?

    I tried changing the size of the video in the :video: tab. This works, but when I play the DVD it appears in the upper left corner, with large black lower and right borders. That is not what I wanted....

    Used ffmpegX, AVI to DVD (ffmpeg), then burn with Toast 9.0.2.

    Thanks.
    Quote Quote  
  2. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    What is the video size (width x height) of your source file?
    Quote Quote  
  3. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    Originally Posted by Case
    What is the video size (width x height) of your source file?

    660x352

    ffmpegx then complains that 660 is not divisible by 16, so I changed that to 656. The resulting DVD also has some problem at the right edge, which has some black and white border.
    Quote Quote  
  4. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    You will have to upscale a bit, as DVD supports a few very specific resolutions. DVD resolutions are build on rectangular pixels.

    Your movie aspect ratio is 660:352 = 1.875:1 .
    DVD is either 4:3 or 16:9, so we'll take the closest, 16:9 = 1.778:1 .
    Your movie is slightly more wide than 16:9, so the end result will have small letterbox bars to make it 16:9. DVD NTSC resolution is 480 px high, so your movie will be around (352/660)*(16/9)*480 = 455. ffmpegX requires the letterbox size to be an even number, so we end up with 12 + 456 + 12 = 480.

    That is pretty small letterboxing, so you could ignore it, but for the sake of argument, let's be precise.

    Open your file in ffmpegX. Select the DVD ffmpeg preset. In the Video tab, set Autosize to DVD 16:9. Change to the Video size to 720x456. In the Filters tab, Image filters, set Letterbox to 12, 12, 0, 0. Encode.

    If you think the calculation are too complicated and you don't mind a bit longer encoding time, then you could activate Decode with QuickTime in the Options tab (with Letterbox), which will ignore the settings in the Filters tab and letterbox automatically. In that case, set DVD 16:9, but leave the size at 720x480.
    Quote Quote  
  5. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    Thank you Case for the detailed explanation.

    Unfortunately, it does not work.

    Besides the minor problem I mentioned before, the first DVD I made played perfectly in a DVD player (Philips).

    In my second attempt, following your instructions, I produced an .ff.mpg file that has the correct aspect ratio and letterbox borders, and plays perfectly in VLC. The VIDEO_TS folder inside the .ff.mpg.DVD folder also plays and looks perfect in VLC, but does not play in Apple's DVD Player (the audio plays, but the video is stuck after about 10 s).

    Unfortunately, the DVD I burned with Toast is unplayable in the DVD player: The sound interrupts just about every 0.5 seconds! This is the same problem I had the first time I tried to use ffmpegX to make a DVD from an .AVI file: While it plays fine on the computer, I never managed to make a DVD that is playable in a hardware DVD player.

    This is all very frustrating. So close and yet so far...
    Quote Quote  
  6. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Hmm, that should have worked. A successful conversion should play in Apple DVD Player, in my experience.
    Time for getting some details...
    What is the duration of your movie?
    What is the framerate of your movie?
    What did you have set for the conversion bitrate (video, audio)?
    What is the file size of the output .mpg file?
    When you drop the output .mpg back on ffmpegX, what does the Summary say?
    Quote Quote  
  7. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    Originally Posted by Case
    Hmm, that should have worked. A successful conversion should play in Apple DVD Player, in my experience.
    Time for getting some details...
    What is the duration of your movie?

    1:30:40. That's one hour and 30 min., etc.

    What is the framerate of your movie?

    23.98, as reported by QuickTime Player

    What did you have set for the conversion bitrate (video, audio)?

    This is given as 4000 kbit/s in the Video tab. The number appears in green color.

    What is the file size of the output .mpg file?

    2.88 GB (original file size of the .AVI file is 701.5 MB)

    When you drop the output .mpg back on ffmpegX, what does the Summary say?
    From: MPG
    Video: mpeg-2, 720x480, 9000 kbps, 23.976 fps
    Audio: ac3, 48000 Hz, 448 kbps
    Quote Quote  
  8. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by germ
    MPG, Video: mpeg-2, 23.976 fps
    Nothing odd in the parameters to indicate playback troubles, except that the NTSC FILM framerate may cause playback trouble if the MPEG-2 video has no "3:2 pulldown". A common symptom is video 'stutter', but different unwanted behavior can also happen on set top DVD players.
    Unfortunately the DVD ffmpeg preset does not provide a direct way to apply the pulldown to the video.
    I would suggest using the DVD mpeg2enc preset, which does have a setting for applying a pulldown with the encoding.

    You could use the ffmpeg encoded .mpg file, but it's quite a bit more work.
    Quote Quote  
  9. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    OK, I am now trying with mpeg2enc, as you suggested. One problem is that there is no "letterbox" option.

    I checked the "Set 3:2" in the Options tab (I presume this will add the 3:2 pull-down).

    Unfortunately, it did not work: Encoding terminated right away. Here is the log:


    Encoding started on Sun Apr 6 11:13:25 PDT 2008
    INFO: [yuvscaler] yuvscaler 1.9.0 (15-02-2004) is a general scaling utility for yuv frames
    INFO: [yuvscaler] (C) 2001-2004 Xavier Biquard <xbiquard@free.fr>, yuvscaler -h for help, or man yuvscaler
    movtoy4m
    Copyright 2002-2006 Johan Lindström
    All rights reserved..
    /bin/sh: /Library/Application Support/ffmpegX/mpeg2enc: Malformed Mach-o file
    ++ WARN: [yuvscaler] Could not infer norm (PAL/SECAM or NTSC) from input data (frame size=720x456, frame rate=24000:1001 fps)!!
    INFO: [yuvscaler] input: frame size: 720x456 pixels (492480 bytes)
    INFO: [yuvscaler] input: chroma: 4:2:0 JPEG/MPEG-1 (interstitial)
    INFO: [yuvscaler] input: frame rate: 24000/1001 fps (~23.976024)
    INFO: [yuvscaler] input: interlace: none/progressive
    INFO: [yuvscaler] input: sample aspect ratio: 1:1
    INFO: [yuvscaler] from 720x456, take 720x456+0+0, NOT_INTERLACED/PROGRESSIVE
    INFO: [yuvscaler] scale to 720x456, 720x456 being displayed
    INFO: [yuvscaler] Scaling uses the RESAMPLE algorithm,
    INFO: [yuvscaler] frame rate: 23.976 fps
    INFO: [yuvscaler] Scaling ratio for width is 1 to 1
    INFO: [yuvscaler] and is 1 to 1 for height
    INFO: [yuvscaler] Specific downscaling routing number 4

    Looks like it does not like my mpeg2enc binary. I tried re-installing the mpeg2enc.intel, but still the same error.

    Any ideas?
    Quote Quote  
  10. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by germ
    OK, I am now trying with mpeg2enc, as you suggested. One problem is that there is no "letterbox" option.
    Sure it does have such an option.(screenshot)

    Originally Posted by germ
    I checked the "Set 3:2" in the Options tab (I presume this will add the 3:2 pull-down).
    Exactly.

    Originally Posted by germ
    Unfortunately, it did not work: Encoding terminated right away. Here is the log:
    [...]
    /bin/sh: /Library/Application Support/ffmpegX/mpeg2enc: Malformed Mach-o file
    [...]
    Looks like it does not like my mpeg2enc binary.
    Exactly.

    Originally Posted by germ
    I tried re-installing the mpeg2enc.intel, but still the same error. Any ideas?
    You must have installed it wrong somehow. Look at these steps below and see if you did one of those steps differently.

    1. Download mpeg2enc.intel to your desktop. The file should be 501,480 bytes.
    2. If the Components Self-Installer window doesn't come up after launching ffmpegX, force the window by selecting "Install binaries" from the ffmpegX menu.
    3. Missing or wrong size binaries are presented in red and should be replaced.
    4. Make sure the checkbox for mpeg2enc is set.
    5. Use the locate button to select the downloaded mpeg2enc.intel.
    6. Verify that the URL to the right of the Locate button has changed to the local location.
    7. Enter your admin password.
    8. Click "Install". The installer will change the binary's properties to make it a proper Unix Executable and copy it to the designated folder.
    Quote Quote  
  11. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    Tried your steps to the letter.

    Same error message: malformed Mach-o file.

    Verified that ffmpegX installed mpeg2enc binary inside /Library/Applications Support/ffmpeg/

    Here's the content of that folder:
    Code:
    drwxr-xr-x  21 user2  admin        714 Apr  6 14:02 .
    drwxrwxr-x  52 root    admin       1768 Feb 29 20:33 ..
    -rw-r--r--   1 user1  staff       6148 Apr  6 14:02 .DS_Store
    -rwxr-xr-x   1 user1  admin     281028 May 15  2004 gocr
    -rw-r--r--   1 user1  admin        500 May 15  2004 gocrfilter_en.sed
    -rw-r--r--   1 user1  admin        361 May 15  2004 gocrfilter_fr.sed
    -rw-r--r--   1 user1  admin        271 May 15  2004 gocrfilter_nl.sed
    -rw-r--r--   1 user1  admin         67 May 15  2004 gocrfilter_none.sed
    -rwxr-xr-x@  1 user1  staff   16655780 Apr 29  2006 mencoder
    -rwxr-xr-x   1 user1  staff     244832 May 15  2004 mp2enc
    -rwxr-xr-x@  1 user1  staff     501480 Apr  6 14:02 mpeg2enc
    -rwxr-xr-x@  1 user1  staff   15869784 Apr 29  2006 mplayer
    drwxr-xr-x  84 user1  staff       2856 Jan 27 20:25 reallib
    drwxr-xr-x  64 user1  user1      2176 Dec  1  2005 reallib_new
    drwxr-xr-x  50 user1  staff       1700 Oct 27  2005 reallib_old
    -rwxr-xr-x   1 user1  admin      22596 May 15  2004 subtitle2pgm
    -rwxr-xr-x   1 user1  staff     286168 Jul 17  2004 tcextract
    -rwxr-xr-x   1 user1  staff     589400 May 15  2004 vcdxbuild
    -rwxr-xr-x   1 user1  staff     568908 May 15  2004 vcdxgen
    -rwxr-xr-x   1 user1  staff     113352 May 15  2004 yuvdenoise
    -rwxr-xr-x   1 user1  staff     314968 May 15  2004 yuvscaler
    Quote Quote  
  12. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by germ
    Code:
    -rwxr-xr-x@  1 user1  staff   16655780 Apr 29  2006 mencoder
    -rwxr-xr-x@  1 user1  staff     501480 Apr  6 14:02 mpeg2enc
    -rwxr-xr-x@  1 user1  staff   15869784 Apr 29  2006 mplayer
    I don't know what the significance of the @-symbol is, but it doesn't show when I do a ls -l on my 10.4.11 system.
    On a "ls -l -F", these should have a "*" mark behind them, telling that they're executable.
    Also, these three have Owner: system (root), Group: admin on my list, not user1, staff.
    Were you logged in with an Administrator account while installing the binaries?
    Quote Quote  
  13. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    The @ means that the file has "extended attributes". The @ only shows in Leopard, so on your system, you would not see it (I am not sure if Tiger's Finder would set the attributes). You can read attributes with xattr. You can see the attributes keys using ls -l@. In my case:

    Code:
    -rwxr-xr-x@  1 user1  staff     501480 Apr  6 14:02 mpeg2enc
    	com.apple.metadata:kMDItemFinderComment	      93 
    	com.apple.metadata:kMDItemWhereFroms	      96 
    	com.apple.quarantine	      78
    This is Finder just tagging the extended attributes to a file downloaded from the 'net. So that you can get the message "This application was downloaded from the Internet on xx/xx/xx. Are you sure you want to run it?" the first time you attempt to run it (Leopard-only).

    So, in summary the @ is nothing to worry about.

    I have replaced my actual name with user1 just for posting to this forum.

    The binaries do have an asterisk when running ls -l -F.

    The owner does not matter, as the execution permissions are set for group and world. I believe the "staff" instead of "admin" default group is another Leopard difference. Yes, user1 has admin privileges (again, that's irrelevant here) and was used to install the binaries and is used when running ffmpegx.

    Perhaps we should change the title of this thread to "mpeg2enc binary not working: Malformed Mach-o file error".
    Quote Quote  
  14. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    One more thing, here's the md5 of mpeg2enc:


    Code:
    MD5 (mpeg2enc) = 3e8e6dd4299cb16b0d96cf3d2d422c66
    Quote Quote  
  15. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM
    Problem solved. It's Safari. Somehow Safari does not download the mpeg2enc binary properly. This is with version 3.1 (5525.13).

    BTW, I am not the only one having this problem: https://forum.videohelp.com/topic338080.html.

    This post put me on the right track: http://support.gams-software.com/doku.php?id=installation:how_do_i_install_the_gams_ve..._for_macintosh

    Downloading the mpeg2enc with Camino resulted in a success (the downloaded file has a Quicktime icon, while with Safari it gets an "empty" icon). The md5 checksum of the proper mpeg2enc binary is:


    Code:
    MD5 (mpeg2enc) = 7cad2f12971a2e69535778b56b3f9485
    There should be a warning on the ffmpegx home page about this pitfall with recent Safari versions (I bet it's the side effect of one of the security updates).


    I am now encoding to DVD using mpeg2enc. Will keep you posted on how that goes.

    For now, thanks for all the help you have given me.
    Quote Quote  
  16. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    Originally Posted by germ
    Problem solved. It's Safari. Somehow Safari does not download the mpeg2enc binary properly. This is with version 3.1 (5525.13).
    Well researched!
    Despite all the reasons for Safari being a great browser,
    downloading files is too often a let-down.
    Quote Quote  
  17. Member
    Join Date
    Oct 2005
    Location
    USA
    Search Comp PM


    Success!

    The DVD prepared with mpeg2enc works fine.

    Finally, finally, finally. After over one year of attempts with ffmpegx, it now works. Talk about a hard to use software.

    In summary, ffmpeg encoder does not work, but mpeg2enc works.

    Off to burning more DVDs. Thanks for all the help.
    Quote Quote  



Similar Threads