VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 24 of 24
Thread
  1. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    I have a Time Warner Cable TV account and a Scientific Atlanta Explorer 8300HD (160 GB HD) and I record some HD shows, then pipe them out to my Plextor ConvertX PX-M402U. I then boot into Xpro, run SageTV 6.3 and capture the file, and edit with womble MM editor. The problem is that I get gray bands across the top and bottom of the output files. Check out this screenshot: screenshot1.png Can't fix this in Womble. So I boot to Linux Mint and AviDemux, load the file, apply a crop filter, removing 64 from top and bottom and the preview looks good.

    But when I save the file, the bands are still there.

    Does anybody have some choice words of wisdom or suggestions regarding my convoluted and tedious, unsuccessful method(s)? Frankly, my friends, I'm getting tired of hard, and want to start working smart. At first I noticed that working hard was character building. But it soon become a repetitious exercise in futility. Any comments are welcome.

    And why isn't AviDemux filter being applied on save? Anything else I could try? I can use CLI.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  2. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    I don't think I fully under stand the problem you're having.

    What I gather from your post, is -
    8300HD is outputing 16:9 content, you are capturing this content with the Plextor in 4:3 format. And don't like the fact that when you capture 16:9 content with a 4:3 device, it puts black bars on the top and bottom?

    Now, what is you final goal? DVD? XviD, x264?

    If you are wanting to output back to DVD, but have it actually in 16:9 format, crop the top and bottom of the black bars, resize to 720x480, encode as 16:9.

    ffmpeg -i file.mpg -croptop 64 -cropbottom 64 -s 720x480 -aspect 16:9 -target dvd-ntsc output.mpg

    Want something a little more complicated?

    mkfifo video.yuv
    mplayer -noconsolecontrols -benchmark -nosound -noframedrop -noautosub -vo yuv4mpeg:file=video.yuv capture.mpg \
    -vf crop=:352::,scale=720:-2:0:0:0.00:0.75:ntsc:0:0,fspp=5::6::,unsharp=l3x3: 1.20:c3x3:0.50,expand=720:480 & \
    cat video.yuv | yuvdeinterlace -S 0 | yuvdenoise* -G 2,3,3 | mpeg2enc -f 8 -a 3 -g 3 -G 18 -4 1 -2 1 --cbr -b 5500 -R 2 -K tmpgenc \
    -o output.m2v


    * yuvdenoise changed it params in the newer release candidates, older than 1.9 would use yuvdenoise -s 2,3,3 -g 32,128,128 -t 3,4,4, and you may need to adjust the crop value. 352 would chop 64 from the top and bottom (480-64-64=352). You could also remove yuvdeinterlace, and keep the footage interlaced, or add yadif to the mplayer filter chain. You can add remove any filter needed, either y4m/yuv filters or mplayer filters.


    When that file is played back on a 4:3 monitor or tv, it will append the black bars. Remember watching 16:9 DVDs on a sqaure TV? When the file is played back on a wide screen TV/Monitor, there will be no black bars.


    You're best bet might be to encode to XviD or x264. Check these programs that do a bang up job - http://xvidenc.sourceforge.net/
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  3. SA cable boxes convert 16:9 HD to letterboxed 4:3 SD at the s-video and composite outputs. Your computer is just capturing what the box is putting out.
    Quote Quote  
  4. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    SA cable boxes convert 16:9 HD to letterboxed 4:3 SD at the s-video and composite outputs. Your computer is just capturing what the box is putting out.
    Now I understand that the Plextor video capture device is receiving a letterbox output. I want to archive some TV shows and squeeze them down with h.264. I will never copy them to a DVD, but they must be in a format easily recognized by Linux vlc or mPlayer.

    disturbed1's ffmpeg cli works fine: ffmpeg -i file.mpg -croptop 64 -cropbottom 64 -s 720x480 -aspect 16:9 -target dvd-ntsc output.mpg

    But the file size grew from 2.5 GB to 17.7 GB.

    Then I tried adding h264 compression ffmpeg -i file.mpg -croptop 64 -cropbottom 64 -s 720x480 -aspect 16:9 -target dvd-ntsc -vcodec h264 output.mpg and it bombed:

    Code:
    rmack@rochester:~/temp$ ~/h264_16x9.sh 
    FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
      configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-libmp3lame --enable-libfaadbin --enable-libfaad --enable-libfaac --enable-xvid --enable-x264 --enable-liba52 --enable-amr_nb --enable-amr_wb --enable-shared --prefix=/usr
      libavutil version: 1d.49.3.0
      libavcodec version: 1d.51.38.0
      libavformat version: 1d.51.10.0
      built on Dec 20 2007 21:25:50, gcc: 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
    Input #0, mpeg, from 'Banned From the Bible II.mpg':
      Duration: 01:27:53.1, start: 0.169900, bitrate: 3869 kb/s
      Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480, 6400 kb/s, 29.97 fps(r)
      Stream #0.1[0x1c0]: Audio: mp2, 48000 Hz, stereo, 384 kb/s
    Assuming NTSC for target.
    File 'Banned From the Bible II-1.mpg' already exists. Overwrite ? [y/N] y
    Output #0, dv, to 'Banned From the Bible II-1.mpg':
      Stream #0.0: Video: h264, yuv420p, 720x480, q=2-31, 200 kb/s, 29.97 fps(c)
      Stream #0.1: Audio: pcm_s16le, 48000 Hz, stereo, 1536 kb/s
    Stream mapping:
      Stream #0.0 -> #0.0
      Stream #0.1 -> #0.1
    [h264 @ 0xb7e22a68]using SAR=32/27
    [h264 @ 0xb7e22a68]using cpu capabilities MMX MMXEXT SSE SSE2 
    [dv @ 0xb7f15610]Can't initialize DV format!
    Make sure that you supply exactly two streams:
         video: 25fps or 29.97fps, audio: 2ch/48Khz/PCM
         (50Mbps allows an optional second audio stream)
    Could not write header for output file #0 (incorrect codec parameters ?)
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  5. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    Grab h264enc. It will make your life easy

    http://h264enc.sourceforge.net/

    Grab the latest tarball, extract it to a directory, and run it (from the cli) from there. No need to install.

    ./h264enc --help
    Will give you lots of information.

    ./h264enc -sc
    Performs a check to see what programs you have installed


    I usually just use
    ./h264enc -1p -p uhq
    Which will do a one pass encode with ultra high quality.

    You can also try
    ./h264enc -1p -p hq
    Which give you a simple one pass encode at high quality
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  6. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    LOL! I'm still in a pickle!

    I had a letterboxed file.mpg sized 2.5 GB. I can remove the letterbox bands and resize it with ffmpeg -i file.mpg -croptop 64 -cropbottom 64 -s 720x480 -aspect 16:9 -target dvd-ntsc output.mpg , but the filesize grows to 17.7 GB. That's too big. Or I can run h264enc -1p -p hq which squeezes the down to a nice 700 MB size, but retains the letterboxing bands.

    I want to do both compressing and cropping in one pass, preferably w/o pipling, because piping is incompatible with h264enc.

    There seems to be an option that would enable cropping in the h264enc script:

    Code:
    Would you like to Crop the video file? [y/n]: y
    
    -> Detecting crop values with 'cropdetect'...
    -> Found crop values: 704:464:6:8
    
    Specify the crop values [default is 704:464:6:8]:
    But I am not sure how much cropping can be done without breaking the encoder. Any ideas?
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  7. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    Specify the crop values [default is 704:464:6:8]:720:352::

    Yes there are 2 : after 352. So that's ::

    Originally Posted by man [url=https://www.videohelp.com/tools/MPlayer
    mplayer[/url]]
    crop[=w:h:x:y]
    Crops the given part of the image and discards the rest. Useful to remove black bands from widescreen movies.
    <w>,<h>
    Cropped width and height, defaults to original width and height.
    <x>,<y>
    Position of the cropped picture, defaults to center.
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  8. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    Tried your suggested resize to 720:352:: and the preview from the h264enc script looked fine; the black lines were removed. However the resultant file was unplayable and only 4.0k in size.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  9. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    I never suggested a resize, it was a crop There's a difference between crop and resize, as there is between .mpg and .mp4, .avi, .mkv (which is the container x264 files need to go in).

    The preview worked, and looked correct, so the crop settings where passed correctly. Sounds like a bad option somewhere was passed. Giving a 4k file means mencoder didn't even encode the file, it instantly bailed. h264enc has the option to both inspect the command and save the command.

    ./h264enc --help
    man mplayer

    There isn't honestly anything I won't tell you that isn't in those 2 pieces of documentation I'd spend the 5 minutes and see what they have to say
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  10. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    I looked at the mencoder script generated by h264enc and it appears impossible for a person of my modest abilities to parse. I guess I know when I'm licked.

    mencoder "/home/rmack/temp/test-5.mpg" -o "/home/rmack/temp/test-5.avi" -vf crop=720:352::,softskip,harddup -oac faac -faacopts mpeg=4:br=110bject=2 -ovc x264 -x264encopts bitrate=1000:me=umh:me_range=16:nodct_decimate:noi nterlaced:8x8dct:threads=auto:nofast_pskip:trellis =1artitions=p8x8,b8x8,i8x8,i4x4:mixed_refs:keyint=30 0:keyint_min=30:frameref=3:bframes=14:bime:b_adapt :b_pyramid:weight_b:direct_pred=autoubq=5:nobrdo:chroma_me:cabac:deblock:nossim:nopsnr

    This, of course, crashes mencoder instantly without processing the file as desired.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  11. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    Originally Posted by Verlager
    I looked at the mencoder script generated by h264enc and it appears impossible for a person of my modest abilities to parse. I guess I know when I'm licked.
    Need an engineering degree for that sucker don't you


    What I do, when I don't understand one of the options passed is look it up in the man page.
    man mplayer

    You may not know this, but there is a man for man to search inside a man page type / a text entry will appear to type in. Use the n
    key for next, p for previous entry. PgUp/Down as Home/End also work naviagting.

    Copy and paste the following, to see how it goes.
    mencoder "/home/rmack/temp/test-5.mpg" -o "/home/rmack/temp/test-5.avi" -vf crop=720:352::,yadif,softskip,harddup \
    -oac copy -ovc x264 -x264encopts \
    bitrate=1000:me=umh:me_range=16:nodct_decimate:8x8 dct::nofast_pskip:trellis=1artitions=p8x8,b8x8,i8x8,i4x4:mixed_refs:\
    keyint=300:keyint_min=30:bframes=3:bime:b_adapt:b_ pyramid:weight_bubq=5:nobrdo:chroma_me:cabac:\
    deblock:nossim:nopsnr


    Mencoder will either process, or send some type of error. Sigterm, can't open -vf, something........

    The only thing I changed from h264enc is adding the yadif deinterlancer, lowered the number of b frames, removed faac encoding.
    Faac encoding can be buggy if you don't have the right bins/libs. It will encode a little slow

    The \ at the end of the lines creates a line break. That way everything doesn't run together as one great big huge line.


    You can try to use the default x264 options as well -

    mencoder inpuptfile.mpg -ovc x264 -oac copy -vf crop=720:352::,yadif -x264encopts bitrate=1000 outfile.avi
    That's just a basic script to use all of the default x264 options with a bitrate of 1000, crop 64 pixels from the top and bottom, deinterlace.


    If you're tired of all this scripting winff is a nice program as well. It has basic options and presets ready for you, but now
    that you know a few options, you can customize it your self
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  12. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    Thank you for your input. It is appreciated. The first suggestion bombed:

    Code:
    rmack@rochester:~$ mencoder "/home/rmack/bin/test-5.mpg" -o "/home/rmack/bin/test-5.avi" -vf crop=720:352::,yadif,softskip,harddup  -oac copy -ovc x264 -x264encopts  bitrate=1000:me=umh:me_range=16:nodct_decimate:8x8dct::nofast_pskip:trellis=1:partitions=p8x8,b8x8,i8x8,i4x4:mixed_refs:keyint=300:keyint_min=30:bframes=3:bime:b_adapt:b_pyramid:weight_b:subq=5:nobrdo:chroma_me:cabac: deblock:nossim:nopsnr 
    MEncoder 2:1.0~rc1-0ubuntu13.1 (C) 2000-2006 MPlayer Team
    CPU: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (Family: 6, Model: 15, Stepping: 11)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    Option x264encopts: Unknown suboption 
    success: format: 0  data: 0x0 - 0x144e638
    AVI file format detected.
    VIDEO:  [MPEG]  720x480  24bpp  29.970 fps  4764.5 kbps (581.6 kbyte/s)
    [V] filefmt:3  fourcc:0x4745504D  size:720x480  fps:29.97  ftime:=0.0334
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [harddup]
    Opening video filter: [softskip]
    Opening video filter: [yadif]
    Opening video filter: [crop w=720 h=352]
    Crop: 720 x 352, -1 ; -1
    ==========================================================================
    Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
    Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
    ==========================================================================
    audiocodec: framecopy (format=50 chans=2 rate=48000 bits=16 B/s=48000 sample-1)
    VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
    SwScaler: using unscaled yuv420p -> yuv420p special converter
    FATAL: Cannot initialize video driver.
    
    Exiting...
    rmack@rochester:~$
    -as did the second:

    Code:
    rmack@rochester:~$ mencoder /home/rmack/bin/test-5.mpg -ovc x264 -oac copy -vf crop=720:352::,yadif -x264encopts bitrate=1000 -o /home/rmack/bin/test-5.avi 
    MEncoder 2:1.0~rc1-0ubuntu13.1 (C) 2000-2006 MPlayer Team
    CPU: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (Family: 6, Model: 15, Stepping: 11)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    success: format: 0  data: 0x0 - 0x144e638
    AVI file format detected.
    VIDEO:  [MPEG]  720x480  24bpp  29.970 fps  4764.5 kbps (581.6 kbyte/s)
    [V] filefmt:3  fourcc:0x4745504D  size:720x480  fps:29.97  ftime:=0.0334
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [yadif]
    Opening video filter: [crop w=720 h=352]
    Crop: 720 x 352, -1 ; -1
    ==========================================================================
    Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
    Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
    ==========================================================================
    audiocodec: framecopy (format=50 chans=2 rate=48000 bits=16 B/s=48000 sample-1)
    VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
    SwScaler: using unscaled yuv420p -> yuv420p special converter
    x264 [info]: using SAR=8/9
    x264 [info]: using cpu capabilities MMX MMXEXT SSE SSE2 
    Pos:   0.0s      1f (99%)  0.00fps Trem:   0min   0mb  A-V:0.000 [0:0]
    Flushing video frames
    Writing index...
    Writing header...
    ODML: vprp aspect is 16384:9011.
    
    Video stream:      nan kbit/s  (-2147483648 B/s)  size: 0 bytes  0.000 secs  1 frames
    
    Audio stream:  384.000 kbit/s  (48000 B/s)  size: 24000 bytes  0.500 secs
    x264 [info]: final ratefactor: 22.20
    Winff is a nice gui for ffmpeg, but it doesn't allow for cropping, AFAIK, and I have tried it. BTW, this mencoder CLI syntax should be more forgiving, users should be allowed to use abbreviated syntax:
    mencoder input.mpg -o output.mpg vf crop=720:352::,yadif -which, of course, is nonsense. I just think this 1970's CLI voodoo is not as user-friendly (yes, I see your signature) as it might be.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  13. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    I just think this 1970's CLI voodoo is not as user-friendly (yes, I see your signature) as it might be.
    Mencoder is not included in that statement

    In my opinion, x264 is bailing on you. 1 of 2 things, mencoder/mplayer outdated, x264 outdated. Using Ubuntu, the only solutions,
    are to work around it, or compile your own. Mplayer/mencoder isn't that out of date, so we'll leave it alone.

    The first command (from h264enc) failed because it passed options that your x264 doesn't support. The second failed
    because I have no idea .

    You can crop with winff. Click view, check additional options. Add this to the additional Command Line Parameters (advanced)
    -croptop 64 -cropbottom 64


    IF winff fails as well with x264 encoding, you'll either have to just use xvid, or compile a new x264. It is quite easy to compile x264.
    I'll type this out for the CLI, just because it easier than typing click this, that, choose this that....
    Code:
    cd $HOME/Desktop
    wget ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-20080315-2245.tar.bz2
    tar -xf x264-snapshot-20080315-2245.tar.bz2
    cd x264-snapshot-20080315-2245
    ./configure --enable-pthread --enable-shared --prefix=/usr
    make -j4
    sudo make install
    sudo ldconfig


    Line by line -
    Changes directory to the current user's home, then Desktop directory.
    Downloads the daily snap shot of x264 (03-15-2008)
    Extracts the tarball
    Changes into the directory of the newly extracted tarball
    Configures x264 to use multithreads, creates shared libraries, with the install prefix of /usr (Standard for Ubuntu)
    Compiles the source using your 4 cores.
    Becomes root to install the newly created files.
    Root once again updates all linked (shared) libraries.


    ------------edit----------------

    Does this file you're trying to encode play with mplayer/VLC? I guess that should of been the first thing, but just covering all bases here.
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  14. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    This takes too many steps to save and compress a file. Can anyone comment on this cumbersome method?

    I. I record the HD cable TV signal to the SA cable box, which converts 16:9 HD to letterboxed 4:3 SD at the s-video and composite outputs.

    II. I pipe the two-hour, 4 GB file to my computer with this shell script:

    Code:
     #!/bin/bash
    bitrate=1750
    mode=ntsc
    #format=mpeg2-dvd
    format=mpeg2
    duration=`expr $2 \* 60`
    input=0
    
    gorecord -input $input -duration $duration -bitrate $bitrate -mode $mode -format $format $1.avi
    III. I use avidemux to load the file, remove the black bars with a crop filter, change the codec to mpeg, and save the file down to 2.5 GB.

    IV. Then I use winff to transcode to h.264 mp4 ipod 16:9 preset. The file is now 1.1 GB

    This works. Avidemux encodes it accurately, even the audio is correct. But what shortcut am I missing? What steps could be eliminated safely to streamline this complex process? Steps I and II are needed as is. It's steps 3 and 4 that might be tweaked. Anybody have any ideas? Is there a better and safe avidemux codec and container combo to use?
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  15. You can use AviDemux to do steps 3 and 4 at the same time. It can output h.264+AAC in an MP4 container. You just have to use settings suitable for your player.
    Quote Quote  
  16. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    Not exactly... If you select x264 from Avidemux, the filters are disabled. Tell me if I'm mistaken.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  17. Originally Posted by Verlager
    If you select x264 from Avidemux, the filters are disabled.
    I've never had that happen. Although, I've only used the Windows version.
    Quote Quote  
  18. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    Huh. And the Linux Avidemux doesn't support the .mkv container. That could have helped.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  19. Member
    Join Date
    Feb 2008
    Location
    Rochester NY
    Search Comp PM
    I off-loaded the task to the bedroom office Q6600 Linux Mint machine and it worked. Thank you so much for the tip!

    I hope I can get crisper with avidemux.
    ..and from the gods we've stolen pi, two times again our radii. the glyphs of mice and men we read, the darkness in our souls stampede....
    Linux bc calculator can display pi to enormous precision: bc -l; scale = 500; 4*a(1)
    Quote Quote  
  20. So is it just a version number difference?
    Quote Quote  
  21. Member
    Join Date
    May 2008
    Location
    New Zealand
    Search Comp PM
    Im trying to extract part of this flv video and im using WinFF, does anyone know if it is possible to just grab a section of the video and encode just that part?
    Quote Quote  
  22. afaik ffmpeg doesn't support encoding of only a section (while mencoder do)

    you can try using avisynth and ffmpeg

    using a script like
    directshowsource("test.flv")
    trim(1500,3000) # for keeping from 1500' frame to 3000' frame

    if ffmpeg is compiled with avs support, you will be able to encode this script

    using WINE of course..

    BHH
    HDConvertToX, AutoMen, AutoMKV Developer
    Quote Quote  
  23. On my 3 Freeview boxes that I've had and the sky and sky+ boxes, if I told them that they were outputting to a 16:9 TV even though they were actually connected to either a Liteon DVD recorder or a Hauppauge capture card (both of which only capture 4:3), the picture would be recorded as a vertically stretched 16:9 picture that filled the screen. Once this video is on the computer you either save from your editing software with the 16:9 option ticked or use DVD Patcher to change a flag in the file's header so that it becomes widescreen again. Check the settings on your cable box and make sure that they're set to output to 16:9 devices.

    Hope this is of some help
    Quote Quote  
  24. Unless there is some hidden menu somewhere Scientific Atlanta cable boxes don't have the option of squeezing a 16:9 image into the s-video or composite outputs. They always letterbox.
    Quote Quote  



Similar Threads