VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 32
Thread
  1. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Hi forum folk,

    I just got a divx-certified DVD player (Pioneer dv-400v IIRC) for the express purpose of playing divx files on my plain old 4:3 low-def TV. I read quite a few reviews of this unit and the consensus was that it could handle just about any divx file you threw at it. So I threw a few at it. And it choked. Over and over again.

    But hey, maybe it's me. My sources are DVD rips and High-def MPEG-TS streams recorded in mythtv from OTA digital TV. I've mostly been trying to use handbrake 0.9 because it handles both types of files and I find it pretty intuitive, but I've also tried some raw ffmpeg voodoo based on presets from winff. My latest test case is a 5 minute snippet of Lost recorded in 720p. I just tried this ffmpeg script:

    Code:
    [n8gray@platypus]% cat tcode
    #!/bin/zsh
    /usr/bin/ffmpeg -i $1 -r 29.97 -vcodec xvid -s 704x384 -aspect 16:9 -maxrate 1800k -b 1500k \
        -qmin 3 -qmax 5 -bufsize 4096 -mbd 2 -bf 2 -flags +4mv+trell -aic 2 -cmp 2 -subcmp 2 \
        -g 300 -acodec mp3 -ar 48000 -ab 128k -ac 2 $2
    The result was a file that worked OK at times but anytime there was a change of camera it turned into a slideshow.

    Is anybody else out there doing this kind of thing with HD streams? How do you make "standard divx" files suitable for standalone players?

    FWIW, I understand my player can handle most divx features other than 3-point GMC, but I don't know how to specify any of those things to ffmpeg or even learn if I've got them in a file.

    Thanks!
    Quote Quote  
  2. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Did you try AVIDEMUX instead?

    It has an option called Xvid4 that should work with the following XviD parameters:









    If you have a NTSC TV then use a resolution of 720x480 or less.

    If you have a PAL TV then use a resolution of 720x576 or less.

    Also you tend to get better playback from a DVD disc than a CD disc. The reason is that high bitrate MPEG-4 encodes play back better from a DVD since a DVD spins faster than a CD. Also note that some players have a USB input and people try to use an external HDD hooked up to the USB input but that can often cause playback issues in the same way i.e., not fast enough.

    - John "FulciLives" Coleman

    P.S.
    As per my example images ... note that you have to use whatever AVERAGE BITRATE is appropriate to your source etc. and the same applies to the PIXEL ASPECT RATIO option (although 1:1 should be what you use). Everything else should be set as per my example images.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  3. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    You shouldn't use avidemux for Divx certified players, since it doesn't support xvid dxn profiles.
    Restricts options and VBV (peak bitrate over a short period) according to the Simple, Advanced Simple and DivX profiles. The resulting
    videos should be playable on standalone players adhering to these profile specifications.
    Here's a simple mencoder script that works flawlessly with my old Philips.

    Code:
    mencoder input.file -o output.avi -ovc xvid -oac mp3lame -ffourcc DIVX -noskip -vf hqdn3d=2:1:2,harddup -xvidencopts\ fixed_quant=2:me_quality=6:trellis:quant_type=mpeg:chroma_opt:vhq=4:lumi_mask:profile=dxnhtntsc:threads=2 -lameopts cbr:br=128:q=2
    Customize to how you like, you may want to add a scale=H??:W?? (or other resizer) to the -vf chain (man mplayer is your friend)

    FFmpeg does have a -profile but it does? Nothing in the man page about it.

    Also check out xvidenc, a nice interactive shell script for xvid encoding. http://xvidenc.sourceforge.net/

    You can try using a DVD as FulciLives suggested. I've always had stuttered playback on my Philips with anything from avidemux. I've watch the bitrate during encoding and have seen it spike to peaks above 6000K.
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  4. Max b-frames 2 might be a problem. Try using 1 instead.
    Quote Quote  
  5. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    Hi,
    If the above advice doesn't work.

    Check out this thread from the WinFF Forums:
    http://biggmatt.com/winff-forums/index.php?topic=40.0
    Quote Quote  
  6. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by FulciLives
    Did you try AVIDEMUX instead?

    It has an option called Xvid4 that should work with the following XviD parameters:
    I'm assuming you're supposed to get this from the Video->Encoder dialog? I choos Xvid4 and click the "Configure Codec" button and... nothing happens. Avidemux 2.3.0 on Ubuntu feisty (7.04)

    Also you tend to get better playback from a DVD disc than a CD disc. The reason is that high bitrate MPEG-4 encodes play back better from a DVD since a DVD spins faster than a CD. Also note that some players have a USB input and people try to use an external HDD hooked up to the USB input but that can often cause playback issues in the same way i.e., not fast enough.
    Hmm, that's a good point. I've been using my ipod for testing. After burning a few coasters I decided to take a more affordable route. I don't have any dvd-rw discs at the moment.

    Thanks,
    -n8
    Quote Quote  
  7. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by jagabo
    Max b-frames 2 might be a problem. Try using 1 instead.
    According to the divxtest cd this shouldn't be an issue for my player. Thanks anyway.
    Quote Quote  
  8. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Originally Posted by n8gray
    Originally Posted by FulciLives
    Did you try AVIDEMUX instead?

    It has an option called Xvid4 that should work with the following XviD parameters:
    I'm assuming you're supposed to get this from the Video->Encoder dialog? I choos Xvid4 and click the "Configure Codec" button and... nothing happens. Avidemux 2.3.0 on Ubuntu feisty (7.04)
    Well that is not a good thing LOL

    Try using SYNAPTIC PACKAGE MANAGER to do a search on "TRANSCODE" and see if there is an option to install the following (if not already installed):

    1.) transcode
    2.) xvid4conf
    3.) gtranscode

    All three of the above show up for me by simply doing a search for "TRANSCODE" although I don't think you really need the third one listed above but you definitely need the first two on the list. That should (knock on wood) solve the problem of the "Configure Codec" button not working in AVIDEMUX.

    Come to think of it you might want to double check and do a search for "XVID" and make sure you have "libxvidcore4" installed although I'm sure it already is (knock on wood).

    I want to stress that while I am no video encoding newbie I am still somewhat new to using Linux so do not take what I say as "gospel" when it comes to using Linux ... ok? LOL 8)

    - John "FulciLives" Coleman
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  9. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by disturbed1
    Here's a simple mencoder script that works flawlessly with my old Philips.

    Code:
    mencoder input.file -o output.avi -ovc xvid -oac mp3lame -ffourcc DIVX -noskip -vf hqdn3d=2:1:2,harddup -xvidencopts\ fixed_quant=2:me_quality=6:trellis:quant_type=mpeg:chroma_opt:vhq=4:lumi_mask:profile=dxnhtntsc:threads=2 -lameopts cbr:br=128:q=2
    Customize to how you like, you may want to add a scale=H??:W?? (or other resizer) to the -vf chain (man mplayer is your friend)
    Thanks. I tried this out but had to modify it to get the frame size down to SD (as you mentioned) and change the framerate from 60fps to 30fps. However, I'm doing something wrong with the framerate conversion, because the result is a video that plays at half-speed with double duration.

    Here's my command:
    Code:
    mencoder $1 -o $2 -ovc xvid -oac mp3lame -ffourcc DIVX -ofps 30000/1001 -noskip \
            -xy 640 -vf scale=640:-11,hqdn3d=2:1:2,harddup -xvidencopts \
            fixed_quant=2:me_quality=6:trellis:quant_type=mpeg:chroma_opt:vhq=4:lumi_mask:profile=dxnhtntsc:threads=2 \
            -lameopts cbr:br=128:q=2
    I got a ton of errors during the transcode:
    Code:
    Too many video packets in the buffer: (4096 in 8280248 bytes).
    Maybe you are playing a non-interleaved stream/file or the codec failed?
    For AVI files, try to force non-interleaved mode with the -ni option.
    Any suggestions?

    Also check out xvidenc, a nice interactive shell script for xvid encoding. http://xvidenc.sourceforge.net/
    This looks awesome, but it doesn't work for me. I get errors like:
    Code:
    -> Detecting source FPS value...
    grep: /fps: No such file or directory
    -> Failed to detect source FPS value!
    
    Would you like to set/force the Output Frame Rate (FPS)? [y/n]:
    I poked around in the source a bit but haven't figured out the problem just yet. :/

    UPDATE: Ok, I figured out that the code assumes ~/.xvidenc exists and fails if it doesn't. I'll try this out again.

    Thanks for the info,
    -n8
    Quote Quote  
  10. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by FulciLives
    Try using SYNAPTIC PACKAGE MANAGER to do a search on "TRANSCODE" and see if there is an option to install the following (if not already installed):

    1.) transcode
    2.) xvid4conf
    3.) gtranscode
    I didn't have xvid4conf installed, but installing it didn't help AFAICT. BTW, I tried running avidemux from the terminal and didn't get any error output when trying to configure xvid.

    Come to think of it you might want to double check and do a search for "XVID" and make sure you have "libxvidcore4" installed although I'm sure it already is (knock on wood).
    Yeah, I did have that at least.

    I want to stress that while I am no video encoding newbie I am still somewhat new to using Linux so do not take what I say as "gospel" when it comes to using Linux ... ok? LOL 8)
    Well I'm a fairly advanced Linux user but a video newbie, so between us we should be able to solve *any* problem.

    Cheers,
    -n8
    Quote Quote  
  11. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    Originally Posted by n8gray
    I poked around in the source a bit but haven't figured out the problem just yet. :/

    UPDATE: Ok, I figured out that the code assumes ~/.xvidenc exists and fails if it doesn't. I'll try this out again.

    Thanks for the info,
    -n8
    About your fps thing, you'll need to pulldown or telecine the footage.

    Don't download the newest one put out today or yesterday, you want the 7.7.1 version. Big changes in the 7.7.2, it isn't ready yet. I get errors on the crop dialog.

    Just download the archive, untar it. Open a term, cd to the xvidenc dir.
    ./xvidenc -sc to do a sanity check
    ./xvidenc -2p -p whater dxn profile you want
    or
    ./xvindenc --help

    No reason to install it. In fact I'd say not. Considering how often this is released, just keep it in a dir, and exec.

    If you have a dual core, avoid Fiesty's xvid, it's out of date. Best just to compile the daily source tarball
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  12. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Well I don't know what else to tell you then

    Here is an example of what I do:

    1.) Fire up AVIDEMUX and open a file (in this case a MPEG-2 DVD compliant file with muxed audio)

    All I did here was open up the file and "seek" to a point within the file.


    2.) Select Xvid4 under "VIDEO"



    3.) Click on the CONFIGURE button (right under where it says Xvid4)



    4.) Then go through the settings like I showed you in one of my previous posts in this thread.


    I have no idea why your CONFIGURE button does not work

    - John "FulciLives" Coleman

    P.S.
    The MPEG file in question is the trailer to INDIANA JONES 4 and I made the MPEG file using WinFF from the downloaded Quicktime file of the trailer.
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  13. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Thanks to you guys I've finally got video that plays! Finding xvidenc has been very helpful, as it (usually) generates working mencoder command lines for me to tweak. But I'm still not 100% there yet. My first xvidenc attempt went pretty well, generating good-looking video. But the audio was just a tiny bit out of sync, coming a little too late (with a constant offset I think). Also, the video seemed jerky somehow. Not "cpu can't keep up" jerky but just uniformly not smooth. My hypothesis was that I actually needed to produce interlaced video to make my old-fashioned non-progressive-scan TV happy. So I generated interlaced video (after downgrading to the older xvidenc -- the new one broke 2-pass interlaced video) and it seemed to help the jerkiness. Does this line of reasoning make sense?

    So the remaining problems are:
    1. The audio sync issue
    2. For some reason my interlaced encodes look really bad. I wasn't surprised to get that from a one-pass encode, but I got bad results from a 2-pass encode with de-blocking enabled as well.
    3. xvid is sloooooow. My 2-pass interlaced encode took about 45 minutes for a 5 minute clip!

    Any suggestions on solving these remaining problems would be appreciated!
    Cheers,
    -n8
    Quote Quote  
  14. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    45 minutes for 5 minutes is way too long.

    If you compiled your own xvid, make sure you have NASM/YASM installed before you compile. That was one of the older bugs in Ubuntu's xvid, they didn't compile it correctly. The default xvid in Feisty gave me 3.x fps, compiling my own gave me 14.xfps for the same footage. I thought this was fixed in an Update?
    xvidcore (2:1.1.2-0.1ubuntu1.1) feisty-updates; urgency=low

    * No-change upload to propagate to feisty-updates (LP: #84705)

    -- Daniel T Chen <crimsun@ubuntu.com> Mon, 04 Jun 2007 17:46:58 -0400

    xvidcore (2:1.1.2-0.1ubuntu1.1~proposed1) feisty-proposed; urgency=low

    * Added missing yasm [i386] dependency in debian/control (fix bug #84705)

    -- Loc Martin <loic.martin3@gmail.com> Thu, 26 Apr 2007 21:33:21 +0200

    Progressive should look better than interlaced. Be sure to apply an ivtc filter. Most NTSC television shows/movies need this.

    As for sync issues, if it's a constant sync timing you should be able to adjust it in the mencoder command line. Or use mpgtx -d to demultiplex the streams and encode separately, using the -audiofile switch to add your audio file. I usually encode/edit my audio separately outside of mencoder and pass -audiofile -oac copy.

    It can be convoluted to get it to work correctly, but once it's figured out, Nautilus scripts are life savers.

    Also check out www.doom9.org's Linux forum. There are some real mencoder guru's over there. Poke around the gentoo wiki's as well.
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  15. Hi everybody!

    I have the same problem as n8gray: I can't get my self-encoded files to play on my standalone DivX-certified DVD player. I followed FulciLives' small tutorial for setting up AviDemux for the encoding process. But the encoded files just won't play.

    After numerous tests and comparisons I think it might be because of the AVI-container (everything else corresponds according to GSpot). Files using the OpenDML AVI v2.0 contaier (which I didn't encode myself) play fine. However the files encoded with AviDemux use the AVI v1.0 container and don't play at all.

    Is there a way to setup AviDemux so that it uses OpenDML AVI v2.0 for the output? Or can you guys suggest another solution for fixing this problem?
    Quote Quote  
  16. Originally Posted by acid_burn
    Is there a way to setup AviDemux so that it uses OpenDML AVI v2.0 for the output? Or can you guys suggest another solution for fixing this problem?
    I hadn't noticed that before. I tried setting Edit -> Preferences -> Output -> Create ODML files... but it didn't make any difference. I did quick remux of AviDemux's output with VirtualDub and that made a ODML 2.0 file.
    Quote Quote  
  17. Originally Posted by jagabo
    I hadn't noticed that before. I tried setting Edit -> Preferences -> Output -> Create ODML files... but it didn't make any difference.
    Yeah, I tried that before posting here. But it didn't do any good for me either....

    Originally Posted by jagabo
    I did quick remux of AviDemux's output with VirtualDub and that made a ODML 2.0 file.
    Cool! I just tried that and the resulting file works like a charm on my standalone player. Thanx for helping!

    If anyone knows how to set up AviDemux to output directly to OpenDML AVI v2.0 I'd appreciate a link or something....
    Quote Quote  
  18. Member FulciLives's Avatar
    Join Date
    May 2003
    Location
    Pittsburgh, PA in the USA
    Search Comp PM
    Originally Posted by jagabo
    Originally Posted by acid_burn
    Is there a way to setup AviDemux so that it uses OpenDML AVI v2.0 for the output? Or can you guys suggest another solution for fixing this problem?
    I hadn't noticed that before. I tried setting Edit -> Preferences -> Output -> Create ODML files... but it didn't make any difference. I did quick remux of AviDemux's output with VirtualDub and that made a ODML 2.0 file.
    Is this as simple as loading the AVI into VirtualDub and simply saving it again to a new file using Direct Stream Mode?

    - John "FulciLives" Coleman
    "The eyes are the first thing that you have to destroy ... because they have seen too many bad things" - Lucio Fulci
    EXPLORE THE FILMS OF LUCIO FULCI - THE MAESTRO OF GORE
    Quote Quote  
  19. Originally Posted by FulciLives
    Originally Posted by jagabo
    Originally Posted by acid_burn
    Is there a way to setup AviDemux so that it uses OpenDML AVI v2.0 for the output? Or can you guys suggest another solution for fixing this problem?
    I hadn't noticed that before. I tried setting Edit -> Preferences -> Output -> Create ODML files... but it didn't make any difference. I did quick remux of AviDemux's output with VirtualDub and that made a ODML 2.0 file.
    Is this as simple as loading the AVI into VirtualDub and simply saving it again to a new file using Direct Stream Mode?

    - John "FulciLives" Coleman
    Yes.... or at least that's what I did. After that GSpot showed "OpenDML AVI v2.0" instead of "AVI v1.0" and the video-file played fine.
    Quote Quote  
  20. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    A dixv certified player will support avi 1.0 before it would support opendml 2.0. Opendml was appended to the avi standard to allow files larger than 2gig to be created. Since Divx certified players only support fat file systems, any file is limited to 2gig max size, even then, most players have issues with files over 1024mb in size, which negates the reason to need opendml 2.0 specification.

    Either you have a divx compatible player and are creating files over 2gig in size, or, virtual dub is doing something else to the stream.

    No matter, here's how to change the settings in Avidemux.


    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  21. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    FYI, here's the script I settled on to transcode 720p to 480i. (Yes, interlaced -- my TV has no progressive input anyway.) I copy the AC3 audio stream from the ATSC broadcast instead of transcoding to mp3. I get no problems with audio sync and the action is almost entirely smooth except for a stutter or jump every so often. The results work well on my divx dvd player, but it might not be the best solution for other folks who don't want interlaced output:

    Code:
    #!/bin/zsh
    
    # TODO: Automatically crop any black borders
    
    # From http://archives.free.net.ph/message/20080125.083638.b9df21a6.en.html
    # This is the proper way to interlace progressive video
    
    # These affect the quality/size/time tradeoffs
    qualityopts=bitrate=1800:hq_ac:vhq=2:bvhq=1:chroma_me:chroma_opt:trellis:quant_type=mpeg:closed_gop:profile=dxnhtntsc
    
    # The width of the output.  The height will be scaled to preserve aspect ratio
    width=640
    
    passfile=`mktemp -t tcode-XXXXXX` || exit 1
    {
        runpass () {
            mencoder -ovc xvid -fps 60000/1001 -ffourcc DX50 -ofps 30000/1001 \
              -vf scale=$width:-11,harddup,phase=t,tinterlace=2 \
              -xvidencopts interlacing:$3 \
              -oac copy -passlogfile $passfile \
              $1 -o $2
        }  
    
        echo "######################## First Pass ###################################"
        time runpass $1 /dev/null pass=1:turbo:$qualityopts
    
        echo "######################## Second Pass ##################################"
        time runpass $1 $2 pass=2:$qualityopts
    } always {  
        rm -f $passfile
    }
    Quote Quote  
  22. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by disturbed1
    A dixv certified player will support avi 1.0 before it would support opendml 2.0. Opendml was appended to the avi standard to allow files larger than 2gig to be created. Since Divx certified players only support fat file systems, any file is limited to 2gig max size, even then, most players have issues with files over 1024mb in size, which negates the reason to need opendml 2.0 specification.
    A minor correction: FAT32 has a 4GB file size limit, not 2GB. I've recently put video files over 2GB on my fat-formatted ipod for playing on my divx player. They didn't work because the *player* has a 2GB limit, but the filesystem has no problem with them. And my player has no problem with files over 1GB. (Pioneer DV-400V)
    Quote Quote  
  23. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    Originally Posted by n8gray
    Originally Posted by disturbed1
    A dixv certified player will support avi 1.0 before it would support opendml 2.0. Opendml was appended to the avi standard to allow files larger than 2gig to be created. Since Divx certified players only support fat file systems, any file is limited to 2gig max size, even then, most players have issues with files over 1024mb in size, which negates the reason to need opendml 2.0 specification.
    A minor correction: FAT32 has a 4GB file size limit, not 2GB. I've recently put video files over 2GB on my fat-formatted ipod for playing on my divx player. They didn't work because the *player* has a 2GB limit, but the filesystem has no problem with them. And my player has no problem with files over 1GB. (Pioneer DV-400V)
    I didn't say FAT32 .

    Your Pioneer playing 2gb files is a player feature, not a specification. Which was only recently added with a new firmware upgrade

    Because my player plays 540x480 mpeg2 authored as a DVD, does that mean it's in the DVD specification?
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  24. @disturbed1

    Hi,

    my player is divx certified for sure - it has that divx-certified-logo on it as well as in the manual and on the package. As for the file size: my videos are about 300 to 400 MB in size. For testing purposes I used small parts of the files only (about 20 MB).

    I did find that OpenDML-setting in AviDemux but - as I posted above - the outcome was still an AVI v1.0 container and the file wouldn't play.

    I'm not saying my player is dependet on ODML AVI v2.0 containers. But I assumed that would be the case since these were the only type of files that I got to play on it. As you said, it might very well be that VirtualDub is altering the stream in one way or another but the only difference I noticed in GSpot was the container version.
    Quote Quote  
  25. Try taking one of your small ODML 2.0 files and remuxing (video and audio in Direct Stream COpy mode) with VirtualDub using File -> Save old format AVI... That will create a AVI 1.0 container instead. If that plays in your player then it's not a matter of AVI 1.0 vs ODML 2.0.

    I did find that AviDemux will use ODML if the file is large. I used a 5 GB DV AVI file as a test. It created a file in 5 ODML segments.
    Quote Quote  
  26. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    Originally Posted by disturbed1
    I didn't say FAT32 .
    Ok, I guess you said "fat file sysems":

    Originally Posted by disturbed1
    Since Divx certified players only support fat file systems, any file is limited to 2gig max size...
    To me that implies FATXX for any valid XX. I just wanted to make sure nobody came to the wrong conclusion.

    Your Pioneer playing 2gb files is a player feature, not a specification. Which was only recently added with a new firmware upgrade

    Because my player plays 540x480 mpeg2 authored as a DVD, does that mean it's in the DVD specification?
    My entire point was that it is possible to put files larger than 2GB on a FAT filesystem. The bit about my player was just extra info for anybody with the same player, not a challenge to anything you said.
    Quote Quote  
  27. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    Originally Posted by n8gray

    My entire point was that it is possible to put files larger than 2GB on a FAT filesystem. The bit about my player was just extra info for anybody with the same player, not a challenge to anything you said.
    I know it wasn't

    The thing is, if you want to make a DVD that plays on all DVD players, you stick to common specs. If you're making something for your player, then you do what it does best.

    Same for xvid playback on stand alones. If people go around saying make them open DML 2.0 and 1.5 gig in size for play back, I have 3 players that will choke on the files (Philips, Toshiba, and Cyberhome). There are also STBs that support usb keys and usb drives, but not formated to FAT32, only FAT16. You happen to own a player made by people with a brain, if only all manufacturers could think the same way.

    OpenDML 2.0 or AVI 1.0 muxing profile should not make a difference if the file is under 1024 in size. If it's larger than 1024 in size, you'll need the open dml 2.0 profile to write the new riff chunk at the 1gig mark.

    acid_burn,
    Give jagabo advice a try. This will determine if Avidemux did something to the file that Virtual Dub needs to fix. I stated earlier in the thread that I was never able to get Avidemux enocde a usable file for my stand alones. It will split/remux them just fine though.
    https://forum.videohelp.com/topic339594.html


    What DVD player are you using by the way?

    Avidemux will not create an Open DML 2.0 file if it is smaller than 1024mb, as there is no reason to use Open DML 2.0.
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  28. Hey guys, thanx for your replies!

    I tried jagabo's advice and the video played just fine - with an AVI v1.0 container! So there must be something that AviDemux messes up and VirtualDub fixes by default. There is also a slight change in filesize around 2KB (don't know whether that matters).

    My DVD player is a Philips DVDR3577H.


    Oh well, I guess I'll have to use both programs in combination then or stick with VirtualDub.
    Quote Quote  
  29. Get Slack disturbed1's Avatar
    Join Date
    Apr 2001
    Location
    init 4
    Search Comp PM
    With Avidemux, check these options. Create an unpacked bitstream, never packed, and for format, choose AVI. Just plain AVI, not avi-unpacked, or anything else. See if that makes a difference.
    Linux _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
    Quote Quote  
  30. Originally Posted by disturbed1
    With Avidemux, check these options. Create an unpacked bitstream, never packed, and for format, choose AVI. Just plain AVI, not avi-unpacked, or anything else. See if that makes a difference.
    If by "unpacked bitstream" you mean clearing the checkbox on the main-tab of the codec-configuaration-dialog then that's what I tried. FulciLives suggested that above - see his screenshots. It didn't work out for me....
    Quote Quote  



Similar Threads