VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Member Greycat's Avatar
    Join Date
    Aug 2002
    Location
    Brazil
    Search Comp PM
    I'm having a severe problem trying to convert a VCD to DVD.
    First of all, the VCD plays absolutely perfect on any player I put it in, so I think the video files burned on it have no problem whatsoever. Then I:

    1) Rip the DAT file(s) to my HD using ISOBuster ("Extract but filter only M2F2 Mpg frames");
    2) Demux the resulting DAT file(s) to .m1v and .mp2 files using TMPEGEnc's "MPEG Tools";
    3) Convert the audio file from .mp2 (44KHz) to .ac3 (48KHz) using ffmpeg gui;
    4) Remux .m1v and .ac3 using mplex.exe (or just open them into an authoring software like GfD)
    (here, a lot of "audio sector out of range" warnings appear during the muxing process).

    I tested either playing the MPEG files on my PC with PowerDVD, WMP and MPClassic, or
    burning a DVD-RW and playing it either on the PC or on standalone players and the results
    are always the same: "jumpy" or "skippy" playback in certain parts of the movie.

    I noticed that if the MPEG-1 is 29.97 fps (VCD-video) there is no problem. Only
    23.976 fps videos (VCD-film) produce this problem after the convertion. Also, if the video
    is not too long (say 5-10 minutes) there is no time for skipping problems. Longer
    videos (say 15+ minutes) show skipping problems from time to time.
    I've searched this forum for "audio sector out of range" posts and found that maybe
    it's a missing pulldown flag problem after the demuxing. But I didn't find any
    tool that allows me to change pulldown flags of MPEG-1 files (if this is
    possible with VCD files). Just to see what'd happen, I used DGPulldown (which is intended
    for MPEG-2 I think) on my MPEG-1 files and it changed the framerate to 29.97, but then the
    movie plays accelerated and out-of-sync with the audio. It seems that DGPulldown just raised
    the framerate instead of setting the pulldown flag (maybe because you can't set pulldown flags
    of VCD MPEG-1 files?)

    Any suggestion (except re-encoding the video stream) will be very appreciated.
    -- Greycat.
    Quote Quote  
  2. Banned
    Join Date
    Jun 2007
    Location
    UNREACHABLE
    Search Comp PM
    It seems mpeg-1 video with pulldown-flags really does not work at all on
    most(all?) software/hardware players Certainly it does not work for
    VCD-structured stuff @ my LG DVD-Player. I'm afraid re-encoding is
    inevitable in cases like yours. HTH.

    P.S.: This is just a guess --- perhaps part of the trouble is in the
    mixture "m1v + ac3". Give a try to 48kHz mp2 and check if it works better.
    Quote Quote  
  3. Banned
    Join Date
    Oct 2004
    Location
    Freedonia
    Search Comp PM
    I have been able to successfully burn MPEG-1 video to DVD using Scenarist 3.0. It's the only tool at my disposal that worked. GuiForDVDAuthor doesn't work for me due to DLL hell that I'm too lazy to try to fix.

    I was able to use AC3 audio (2 channel) with no problems. My video was 29.97 fps. I don't think it's possible to use 23.976 fps MPEG-1 video in DVD. I haven't seen it officially listed as forbidden, but I seem to recall trying to use some in another project and Scenarist did not like it at all.
    Quote Quote  
  4. Member Greycat's Avatar
    Join Date
    Aug 2002
    Location
    Brazil
    Search Comp PM
    Thanks, Midzuki. I'll give it a try -- although I read somewhere that DVD's require at least one AC3 track to work properly.
    -- Greycat.
    Quote Quote  
  5. Member Greycat's Avatar
    Join Date
    Aug 2002
    Location
    Brazil
    Search Comp PM
    Midzuki, using 48KHz mp2 audio instead of ac3 didn't work.
    As jman98 posted, and unless another good soul comes up here with a solution, I'm inclined to accept that 23.976 fps MPEG-1 files can't be used to author DVD's without re-encoding the video stream (which I already tried and I really didn't like the quality of the resulting image even using higher bitrates.

    Thanks anyway.
    -- Greycat.
    Quote Quote  
  6. Member AlanHK's Avatar
    Join Date
    Apr 2006
    Location
    Hong Kong
    Search Comp PM
    I had exactly this problem a while ago. Pulldown does not work on MPEG1.
    However, I did not have any playback problems, using MPEG1 at 23.976 fps, MP2 audio at 224k sampled to 48000 with Besweet, authored with GfD. The only oddity were the chapter points and the time indicator on the player was way off, though it played at the correct speed.

    I've done this on at least two different VCD movies, split over 3 CDs, to make a single 100+ minute DVD title.
    I joined MPEG1 files into one file for each movie with TMPGEnc.

    Perhaps just saving the MPEG through TMPGEnc's "Merge and Cut" tools, using "Correct" will help.

    Also VCDGear has some functions, including "mpeg -> mpeg" with an option to "fix MPEG errors". (This is also a good tool to extract MPEG from VCDs to begin with.)
    Quote Quote  
  7. Member Greycat's Avatar
    Join Date
    Aug 2002
    Location
    Brazil
    Search Comp PM
    Well, I tried all the suggestions made and none of them worked. The converted movie plays "jumpy" from time to time and REW/FF sometimes work, sometime freeze the movie or produce audio sync issues.
    I'll give up since this thing is giving me headaches by now!

    Thanks everybody who have replied!
    -- Greycat.
    Quote Quote  



Similar Threads