VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    Hi,

    MODS: I didn't put this in the Linux forum because I thought it might be a general Video card issue, move it at your discretion.

    I recently upgraded my htpc to a Nvidia GeForce FX-5500 Video card so as well as watch movies the family could also play some games on the TV. I have several MPEG-4 and H.264 files that were on the htpc prior to changing the Vid card, I should make it clear that these files are all fine and played back flawlessly with the original Video card. When I watch these movies now I am seeing the same symptoms in 4 different software players, The playback is smooth but when there are wide pans and fast action sequences the picture will "slice" horizontally into 2 or three sections and the picture will become misaligned at the slices for a brief second and then be fine in slower sequences. I am using openSUSE Linux 10.3 for the operating system, and before the Linux slagging begins it was also fine prior to the card change. The Nvidia drivers are installed and the Compiz 3D Desktop works flawlessly, as do the games I'm playing. I am using VLC, SMPlayer, Totem (Xine) and Kaffeine and seeing the same problem with all, this is leading me to wonder if it is an overlay issue of some kind. If anyone could tell me of a similar experience or what the underlying causes of the "slicing" could be I would really apppreciate it. Thanks
    Quote Quote  
  2. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    You may be able to diagnose it as an overlay problem by reducing your hardware acceleration. Not sure where that's at in Linux, but in your video card settings there should be a slider where you can change it. Drop it down to about 1/4 to 1/3 and see if you still have the same issues.

    I have seen a 'tearing' effect in the past, but I don't remember the cure, though I think it was driver related, maybe a timing issue.

    It sounds like a driver issue, though. Did you get your video drivers from the video card manufacturer? If so, you might go to Nvidia and see if they have newer or different drivers for the card (Chipset). Often the manufacturer has older drivers on their site than the chipset manufacturer. Or it might even be a case where an older driver may work better. If you are using Nvidia chipset drivers, then try the card manufacturers drivers.

    I had problems with the card manufacturers Vista drivers for one of my video cards, but the Nvidia chipset drivers worked fine.
    Quote Quote  
  3. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Sounds like tearing, ?

    Try google it for tips. And I have also had such problems but I don't know what I did to solve it....
    Quote Quote  
  4. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    OK,
    Ahhh yes "tearing" is a much better word, and that is exactly what we're talking about. Thanks for the hints although it would seem that the solution to the problem is accompanied by some sort of Amnesia which causes the solution to be forgotten!?

    Nvidia has made it's driver source code available to Linux developers so the resulting drivers probably differ somewhat from their Windows counterparts, however I have the latest driver available for this distro of Linux. I will see if it's related to the 3D Acceleration, Thanks
    Quote Quote  
  5. Look for a "switch on vertical blank only" setting. AKA Vertical Sync, etc.

    The cause of this is simple: the video data is changing while the graphics card is drawing the frame. This typically happens with double or tripple buffering. The graphics card has finished drawing a new frame of video and switches from the old frame to the new one before the old one has finished displaying. The result is that the top part of the screen is the old frame and the bottom part is the new frame. If there's any motion you'll see a tear. The solution is to force the video card to wait until the next vertical refresh period before switching.
    Quote Quote  
  6. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    jagabo,

    Thanks a lot, I'll look into the driver config utility and see if I can find something like that, I'll post back if it works so others can benefit. Thanks Again!
    Quote Quote  
  7. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    OK,
    Hmmm, Found an option to "Sync to VBlank" checked it off but it seems to have no effect, still tearing. I have a dual-boot with XP on another box with the same model Video card, maybe I'll see if the tearing is evident in XP.
    Quote Quote  
  8. Do you have Video Overlay enabled? If Video Overlay is disabled video has to be copied to the desktop for display. That can result in tearing. Overlay needs to be enabled in the video drivers and the player application.

    In VLC you can check:

    Settings -> Preferences -> Video. Overlay Video output should be enabled.

    Settings -> Preferences -> Video -> Output Modules -> Video Output Mode (enable Advanced Options at the bottom right of the dialog). Try different options. Especially Default, and DirectX.

    Settings -> Preferences -> Video -> Output Modules -> DirectX. Make sure Use Hardware YUV->RGB conversions is enabled. Try changing the Tripple Buffering setting. The other settings too.

    Changes in VLC may not take place until you stop and restart playback. You may even need to exit the player and restart it.
    Quote Quote  
  9. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    jagabo,

    Thanks for the further help, The interesting thing is that this problem doesn't occur in Windows. I tried changing the overlays in openSUSE and although I was able to view the movies in a couple of different overlays the tearing was still evident, The compiz 3D desktop is really just eye candy so I am going to try and uninstall it, and perhaps the proprietary Nvidia driver and see what happens. It's funny I couldn't get 3D or game with my crappy old ATI AIW 128 pro that was installed in the first place but the video playback was flawless. Thanks Again.
    Quote Quote  
  10. Member GMaq's Avatar
    Join Date
    Mar 2004
    Location
    Canada
    Search Comp PM
    OK,
    Uninstalled Compiz, no difference so Compiz isn't the culprit. Uninstalled the Linux Nvidia driver and presto! no tearing. It is the driver at fault, but now I get no 3D so I'm back at square one !.
    Quote Quote  



Similar Threads